none
Mscaptcha não aprece qdo publico RRS feed

  • Discussão Geral

  • Tenho uma aplicação onde tenho que colocar um captcha, achei alguns tutoriais sobre o mscaptcha e foi o único gratuito que conseguir colocar na imagem somente números, bem localmente tudo funciona perfeito, mais quando publico a imagem não aparece.

    alguém já passou por isso ?


    Junior

    sexta-feira, 29 de setembro de 2017 18:49

Todas as Respostas

  • Boa tarde,

    Precisa verificar se o servidor de hospedagem não está bloqueando a saída externa.
    Tente també dar um F12 na página e verifica se todos os arquivos js foram carregados corretamente.

    Eu utilizo o Google reCAPTCHA, nunca tive esse problema.

    Att,


    Se a resposta contribuiu com seu aprendizado por favor marque como util, se solucionou seu problema marque como resposta.

    sexta-feira, 29 de setembro de 2017 18:54
  • Eu também estava usando o recaptcha e não tive problemas, tive que mudar exatamente pq não conseguir fazer com que ele mostrasse somente números, por isso mudei para o mscaptcha.

    Junior

    sexta-feira, 29 de setembro de 2017 18:56
  • Depois de pesquisar, achei a solução

    no webcofing faça isso

    <httpHandlers>
      <add verb="GET" path="CaptchaImage.axd" type="MSCaptcha.CaptchaImageHandler, MSCaptcha" />
    
    </httpHandlers>
    
    <handlers>
     <add name="MSCaptcha" path="CaptchaImage.axd" verb="*" type="MSCaptcha.CaptchaImageHandler" resourceType="Unspecified" preCondition="integratedMode" />
    
    </handlers>
    
    <location path="CaptchaImage.axd">
        <system.web>
          <authorization>
            <allow users="*" />
          </authorization>
        </system.web>
      </location>


    Junior

    segunda-feira, 2 de outubro de 2017 19:11