none
problemas com combobox RRS feed

  • Pergunta

  • Boa tarde, 

    tenho um form com dois panels sendo que o primeiro faz a inserção de um cadastro de grupos e o segundo faz o relacionamento entre estes grupos e maquinas . neste segundo panel as informações vem através de combobox tanto p grupo quanto para maquinas.

    O problema e que quando faço a inseção dos grupos no primeiro panel, quando abro o segundo este grupo novo nunca esta la na combo box do segundo panel de relacionamento. Tenho que fechar o form e abrir de novo só assim o novo grupo estará la na combo box.

    Alguém poderia me socorrer!! Obrigado.

    O codigo da combobox de grupos e esse

     public void Carrega_CbGrupo()
            {

                Connection con1 = new Connection();
                string strSql = "SELECT id_grupo,nome_grupo from grupos where id_grupo = id_grupo";
                SqlCommand cmd = new SqlCommand(strSql, con1.cone());
                //     con1.cone().Open();
                SqlDataReader dr = cmd.ExecuteReader();
                DataTable dt = new DataTable();
                dt.Load(dr);
                cbGrupo.ValueMember = "id_grupo";
                cbGrupo.DisplayMember = "nome_grupo";
                cbGrupo.DataSource = dt;
                carregaGrupos();

            }
    quarta-feira, 28 de junho de 2017 19:01

Respostas

  • Bom dia,

     pelo que entendi você deve chamar novamente o método que carrega a combo para buscar os dados atualizados no banco de dados após cadastrar um grupo.

    • Marcado como Resposta Felipe1520 quinta-feira, 29 de junho de 2017 18:51
    quinta-feira, 29 de junho de 2017 11:47

Todas as Respostas

  • Bom dia,

     pelo que entendi você deve chamar novamente o método que carrega a combo para buscar os dados atualizados no banco de dados após cadastrar um grupo.

    • Marcado como Resposta Felipe1520 quinta-feira, 29 de junho de 2017 18:51
    quinta-feira, 29 de junho de 2017 11:47
  • OI Boa tarde,

    entao eu fiz isso, mas nao funciona!

    quinta-feira, 29 de junho de 2017 18:20
  • Boa tarde, Felipe1520.

    Tudo bem com você?

    Você disse que não funciona, mas depois marcou como resposta. Poderia dizer se funcionou ou não?

    Queremos te ajudar.

    Atenciosamente,


    Filipe B de Castro

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    sexta-feira, 30 de junho de 2017 14:04
    Moderador