locked
Soma condicional RRS feed

  • Pergunta

  • Olá pessoal, gostaria de uma ajuda para solucionar um problema que estou me deparando no excel 2003. Eu tenho uma planilha com uma coluna de datas e outra coluna de status. Gostaria de uma fórmula que somasse a quantidade de status dentro de um mês específico. Segue abaixo uma planilha que tentei fazer, porém quando eu aplico a fórmula em toda coluna aparece o ERRO #NÚM!

    Data Implantação Status Erro ocorre quando é selecionado toda coluna
    25/01/2010 dentro   Jan Fev Mar Abr Mai Jun Jul Ago Set Out Nov Dez
    02/07/2010 dentro Dentro #NÚM! #NÚM! #NÚM! #NÚM! #NÚM! #NÚM! #NÚM! #NÚM! #NÚM! #NÚM! #NÚM! #NÚM!
    03/06/2010 dentro Fora #NÚM! #NÚM! #NÚM! #NÚM! #NÚM! #NÚM! #NÚM! #NÚM! #NÚM! #NÚM! #NÚM! #NÚM!
    02/07/2010 dentro
    12/07/2010 fora
    10/07/2010 dentro
    09/07/2010 fora
    12/07/2010 dentro
    29/07/2010 dentro Fórmula tem o resultado, mas não seleciona toda coluna
    01/03/2010 fora   Jan Fev Mar Abr Mai Jun Jul Ago Set Out Nov Dez
    29/07/2010 dentro Dentro 1 0 0 0 0 1 7 0 0 0 0 0
    29/07/2010 dentro Fora 0 0 1 0 0 0 2 0 0 0 0 0

     

     

    quarta-feira, 11 de agosto de 2010 14:03

Todas as Respostas

  • Fantos boa noite

    Tente com o somarproduto

    =SOMARPRODUTO((B1:B15="dentro")*1)

    Qualquer coisa poste ai

    Atenciosamente


    Bruno Silva Leite Office Developer
    quarta-feira, 11 de agosto de 2010 23:27
  • Bruno,

              Tentei aplicar a fórmula que vc indicou e não consegui. Quando eu uso a fórmula =SOMARPRODUTO(($L$2:$L$65536=Q$21)*(TEXTO($J$2:$J$65536;"mmm")=P22)) em uma planilha eu consigo obter o resultado, mas quando eu altero o intervalo para selecionar toda coluna conforme a fórmula =SOMARPRODUTO(($L:$L=Q$21)*(TEXTO($J:$J;"mmm")=P22)) é apresentado o erro #NÚM! .

     

    Obs.: Eu estou utilizando o excel 2003 e ao final das fórmulas pressiono SHIFT + CTRL + ENTER.

    sexta-feira, 13 de agosto de 2010 14:21
  • Fsantos, o SomarProduto, não aceita uma coluna inteira como intervalo, vocês pode usar por exemplo A1:A65536, que deve te atender
    Esta fórmula não tem necessidade do shift+ctrl+ enter( matricial) ela funciona corretamente sem isto.

    teste ai e qqer coisa fale

    Att
    Bruno Silva Leite Office Developer
    sexta-feira, 13 de agosto de 2010 23:40
  • Fsantos, bom dia!
    Espero que tenha resolvido seu problema, mas caso não tenha, segue minha sugestão
    Crie duas chaves, em uma concatene o mês com o status e na outra sempre acrescente o numero 1 e arraste até o fim dos dados correspondente
    Escreva 1 no lugar de jan e assim por diante.
    Agora é só utilizar o samase com concatenar
    exemplo: somase($C:$C;F$2&$E3;$D:$D)
    A B C D E  F G H I J K L M N O  P Q
    Data Implantação Status Erro ocorre quando é selecionado toda coluna
    24/1/10 dentro mês(a2)&b2 1
    25/1/10 dentro 1dentro 1 1 2 3 4 5 6 7 8 9 10 11 12
    2/7/10 dentro 7dentro 1 Dentro 1 0 0 0 0 1 7 0 0 0 0 0
    3/6/10 dentro 6dentro 1 Fora 0 0 1 0 0 0 2 0 0 0 0 0
    2/7/10 dentro 7dentro 1
    12/7/10 fora 7fora 1
    10/7/10 dentro 7dentro 1
    9/7/10 fora 7fora 1
    12/7/10 dentro 7dentro 1
    29/7/10 dentro 7dentro 1 Fórmula tem o resultado, mas não seleciona toda coluna
    1/3/10 fora 3fora 1 Jan Fev Mar Abr Mai Jun Jul Ago Set Out Nov Dez
    29/7/10 dentro 7dentro 1 Dentro 1 0 0 0 0 1 7 0 0 0 0 0
    29/7/10 dentro 7dentro 1 Fora 0 0 1 0 0 0 2 0 0 0 0 0
                                     
    sábado, 14 de agosto de 2010 14:11