none
Demora na execução da aplicação. RRS feed

  • Pergunta

  • Pessoal.

    Estou com o seguinte problema.
    Tenho uma aplicação que executa umas tarefas bem pesadas, copia milhares de fotos, redimensiona as mesmas, renomeia, cria um pacotão ZIP com todas estas imagens e disponibiliza para download.

    Acontece o seguinte.
    As vezes, fica rodando, rodando, rodando e para mas não dá erro e também não finaliza o processo.
    As vezes funciona, as vezes não.
    Mas nunca dá uma mensagem de erro.
    Parece que o servidor "desiste" de executar no meio do caminho.

    Já tentei aumentar o timeout da aplicação, mas alguma coisa para que eu possa alterar na configuração para que funcione, ou ao menos dê uma mensagem de erro?

    Grato antecipadamente por qualquer auxílio.




    Notepad na mão e uma idéia na cabeça......Se foi útil, marca lá.... Me ajuda que eu marco também... heheheh

    segunda-feira, 3 de setembro de 2012 14:26

Todas as Respostas

  • Ja tentou colocar um breakpoint no evento application error do arquivo global.asax?
    segunda-feira, 3 de setembro de 2012 16:22
  • Obrigado Marcelo.

    Vou dar uma investigada nesse evento do global.asax




    Notepad na mão e uma idéia na cabeça......Se foi útil, marca lá.... Me ajuda que eu marco também... heheheh

    segunda-feira, 3 de setembro de 2012 16:44
  • Glauber, tenta colocar um trace para ver o que está ocorrendo, ou coloque um log com try catch que se der ex vc pega qual é o problema

    Não esqueça de usar o componente </> na barra para posta seu código. Microsoft MCPD,MCTS,MCC

    terça-feira, 4 de setembro de 2012 13:25
    Moderador