none
Procurar um maior valor em uma tabela RRS feed

  • Pergunta

  • Ola meu povo....

    Qual a formula para procurar o maior valor em uma tabela, apartir de uma referencia, por exemplo:

    Na célula(produtos) A1: A, A2: A, A3: B, A4: A, A5: B e A6: B

    Na célula(valores) B1: 5, B2: 8, B3: 2, B4: 3, B5: 6 e B6: 5.

    Agora eu gostaria de uma formula que me trouxesse o maior valor com referencia no produto "A", como faço isso?

    Erick Moura

    sexta-feira, 21 de outubro de 2011 20:35

Respostas

  • Erick,

    Se vc trocar as colunas de posição (os valores da coluna A vc coloca em B e os valores da coluna B vc coloca em A) vc poderá usar a Função Máximo dentro da Função PROCV. Por exemplo:

    Se a sua referência está na coluna C e os valores buscados estão na coluna B, a fórmula ficaria:

    PROCV(MÁXIMO(B1:B6),B1:C6,2,FALSO)

    Lembrando que esta fórmula te dirá o primeiro maior valor, de toda a matriz, que ele encontrar.
    Tiago Pratti
    sexta-feira, 18 de novembro de 2011 19:48

Todas as Respostas

  • Boa noite!!!

    Use a função =MAIOR(matriz;k)

    Qual quer dúvida veja aqui...http://excelgurueletronico.blogspot.com/

    Att..


    zinho
    terça-feira, 25 de outubro de 2011 21:22
  • Zinho, muito obrigado.

    Mas esta formula ela procura o primeiro, segundo, terceiro maior valor em uma matriz. Certamente o que estou querendo é que a formula me mostre o maior valor com referencia ao item A ou B.

    Erick 

    quarta-feira, 9 de novembro de 2011 19:09
  • Boa tarde Erick

    Vc poderá usar a fórmula Matricial  {=SE(A:A=D1;MÁXIMO(B:B);0)}

    Para a fórmula funcionar, nofinal em vez de tc ENTER tem que teclar CTRL+SHIFT+ENTER

    Baixe a planilha com o resultado esperado:

    http://www.sendspace.com/file/jzwh37

    Um abraço.

    quinta-feira, 10 de novembro de 2011 17:26
  • Erick,

    Se vc trocar as colunas de posição (os valores da coluna A vc coloca em B e os valores da coluna B vc coloca em A) vc poderá usar a Função Máximo dentro da Função PROCV. Por exemplo:

    Se a sua referência está na coluna C e os valores buscados estão na coluna B, a fórmula ficaria:

    PROCV(MÁXIMO(B1:B6),B1:C6,2,FALSO)

    Lembrando que esta fórmula te dirá o primeiro maior valor, de toda a matriz, que ele encontrar.
    Tiago Pratti
    sexta-feira, 18 de novembro de 2011 19:48