none
Direcionamento de Paginas no Servidor não está funcionando RRS feed

  • Pergunta

  • Olá pessoal,
    Estou enfrentando problemas com direcionamento de paginas ao publicar o site no servidor.

    No meu ambiente de desenvolvimento os links funciona normalmente.

    Estou utilizando o VS 2017 / ASPNET / Framework 4.5

    Neste novo framework percebi que na barra de endereço, não está mais aparecendo as extenção da pagina, sempre mostra somente o nome da pagina... exemplo...

    Antes era assim...
    http://localhost/site/empresa.aspx
    Agora está assim...
    http://localhost/site/empresa

    acessando no meu ambiente de desenvolvimento, mesmo acessando as paginas direto sem a extenção funciona, exemplo
    http://localhost/site/produtos
    http://localhost/site/contato

    Agora se eu usar a mesma forma de acessar as pagina depois de publicado no servidor, as paginas nao abre, dá erro de página nao encontrada, 404, tentei até mesmo com a extenção, mais nao abre, exemplo...

    http://meusite.com.br/produtos
    http://meusite.com.br/produtos.aspx

    Os Hiperlinks mesmo com respectivos links, tambem nao funciona no servidor, fiz até redirecionamento via código em um botao
    usando o Response.Redirect("produtos.aspx") e não funciona.

    Creio que tem alguma coisa haver com esta nova forma de acessar as paginas sem a extenção, se alguem puder me ajudar, agradeço!!!

    Att,
    Ednaldo Soares



    Att,
    Ednaldo Soares Garcia
    Programador .NET
    Sistemas Windows / WEB
    Acesse: www.ednaldosoares.hd1.com.br
    Frase: Honestidade, Humildade e Perseverança acima de tudo!!!

    sexta-feira, 1 de setembro de 2017 02:52

Respostas

  • Tire um screenshot mostrando a estrutura do seu projeto no Visual Studio e no IIS pra ficar um pouco mais fácil te ajudar.

    Juliano Nunes - http://linkedin.com/in/julianonunes

    Lembre-se de clicar em "Votar como útil" e "Marcar como Resposta" caso tenha respondido sua dúvida.

    Remember to "Vote as Helpful" and "Mark as Answer" if your question has been answered.

    domingo, 3 de setembro de 2017 01:44

Todas as Respostas

  • opa... nao estou usando MVC, estou usando webforms 

    Att,
    Ednaldo Soares Garcia
    Programador .NET
    Sistemas Windows / WEB
    Acesse: www.ednaldosoares.hd1.com.br
    Frase: Honestidade, Humildade e Perseverança acima de tudo!!!

    sábado, 2 de setembro de 2017 01:18
  • Tire um screenshot mostrando a estrutura do seu projeto no Visual Studio e no IIS pra ficar um pouco mais fácil te ajudar.

    Juliano Nunes - http://linkedin.com/in/julianonunes

    Lembre-se de clicar em "Votar como útil" e "Marcar como Resposta" caso tenha respondido sua dúvida.

    Remember to "Vote as Helpful" and "Mark as Answer" if your question has been answered.

    domingo, 3 de setembro de 2017 01:44
  • Boa tarde,

    Por falta de retorno, essa thread está sendo encerrada.

    Se necessário, favor abrir uma nova thread.

    Atenciosamente,


    Filipe B de Castro

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    terça-feira, 26 de setembro de 2017 13:49
    Moderador