none
Object reference not set to an instance of an object RRS feed

  • Pergunta

  • Oi pessoal,

     

    Estou c/ o seguinte problema. Meu sistema ta dando um erro esporadicamente qd estou inserindo um cadastro no banco de dados. O erro da no parametro userID (

    Membership.GetUser.ProviderUserKey).

     

    E o erro é o seguinte: "Object reference not set to an instance of an object".

     

    Alguém pode me ajudar por favor.

    quinta-feira, 12 de abril de 2007 17:45

Todas as Respostas

  • Daniela,

    Va em modo debug e verifique pq esse erro ocorre pq algum objeto que vc esta tentando usar esta nulo, ou seja, nao foi instanciado.



    Espero ter ajudado,

    []'s
    • Sugerido como Resposta Seratti sexta-feira, 15 de junho de 2012 16:29
    quinta-feira, 12 de abril de 2007 20:27
  • Foi o q fiz e coloquei no post. O erro ta dando no parametro userID (Membership.GetUser.ProviderUserKey).
    quinta-feira, 12 de abril de 2007 21:33
  • Daniela,

    Então esse objeto esta nulo verifique os metodos que o preenchem.

    []'s
    quinta-feira, 12 de abril de 2007 21:52
  • Oi Diego,

     

    Estou usando o membership provider do asp.net 2.0. Tem alguma ideia do q pode ser?

    sexta-feira, 13 de abril de 2007 15:03
  • Daniela,

    Mesmo o mermbership tem os metodos de login que devem carregar os dados que vc esta tentando usar verifique o processo como um todo e veja se tem falhas.



    []'s
    sábado, 14 de abril de 2007 14:03
  • A questão é q não sei o q está acontecendo pois não é sempre q da o erro. É esporadico e não estou sabendo o pq.
    sábado, 14 de abril de 2007 21:32
  • Estou com esse problema só que não é nas páginas do WebSite, estou usando o Visual Studio 2005 no Windows Vista, porém isso está acontecendo em um Dataset (Visual) ao Salvar, até ontem eu estava conseguindo alterar as tabelas e os adapters porém agora não consigo mais, uma coisa que eu consigo identificar é que as minhas alterações não estão sendo vinculadas com o .xss, aí quando eu salvo o dataset ele dá esta mensagem de erro.

     

    Se alguém tiver alguma idéia do que seja, por favor me ajude.


     

     

    quarta-feira, 22 de agosto de 2007 22:10
  • Olá...

    Já que vc esta utilizando o VS 2005, vc verificou se atualizou o Service Pack 1 e depois o Service Pack 1 para Windows Vista?

    São dois passos,  SP1 e SP1 para Vista.

    Você encontrará na parte de downloads da MS.

     

     

    Abraços.!

     

     

    segunda-feira, 9 de junho de 2008 19:00
  • Na hora  de instanciar a classe você pode ter errado como eu.

     

    O código cerro

    Dim (Nome do Objeto) As New (Nome da Classe)

     

    No meu caso eu estava botando

     

    Dim ObjCarro As CadCarro

     

    e o certo é:

     

    Dim ObjCarro as NEW CadCarro

    segunda-feira, 29 de novembro de 2010 19:58