locked
Erro ao tentar criar um projeto Windows Phone Application RRS feed

  • Pergunta

  • Boa tarde

    Instalei o sdk do windows phone ( 7.1 ). Ao abrir o visual studio 2010 Ultimate, o add-in está instalado. Para a criação de jogos, os templates de projetos estão entrando, porém quando tento entrar com um projeto do tipo: WINDOWS PHONE APPLICATION ou similar no menu: SILVERLIGHT FOR WINDOWS PHONE, me ocorre o seguinte erro:

    Unable to create the new project because some of the files are the incorrect version.
    to correct the problem, try to repair the Microsoft windows Phone Developer Tools.

    Alguém saberia como resolver este problema?

    Obrigado

    Junior

    quarta-feira, 4 de abril de 2012 16:45

Todas as Respostas

  • Bem, neste caso acho que o ideal mesmo seria reinstalar o SDK completo...

    E nada como fazer o download da versão mais recente neste momento (7.1.1)! :)


    Pedro Lamas
    DevScope | Senior Software Development Engineer & WP7 Development Speaker
    www.pedrolamas.com | @pedrolamas

    quarta-feira, 4 de abril de 2012 17:11
  • Só para reforçar o emulador não funciona no windows XP
    quarta-feira, 4 de abril de 2012 17:55
  • Olá Reuber

    Verifique se o SP1 do visual studio 2010 está instalado, se não estiver sugiro fazer a instalação.

    Em todo o caso, recomendo que você reistale o SDK do Windows Phone [ou baixe o SDK novamente].

    Download SDK

    Um abraço

    __________________________

    Thiago Oliveira Chaves

    @wp7boy

    www.windowsphone-dev.net

    quarta-feira, 4 de abril de 2012 22:12
  • Olá Pessoal

    Refiz todo o processo, reinstalei o sdk, baixei-o novamente, fiz a atualização do 7.1.1 e nada resolveu. Continua com o mesmo erro.

    Estou usando o Windows 7 (64), Visual Studio 2010 Ultimate com SP1 instalado.

    A única "coisa" que fiz de diferente, digamos assim, foi desinstalar o Visual Studio 11 Beta que havia instalado para testar. 

    Será que ficou alguma sujeira da desinstalação do VS11?

    quinta-feira, 5 de abril de 2012 12:32
  • Ok, agora tocaste no ponto fulcral: tinhas o VS11 e desinstalaste-o!

    Pessoalmente, quando instalei o VS11 junto com o meu Visual Studio 2010, tive vários problemas (ao ponto de não conseguir sequer compilar pequenos programas de consola!) e acabei por o desinstalar; escrevi mesmo um artigo sobre isso no meu blog!

    Mas depois de o desinstalar os problemas mantiveram-se (e de que maneira!) ao ponto que removi tudo o que se referia a .NET 4.5 do meu computador e forcei a reinstalação a .NET 4 e só aí ficou resolvido!


    Pedro Lamas
    DevScope | Senior Software Development Engineer & WP7 Development Speaker
    www.pedrolamas.com | @pedrolamas

    quinta-feira, 5 de abril de 2012 13:24
  • Olá Pedro Lamas

    Já desinstalei o Visual Studio, .Net 4. Fiz uma limpeza do registro e reinstalei os programas.

    Nada resolveu. Acho que vou ter que partir para uma formatação do computador. Lá vai 2 dias para reinstalar tudo. 

    sexta-feira, 6 de abril de 2012 10:06