none
Desenvolvo em .NET Framework 4.6...roda no 3.5 RRS feed

  • Discussão Geral

  • Bom dia Amigos!

    Estou saindo do mundo java desktop muito ralado, sofrido, rsss...e estou mergulhando de cabeça no C# para desktop...tenho uma duvida...instalei o visual studio 2017 comunnity e ele exigiu o .net 4.6...blz..se eu desenvolvo com essa versao 4.6, meu sistema vai rodar por exemplo num Win XP com .net 3.5? Ou seja, os recursos novos do 4.6 num vai rodar no anterior?

    Como seria isso?

    Rodrigo

    terça-feira, 1 de agosto de 2017 13:44

Todas as Respostas

  • Rodrigo

    Você vai ter de instalar o Framework do .NET  que voce desenvolver no visual studio 2017.

    Baixe o framework e tente instala-lo no windows xp. Se não rolar, acho que voce vai ter de usar .NET 4.0.

    Este eu sei que instala no XP.

    No momento de desenvolver no Visual studio, voce pode selecionar o .NET 4.0.

    Infelizmente, alguns recursos avançados você vai perder voltando o Framework. Analise se é mesmo necessário desenvolver para WIN XP.

    E vc vai ter de compilar  como  X86. -  propriedades do projeto - build - Plataform get:  X86

    terça-feira, 1 de agosto de 2017 17:05