none
Problema com SVG ! Bug do IE ou do Adobe Viewer ? RRS feed

  • Discussão Geral

  • Bom dia pessoal!

    Estou desenvolvendo uma aplicação de mapas e percebi que alguns elementos do tipo text estavam apresentando bordas (stroke) bemmm extensas. O estranho é que no mesmo "group" estão incluídos vários <text>'s e somente alguns deles apresentavam este problema. 

    Depois de alguns testes, percebi que somente aqueles que "encostavam" em uma determinada linha (imaginária) do SVG , apresentavam esse problema.

    Com isso, fiz o seguinte:

    <?xml version="1.0" standalone="no"?>
    <svg id="gwmroot" viewBox="0 0 28800 18000">
    <style type="text/css" id="gwmstyles">
    <![CDATA[
    .pracas
    {
          fill:#000000;
          stroke:red;
          font-size:310;
          font-family:Vedana;     
    }

    ]]>
    </style>
    <text class="pracas" x="15000" y="5231" startOffset="0">PC CEL FERNANDO PRESTES</text>
    </svg>


    Salvem esse arquivo com a extensão "SVG" e abram no Internet Explorer. Verão que o nome aparece corretamente. O problema é quando se muda a propriedade x de 15000 para 19000. O stroke fica "louco" e fica impossível de ler o texto. Se ao colocar os 19000 você retirar a propriedade "stroke" da classe "pracas" , verão que a palavra volta ao normal.

     

    Alguém já teve esse problema ? Conseguiram reprodizir o problema em seus computadores ?


    Michel Wilker Prado
    quarta-feira, 8 de abril de 2009 12:45

Todas as Respostas

  • Amigo, não consegui simular o seu problema, nenhuma formatação está sendo exibida.
    Murilo Maciel Curti (Shinji) Software Engineer Microsoft Brazil Windows International Team http://blogs.msdn.com/winbr - Windows Brazil Team Blog http://shinji360.spaces.live.com - Personal Blog
    terça-feira, 28 de abril de 2009 15:33
  • Olá!


    Você salvou o arquivo com extensão SVG e mandou abriu no Internet Explorer com o Adobe SVG Viewer instalado ?
    Michel Wilker Prado
    terça-feira, 28 de abril de 2009 21:39
  • Olá!


    Você salvou o arquivo com extensão SVG e mandou abriu no Internet Explorer com o Adobe SVG Viewer instalado ?
    Michel Wilker Prado

    Eu assumi o Internet Explorer sozinho para verificar o comportamento. Já que a visualização do arquivo depende de um visualizador adicional ao IE o problema provavelmente está com o visualizador que aparentemente não está compatível com a nova versão do Internet Explorer.

    Uma dos métodos pra testar possíveis problemas de compatibilidade no IE8 é executar ao IE que não carrega add-ons. Sendo assim será é bom verificar uma versão mais atualizada do svg viewer.

    Abraços
    Murilo Maciel Curti (Shinji) Software Engineer Microsoft Brazil Windows International Team http://blogs.msdn.com/winbr - Windows Brazil Team Blog http://shinji360.spaces.live.com - Personal Blog
    quinta-feira, 14 de maio de 2009 20:21
  • OI! estou tendo problemas com o SVG relativo ao site da Mitsubishi

    http://www.mitsubishicarbide.net/mmus/en/catalogue/index.html  Versão USA

    e

    http://www.mitsubishicarbide.net/EU/west/catalogue/index.html   Versão Européia

    Ambos estão apresentando erro no SVG e IEXPLORER , mas isso está acontecendo Aleatóriamente, ou seja, pode se navegar pelo Site por horas ou ja quando se abre a página

    Já fiz testes em Maquinas diferentes com WindowsXP Pro SP2, SP3 e Vista
    IE6 e o IE8 Ambos apresentam erro

    PRINT dos erros


    http://www.flickr.com/photos/41814762@N06/4090356212/sizes/o/



    http://www.flickr.com/photos/41814762@N06/4089592407/sizes/o/


    Alguem pode me ajudar?

    segunda-feira, 9 de novembro de 2009 18:05