locked
Compatibilidade entre o CE 3.5 e o Management Studio 2005 RRS feed

  • Pergunta

  • Srs... aqui na empresa nós usamos o SQLServer 2k5, e não temos nem previsão de mudar para o 2008.

    Só que começamos a desenvolver alguns prototipos em SQLServer CE 3.5... há alguma chance de ter compatibilidade entre o Management Studio 2005 no desktop e o CE 3.5?
    Tks. Fausto Fiorese Branco DBA - SQL Server 2k5 São Paulo - Brasil * http://dba-sqlserver.blogspot.com/
    sexta-feira, 21 de agosto de 2009 17:56

Todas as Respostas

  • Fausto,

    Você esta começando a utilizar o SQL Server Compact Edition 3.5 e pretende utilizar uma instância do SQL Server 2005 através do Management Studio para se conectar neste SQL Server CE?

    O SQL Server 2005 Express trabalha normalmente com o CE 3.5, inclusive tem suporte nativo a esta edição.
    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    sábado, 22 de agosto de 2009 01:20
    Moderador
  • Isso... Instalei o SQLServer CE 3.5 no meu celular que tem WM6. Pelo Query Analizer do CE eu crio um banco.

    Conecto meu celular na minha maquina, Active Sync funcionando, tudo certo. Pelo Management Studio do 2005 eu acho o banco que eu criei no PPC e na hora de abrir ele manda a mensagem:

    You are trying to access an older version of a SQLServer Everywhere database. If this is as SQL Server CEO 1.0 or 2.0, run upgrade.exe... bla bla bla [Db verion 3505053......]
    Tks. Fausto Fiorese Branco DBA - SQL Server 2k5 São Paulo - Brasil * http://dba-sqlserver.blogspot.com/
    segunda-feira, 24 de agosto de 2009 14:42
  • Olá Fausto,
    O SQL Server 2005 trabalha normalmente com o SQL Server CE 3.5, uma vez eu tb tive problemas para usar o SQL Server CE então eu usei o CEQuery para resolver o problema. Você pode, por exemplo, exportar o script SQL e rodar no Management Studio etc...
    Site do projeto:

    Espero ter ajudado.
    Abraços

    terça-feira, 19 de julho de 2011 18:36