none
Informar Login no Crystal Database RRS feed

  • Pergunta

  • Ae galera,

    Estou precisando de uma ajuda já procurei demais e nao encontro.

    Galera criei um la no crystal do vs 2008 ate ai tudo bem porém tinha que passar uns parametros e tinha que passar o usuario e senha executo compilo com o codigo abaixo quando instalo no meu computador funciona normalmente porém quando instalo em outro computador aparece uma tela pedindo usuario e senha.

     

     

    CrystalDecisions.CrystalReports.Engine.

    ReportDocument report = new CrystalDecisions.CrystalReports.Engine.ReportDocument();

     

     

    //report.Load(@"A:\_Homolog\Testar\TMOETIQUETAROTULAGEM\TMOROTULAGEM\TMOROTULAGEM\REL_HistoricoEtiquetaCorreto.rpt");

     

     

    report.Load(

    @"C:\SISTEMA DE TMO\Rel_EtqMedicamento.rpt");

    report.SetDatabaseLogon(

    "usuario", "senha","SERVER","DATABASE");

    CrystalDecisions.Shared.

    ParameterField param;

    param = report.ParameterFields[

    "id_med"];

    param.CurrentValues.AddValue(cod_id_med);

    crystalReportViewer1.ReportSource = report;

     

    //report.SetDatabaseLogon(user, senha);

     

     

    quarta-feira, 6 de outubro de 2010 12:20

Respostas

  • Cleiton,

    Você está pegando os dados do SQL Server? Você setou a datasource quando estava desenvolvendo o relatório, certo?

    Veja se você não utilizou o provider "SQL Server Native Client"... Ao invés dele, tente utilizar o "Microsoft OLEDB Provider for SQL Server"...


    André Alves de Lima
    Visite o meu site: http://andrealveslima.spaces.live.com
    Me siga no Twitter: @andrealveslima
    • Sugerido como Resposta AndreAlvesLimaModerator sexta-feira, 8 de outubro de 2010 00:38
    • Marcado como Resposta Novais quinta-feira, 21 de outubro de 2010 09:52
    quarta-feira, 6 de outubro de 2010 18:46
    Moderador

Todas as Respostas

  • Cleiton,

    Você está pegando os dados do SQL Server? Você setou a datasource quando estava desenvolvendo o relatório, certo?

    Veja se você não utilizou o provider "SQL Server Native Client"... Ao invés dele, tente utilizar o "Microsoft OLEDB Provider for SQL Server"...


    André Alves de Lima
    Visite o meu site: http://andrealveslima.spaces.live.com
    Me siga no Twitter: @andrealveslima
    • Sugerido como Resposta AndreAlvesLimaModerator sexta-feira, 8 de outubro de 2010 00:38
    • Marcado como Resposta Novais quinta-feira, 21 de outubro de 2010 09:52
    quarta-feira, 6 de outubro de 2010 18:46
    Moderador
  • _Olá Cleiton, 

      No momento de preencher o Dataset, vc deve escolherr o mesmo nome do DataTable que vc criou!

     Ex. 

    adapt.Fill(ds, "pagar")

     

    Qualquer dúvida poste aqui! 

    Abraço!

    quarta-feira, 13 de outubro de 2010 12:42
  • Ola galera,

    Desculpa pela demora da resposta mas efetuei o que o andre lima me falou estava usando o sql native client agora passei a usar o Sql provider sql.

     

    Att:

    Cleiton Novais

    quinta-feira, 21 de outubro de 2010 09:53