locked
PROCV ou Via Macro RRS feed

  • Pergunta

  • Galera...preciso de uma ajuda urgente....

     

    tenho duas planilhas (Plan1 e Plan2)

    ----------------------------------------------

    Na Plan1 tenho:

     

    Cod   Nome   Contrato

    1        A        ???

    2        B        ???

     

    -------------------------------------------

    Na Plan2 tenho:

     

    Cod   Contrato

    1       123

    2       321

    --------------------------------------------

     

    Preciso varrer a plan2 e verificar os cod que tem na 1 e na 2....se tiver na dois, trazer o contrato correspondente para a 1

     

    A planilha vai da linha 2 ate a 352

     

    Desde já agradeço.

     

    Obrigado.

    sábado, 26 de abril de 2008 17:18

Todas as Respostas

  •  

    Renato,

     

    A melhor solução neste caso, seria usar o procv pois no caso de uma macro, você depende de uma ação pessoal.

    No caso do PROCV, se houver uma alguma alteração será modificado simultaneamente.

     

    Cod   Nome   Contrato

    1        A        =procv(A2;Plan1!A1:B3;2)

    2        B        =procv(A3;Plan1!A1:B3;2)

     

    Indicação: Usa $ para fixar a matriz ....;Plan1!$A$1EmbarrassedB$3....

     

    Duvidas estou a disposição!!!!!

    Espero que assim resolva a sua necessidade, abraços!

     

    sábado, 26 de abril de 2008 20:34
  •  

    Fabio...tentei fazer isto mas não deu certo....
     
    Abusando um pouco da sua boa vontade...você pode dar uma olhada para mim?
     
    Segue o link:
     
     
    ou
     
     
     
    Desde já agradeço sua ajuda.
     
    Valeu!
    sábado, 26 de abril de 2008 20:50
  • Para a célula B2 da Plan2, use a função =SE(ÉERROS(ÍNDICE(Plan1!$A$1EmbarrassedA$352;CORRESP(A2;Plan1!$B$1EmbarrassedB$352;0)));"Não aparece em Plan1";ÍNDICE(Plan1!$A$1EmbarrassedA$352;CORRESP(A2;Plan1!$B$1EmbarrassedB$352;0))).

    Em seguida copie-a até a célula B104.

    [ ]s

    segunda-feira, 28 de abril de 2008 10:27