locked
Inicializar access 2007 sem menus RRS feed

  • Pergunta

  • Boa tarde,


    Estou com uma dúvida em um código. Estou tentando inicializar o access sem com comandos de menus existentes, ou seja, aparecer o access somente executando meu formulario sem nenhum menu.

    Porém esta aparecendo a aba do menu inicio (somente ele). Alguem poderia me ajudar a desabilita-lo.

    Abaixo o comando, obrigado,


    Dim Dbt As DAO.Database
        Set Dbt = DBEngine(0)(0)
        With Dbt
            .Properties("AppTitle") = "GBI - Sistema de Recomendação"
            .Properties("StartUpShowDBWindow") = False
            .Properties("AppIcon") = False
            .Properties("StartupShowDBWindow") = False
            .Properties("StartUpShowStatusBar") = False
            .Properties("StartupMenuBar") = False
            .Properties("AllowShortcutMenus") = False
            .Properties("AllowBuiltinToolbars") = False
            .Properties("AllowFullMenus") = False
            .Properties("AllowBuiltInToolbars") = False
            .Properties("AllowToolbarChanges") = False
            .Properties("AllowBreakIntoCode") = True
            .Properties("AllowSpecialKeys") = False

        End With
       
        Set Dbt = Nothing

    'Retira as Barras
    DoCmd.ShowToolbar "Banco de Dados", acToolbarNo
    DoCmd.ShowToolbar "Barra de Menus", acToolbarNo
    DoCmd.ShowToolbar "Barra de Formatação (formulário/relatório)", acToolbarNo
    DoCmd.ShowToolbar "Barra de Visualização", acToolbarNo
    'Maximiza a Janela

    DoCmd.Maximize

    sexta-feira, 19 de fevereiro de 2010 18:17

Respostas

Todas as Respostas

    • Marcado como Resposta cgteixeira_1980 segunda-feira, 29 de março de 2010 14:49
    sexta-feira, 19 de fevereiro de 2010 18:53
  • Em ferramentas / inicializar eu sempre seleciono o formulário que quero e desabilito todos os checkbox. A barra superior fica mas só com os comando basicões como imprimir, localizar, salvar, ajuda... Espero ter ajudado.


    Melhor que dar o peixe é ensinar a pescar

    Daniel Yamaguti
    Gerente de TI
    sábado, 20 de fevereiro de 2010 01:24