none
Preenchimento automático RRS feed

  • Pergunta

  • Amigos

    Bom dia !

    Acredito que minha dúvida seja simples, tenho uma tabela de eventos no Excel, e gostaria de preencher automaticamente as colunas "Disciplina, Categoria e Classificação" com base na descrição do evento.

    Exemplo:

    • Coluna K - "Descrição"
    • Coluna P - "Disciplina"
    • Coluna Q - "Categoria"
    • Coluna R - "Classificação"

    Quando o evento começar com "Falha", preencher na Classificação "Falha". 

    Quanto o evento conter uma palavra "Servidor", preencher na Categoria "Servidor".

    Tentei fazer utilizando alguns códigos que encontrei na internet, porém não estou conseguindo finaliza.

    Obrigado pelo apoio.

    Abraços

    Vitor



    quarta-feira, 1 de abril de 2015 12:24

Respostas

  • Vitor,

    precisa ser por VBA? Se for simples como os exemplos que passou funciona por fórmulas:

    Para Categoria:

    • =SE(NÃO(ÉERRO(PROCURAR("Servidor";$K2))); "Servidor"; SE(NÃO(ÉERRO(PROCURAR("Storage";$K2))); "Storage";"-"))

    Para Classificação:

    • =SE(NÃO(ÉERRO(PROCURAR("Falha";$K2)));"Falha";"-")

    Para Disciplina vc não disse o teste.

    Abraço.


    Filipe Magno

    quinta-feira, 2 de abril de 2015 22:28

Todas as Respostas

  • Amigos,

    Ate o momento, minha macro esta desta forma:

        

    "Sub PREENCHIMENTOV1()

    Set DESCFALHA1 = Range("K3")
    Set DISCIFALHA1 = Range("P3")
    Set CATFALHA1 = Range("Q3")
    Set CLASSIFALHA1 = Range("R3")

    If DESCFALHA1 = "Falha na comunicacao com o Servidor" Then

    DISCIFALHA1.Cells.Value = "Infra"
    CATFALHA1.Cells.Value = "Servidor"
    CLASSIFALHA1.Cells.Value = "Falha"

    End If

    End Sub"

    Não pesquisa no range, somente na célula definida. Além disso não consegui pesquisar pela expressão, somente pelo valor certo da descrição.

    Att

    Vitor


    quinta-feira, 2 de abril de 2015 11:46
  • Vitor,

    precisa ser por VBA? Se for simples como os exemplos que passou funciona por fórmulas:

    Para Categoria:

    • =SE(NÃO(ÉERRO(PROCURAR("Servidor";$K2))); "Servidor"; SE(NÃO(ÉERRO(PROCURAR("Storage";$K2))); "Storage";"-"))

    Para Classificação:

    • =SE(NÃO(ÉERRO(PROCURAR("Falha";$K2)));"Falha";"-")

    Para Disciplina vc não disse o teste.

    Abraço.


    Filipe Magno

    quinta-feira, 2 de abril de 2015 22:28
  • Filipe

    Obrigado pela dica. A formula que voce me passou ajuda, eu vou adapta-la para usar na Disciplina.

    A questão é que daqui a algum tempo, conforme o "banco de dados" de problemas irá crescendo, a o formula via ficar um pouco grande, nessa talvez eu tenha que utilizar literalmente um banco de dados para a consulta.

    De qualquer forma obrigado pela ajuda.

    Abraços

    Vitor

    terça-feira, 14 de abril de 2015 12:55