none
Google Co-op RRS feed

  • Pergunta

  • Olá,

     

    Estou trabalhando com o VS 2005 e C#. Coloquei o seguinte código gerado automáticamente pelo assistente do Google Co-op em uma página ASPX, tanto o código de pesquisa quanto o de resultado na mesma página .

     

    (Cole esse código na página onde deseja exibir sua caixa de pesquisa.)

     

    <form action="http://meudomino.com.br/resultados.aspx" id="cse-search-box">
      <div>
        <input type="hidden" name="cx" value="014318188132305645676:auoxn-jga18" />
        <input type="hidden" name="cof" value="FORID:11" />
        <input type="text" name="q" size="25" />
        <input type="submit" name="sa" value="Pesquisar" />
      </div>
    </form>
    <script type="text/javascript" src="http://www.google.com/coop/cse/brand?form=cse-search-box&lang=pt"></script>

    (Cole esse código no http://meudomino.com.br/resultados.aspx em que deseja que seus resultados de pesquisa sejam exibidos.)

     

    <div id="cse-search-results"></div>
    <script type="text/javascript">
      var googleSearchIframeName = "cse-search-results";
      var googleSearchFormName = "cse-search-box";
      var googleSearchFrameWidth = 600;
      var googleSearchDomain = "www.google.com";
      var googleSearchPath = "/cse";
    </script>
    <script type="text/javascript" src="http://www.google.com/afsonline/show_afs_search.js"></script>

     

    Porém eu digito um texto a ser pesquisado e simplesmente não aparece nenhum resultado. Se eu colocar esse código em uma página htm funciona. Mas mesmo na página htm não funciona como deveria porque se eu digitar um texto com acento não aparece nenhum resultado. O que devo fazer para conseguir exibir os resultados da pesquisa na minha página ASPX?

     

    Obrigado antecipadamente,

     

    CLA.

     

    PS. http://meudomino.com.br/resultados.aspx é fictício.

    quarta-feira, 21 de maio de 2008 19:23

Respostas

Todas as Respostas

  • Olá,

     

    Já encontrei a resposta para a minha dúvida, quem estiver com o mesmo problema pode consultar o link:

    http://www.codeproject.com/KB/aspnet/CustomSearchEngine.aspx

     

    CLA.

    quinta-feira, 22 de maio de 2008 17:40
  • Amigo CLA, estou com um problema parecido: tenho um site em ASP e os resultados do mecanismo de busca personalizado (CSE) do Google não exibe os resultados das palavras acentuadas. Tentei acessar o site indicado por você, mas não consegui identificar como resolver este problema. Vc poderia me auxiliar de maneira mais específica? Ou, ao menos, indicar em qual dos títulos exibidos no link indicado por você está a resposta para a questão, ok? Meu site é http://www.asbairj.org.br/forum/comunidade.asp. Basta digitar uma pergunta acentuada que o resultado informa como não existente.  O curioso é que, no site do Google Pesquisa Personalizada, a palavra acentuada é encontrada. Contudo, quando disponho o código do resultado no meu site, ele dá erro! Agradeço desde já! Forte abraço.
    sábado, 23 de maio de 2009 23:07