none
Sintaxe da função texto para exibir uma data completa sem incluir o dia da semana RRS feed

  • Pergunta

  • Prezada Comunidade,

    Gostaria de exibir a data 31/12/2015, que se encontra na célula A1, em uma outra célula, no formato: 31 de dezembro de 2015.

    Na sintaxe =TEXTO(A1;"dd/mmmm/aaaa") a data é exibida como: 31/dezembro/2015, mas não como gostaria: 31 de dezembro de 2015.

    Usando a sintaxe: =TEXTO(A1;"[$-F800]mmmm dd, yyyy"), a data é exibida como: quinta-feira, 31 de dezembro de 2015.

    Gostaria de saber se a função TEXTO tem um formato que exiba a data completa, SEM A INFORMAÇÃO DO DIA DA SEMANA , de uma forma mais simples do que a que elaborei:
    =TEXTO(A1;"dd")&" de "&TEXTO(A1;"mmmm")&" de "& TEXTO(A1; "aaaa")

    Grato por qualquer ajuda.

    quarta-feira, 25 de maio de 2016 14:01

Todas as Respostas

  • Qual o contexto? Esse código é no banco, em um relatório?

    Rodrigo Reis Ferreira
    Microsoft Certified

    quarta-feira, 25 de maio de 2016 17:23
  • já tentei de todo jeito e não consegui

    O problema é que 'd' significa dia...

    Se fosse em inglês por exemplo ficaria "dd of mmmm of aaaa" (31 of dezembro of 2015), o que funcionou perfeitamente

    Mas como não dá pra por um "de" ali no meio, fica difícil.

    Poste sua dúvida aqui que mais pessoas irão ver

    https://social.msdn.microsoft.com/Forums/pt-BR/home?forum=vbapt


    André Santo | basevba.wordpress.com

    quarta-feira, 25 de maio de 2016 17:53
  • Se for na query você pode tentar datepart():

    SELECT datepart(mm, dt_lancamento) as mes , datepart(yyyy,dt_lancamento) as ano 
      FROM TABELA 


    quarta-feira, 25 de maio de 2016 20:59
  • Me parece que você está falando do Excel... 

    Tente assim: 

    =CONCATENAR(TEXTO(A1;"dd");" de ";TEXTO(A1;"mmmm");" de ";TEXTO(A1;"aaaa"))

    • Marcado como Resposta Jose Morato quinta-feira, 26 de maio de 2016 09:23
    • Não Marcado como Resposta Jose Morato domingo, 29 de maio de 2016 16:02
    quarta-feira, 25 de maio de 2016 23:03
  • Caro Kerplunk,

    A função CONCATENAR é um pouco melhor do que a forma que vinha fazendo, mas resolvi o problema com a seguinte sintaxe:

    =TEXTO( A1;"dd"" de ""mmmm"" de ""aaaa").

    De qualquer forma, agradeço o interesse e a ajuda.

    Abraços.

    quinta-feira, 26 de maio de 2016 09:23
  • Prezado André Santo,

    Resolvi o problema com a seguinte sintaxe:

    =TEXTO( A1;"dd"" de ""mmmm"" de ""aaaa")

    Agradeço a atenção e a ajuda.

    Abraços

    quinta-feira, 26 de maio de 2016 09:26
  • Prezado Rodrigo,

    A função era no Excel, mas já consegui resolver o problema com a seguinte sintaxe:

    =TEXTO( A1;"dd"" de ""mmmm"" de ""aaaa")

    Agradeço a atenção e a tentativa de ajuda.

    Abraços.

    quinta-feira, 26 de maio de 2016 09:28
  • Prezado Rodrigo,

    A função era no Excel, mas já consegui resolver o problema com a seguinte sintaxe:

    =TEXTO( A1;"dd"" de ""mmmm"" de ""aaaa")

    Agradeço a atenção e a tentativa de ajuda.

    Abraços.


     Bacana Jose, que bom que conseguiu. Sucesso no projeto! :)

    Rodrigo Reis Ferreira
    Microsoft Certified


    sexta-feira, 27 de maio de 2016 12:10