none
Column Status does not exist On edit site page RRS feed

  • Question

  • Hi,

    I have a site that is a backup of another site that when i try to edit the home page  and click save i get the error "Column 'Status' does not exist. It may have been deleted by another user.  /traveltool/at/SitePages", however if i check the original there is no column Status on the Site Pages and the ULS logs dont provide much information either.

    This is preventing me from doing necessary changes to the homepage, can anyone help?

    Best regards.

    EDIT: Its happening on other lists that also do not have a status column.


    Rui Pais


    • Edited by R Pais Friday, November 8, 2019 12:28 PM issue on other lists
    Friday, November 8, 2019 12:07 PM

Answers

  • Hi,

    Turns out there was code that i was not aware of, the issue was fixed.

    Thank you for your help.


    Rui Pais

    • Marked as answer by R Pais Thursday, December 5, 2019 5:38 PM
    Thursday, December 5, 2019 5:38 PM

All replies

  • Hi Rui Pais,

    Did you use some code on the home page?

    The error means that there isn't a column which internal name is called ‘Status’ on the home page. As a workaround, you could create a column named ‘Status’ in the site page library. 

    Best Regards,

    Michaek Han


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, November 11, 2019 8:40 AM
    Moderator
  • Hi,

    There is some code but is mostly on OTB web parts (script editors and list views).

    I have created the status column, but still was not able to change the pages.

    Best regards.


    Rui Pais

    Thursday, November 14, 2019 3:36 PM
  • Hi Rui Pais,

    Since there are list view web parst on your home page, there may be a missing ‘Status’ column in some list view web part. As a workaround, you could create a column named ‘Status’ in your list.

    Best Regards,

    Michael Han


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, November 19, 2019 8:02 AM
    Moderator
  • Hi,

    I tried to create the Status Column but oly to receive an Object reference not set to an instance of an object.

    The thing is that it only happens on Edit, now i have the same error on the original platform from where i duplicated the previous one, but on another list.

    It is a standard list with some fields on it and i cannot edit items.

    ULS logs are not very helpfull also.


    Best regards


    Rui Pais


    • Edited by R Pais Tuesday, November 26, 2019 5:26 PM log info
    Tuesday, November 26, 2019 5:25 PM
  • Hi,

    Turns out there was code that i was not aware of, the issue was fixed.

    Thank you for your help.


    Rui Pais

    • Marked as answer by R Pais Thursday, December 5, 2019 5:38 PM
    Thursday, December 5, 2019 5:38 PM
  • Hi Rui Pais,

    Great, glad you solved this issue. Thanks for your sharing.

    Best Regards,

    Michael Han


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, December 6, 2019 1:38 AM
    Moderator