none
SSRS 2017 - Pipe delimited required - Was facing trouble or couldn't find the exact code to have the export option for pipe delimited RRS feed

  • Question

  • SSRS 2017 - Pipe delimited required - Was facing trouble or couldn't find the exact code to have the export option for pipe delimited option. Had tried below code, but it doesn't help either.

    <Extension Name="PIPE" Type="Microsoft.ReportingServices.Rendering.DataRenderer.CsvReport,Microsoft.ReportingServices.DataRendering">
                   <OverrideNames>
                         <Name Language="en-US">TXT (Pipe delimited)</Name>
                   </OverrideNames>
                   <Configuration>
                     <DeviceInfo>
                         <FieldDelimiter>|</FieldDelimiter>
                         <FileExtension>txt</FileExtension>
                     </DeviceInfo>
                   </Configuration>
    </Extension>

    Wednesday, November 13, 2019 11:29 AM

Answers

  • Hi,

    How and where have you put the code in the config file?

    Copy and paste the code inside Render section as I did here:

    Stop and restart  the SSRS service.

    Then you could find the new export extension in web portal, see:

    I tested in SSRS 2017, it should work.

    Regards,

    Lukas


    MSDN Community Support Please remember to click Mark as Answer; the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by SrinivasYSQL Saturday, November 16, 2019 11:35 AM
    Friday, November 15, 2019 1:18 AM

All replies

  • Hi,

    Were you trying to get a pipe delimited CSV exportation option?

    Where have you put the above code ?

    As far as I recall, this should work as I have had tested before. 

    Could you kindly go through this article and check if anything missing?

    SSRS Tip: Adding a Pipe-delimited option to SSRS Export Destinations

    Regards,

    Lukas


    MSDN Community Support Please remember to click Mark as Answer; the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, November 14, 2019 7:00 AM
  • Hi Lukas,

    The link which you have directed me is the same code i have copied in the question.. i have copied the code into config file. In 2014 version of SSRS, it is just adding a little bit piece of code that worked, but 2017 SSRS some how it is not showing up with different sets of code, the code i had already tried is from the link that you have provided.

    Thanks

    Thursday, November 14, 2019 10:49 AM
  • Hi,

    How and where have you put the code in the config file?

    Copy and paste the code inside Render section as I did here:

    Stop and restart  the SSRS service.

    Then you could find the new export extension in web portal, see:

    I tested in SSRS 2017, it should work.

    Regards,

    Lukas


    MSDN Community Support Please remember to click Mark as Answer; the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by SrinivasYSQL Saturday, November 16, 2019 11:35 AM
    Friday, November 15, 2019 1:18 AM
  • Thanks Lukas very much, I am not sure how it didn't worked before, but it worked finally. the other options what my DBA provided is as below. instead of csv it is txt. the below code also worked.. 

    <Extension Name="CSV" Type="Microsoft.ReportingServices.Rendering.DataRenderer.CsvReport,Microsoft.ReportingServices.DataRendering"/>

    <Extension Name="PIPE" Type="Microsoft.ReportingServices.Rendering.DataRenderer.CsvReport,Microsoft.ReportingServices.DataRendering">

    <OverrideNames>

      <Name Language="en-US">CSV (Pipe Delimited)</Name>

    </OverrideNames>

    <Configuration>

      <DeviceInfo>

       <FieldDelimiter xml:space="preserve">|</FieldDelimiter>

       <NoHeader>true</NoHeader>

       <FileExtension>csv</FileExtension>

       <ExcelMode>False</ExcelMode>

       <Encoding>ASCII</Encoding>

      </DeviceInfo>

    </Configuration>

    </Extension>

    Saturday, November 16, 2019 11:35 AM
  • Glad, it's working now! 

    Thanks for your feedback.


    MSDN Community Support Please remember to click Mark as Answer; the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, November 18, 2019 1:47 AM