locked
Azure Devops: Pipeline fails to deploy to Linux Web App RRS feed

  • Question

  • Hi, 

    I have a pipeline deploying to my Azure web app, that most of the times errors out because it couldn't deploy to my web app but when I go to the app I do see the latest changes, here are the relevant logs:

    ...

    Copying file: 'frontend/.gitignore'
    Copying file: 'frontend/README.md'
    Copying file: 'frontend/package.json'
    Copying file: 'frontend/tsconfig.json'
    Copying file: 'frontend/yarn.lock'
    Omitting next output lines...
    Error: ENOENT: no such file or directory, open '/home/site/wwwroot/node_modules/.bin/esparse'
    An error has occurred during web site deployment.
    Kudu Sync failed
    \n/opt/Kudu/Scripts/starter.sh "/home/site/deployments/tools/deploy.sh"
    ##[error]Failed to deploy web package to App Service.
    ##[error]To debug further please check Kudu stack trace URL : https://$someapp:***@someapp.scm.azurewebsites.net/api/vfs/LogFiles/kudu/trace
    ##[error]Error: Package deployment using ZIP Deploy failed. Refer logs for more details.

    ...

    Any ideas what could be wrong?



    Manuel Ocampo

    Thursday, May 28, 2020 6:35 AM

All replies

  • A few questions:

    1. Can you provide a snippet any errors from ***scm.azurewebsites.net/api/vfs/LogFiles/kudu/trace?
    2. Can you post your package.json file?
    3. What version of node are you attempting to use?
    4. Is your hosting plan Linux or Windows?
    5. When was the last time the deployment was successful?

    Thanks in advance, Ryan

    Friday, May 29, 2020 12:25 AM
  • Hi Manuel,

    Kudu sync failed appears to be similar to this open GitHub issue.  The issue has been open for over a year so I'm not sure what the exact state of it is. Feel free to reach out to us at AzCommunity[at]microsoft[dot]com ATTN Ryan so we can work more closely with you.


    Thanks in advance, Ryan

    Monday, June 1, 2020 4:20 PM