none
Checked Out Required to modified the server work book RRS feed

  • Question

  • We are using SharePoint 2013, users is having office 2016, Now in Document Library --> Open with Explorer -> Right clicked and created Excel Document --> Double clicked to add data in excel. Now here in my Development environment I'm able to add data in excel sheet and its get saved in my document library using Open with Explorer as per above steps.

    But same thing when I'm trying to do in my production, Document Library --> Open with Explorer -> Right clicked and created Excel Document --> Double clicked to add data in excel then after opening the excel its shows message "CHECK OUT REQUIRED To modify this server workbook, you must check it out." because of this I'm not able to add the data in excel. This message I'm not getting in Development Environment.  

    • Edited by SP2013Devp Tuesday, August 20, 2019 9:12 AM printscreen
    Tuesday, August 20, 2019 6:02 AM

Answers

All replies

  • Hi SP2013Devp.

    What about the settings for that document library in the production environment? Is it set to require documents to be checked out for editing?

    Bye.


    Luigi Bruno
    MCP, MOS, MTA, MCTS, MCSA, MCSE

    Tuesday, August 20, 2019 3:49 PM
  • Hi Luigi,

    Dev and Production both places YES for "Require documents to be checked out before they can be edited?"

    Thanks

    Tuesday, August 20, 2019 5:57 PM
  • Hi SP2013Devp,

    If you select “yes” for "Require documents to be checked out before they can be edited?", you will receive the message "CHECK OUT REQUIRED To modify this server workbook, you must check it out." when you edit the document.

    It is by design.

    If you want to edit the document, you should click the “Check Out”. Then you can edit and save the document.

    I have no idea why you did not receive the “Check out” message in Development Environment.

    Best regards,”

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by SP2013Devp Wednesday, August 21, 2019 5:43 AM
    • Unmarked as answer by SP2013Devp Wednesday, August 21, 2019 6:21 AM
    Wednesday, August 21, 2019 3:31 AM
    Moderator
  • Hi Sara,

    Since document is created by same user from Document Library --> Open with Explorer , and as per your above post when I click on "Check Out" to Edit the document I'm getting below error screen :-

    Wednesday, August 21, 2019 6:29 AM
  • Hi SP2013Devp,

    Did the issue only occur in one workbook or all documents in the current document library?

    Was the workbook edited by other user?

    You could check if the workbook is edited by other user.

    And then clear IE cache, then open with explorer and edit the workbook.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, August 21, 2019 7:06 AM
    Moderator
  • Hi Sara,

    Did the issue only occur in one workbook or all documents in the current document library? - Only Excel this issue we are facing, other file I can able to create in explorer edit and save it

    Was the workbook edited by other user? No, Its new workbook created by user in Open with Explorer

    You could check if the workbook is edited by other user. No its new workbook.

    And then clear IE cache, then open with explorer and edit the workbook. - tried but not able to edit the excel after clicking on check out option. However for Development I'm not facing this issue.

    For excel when in File --> Info below are the screen shows for me in Dev and Pod when I create through open with explorer.

     

     

    Wednesday, August 21, 2019 7:18 AM
  • Hi SP2013Devp,

    In Production environment, you could check out the workbook in the document library and then edit the workbook by opening with explorer.

    In the Development environment, the workbook has been checked out, so you did not receive the “Check Out” message when you edit the workbook.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, August 21, 2019 7:50 AM
    Moderator
  • In Production when I click on Check Out I'm getting the above error Locked for editing with my name which I posted on my first post. Please advice
    Wednesday, August 21, 2019 7:55 AM
  • Hi SP2013Devp,

    To troubleshoot the issue, you could download the workbook, delete the workbook in the document library and upload into the document library again.

    Then you also could create a new workbook and check if the same issue will occur.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, August 21, 2019 8:52 AM
    Moderator
  • Hi Sara,

    I've create the excel document in Document Library --> Open with Explorer, while edit the document I'm getting Check Out option and when I click on Check Out its shows document is locked for editing with my name. Could you please test if you are also getting this issue or advice how to resolve it or any suggestion. Thanks


    • Edited by SP2013Devp Wednesday, August 21, 2019 9:13 AM edit
    Wednesday, August 21, 2019 9:11 AM
  • Hi SP2013Devp,

    Per my test in my sharepoint 2013 environment, I create the excel document by opening with explorer, I did not encounter the same issue as yours.

    The excel document can work fine.

    And I suggest you could troubleshoot the issue by the troubleshooting steps in my previous post.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, August 21, 2019 9:20 AM
    Moderator
  • I'm doing the same step as per your previous post, only when I click on Check Out to edit the excel document I'm getting message locked for editing with button Notify / Cancel. Could you please advice any solution. 
    Wednesday, August 21, 2019 10:24 AM
  • Hi SP2013Devp,

    To troubleshoot the issue, check things below:

    1. You could select “No” for “Require documents to be checked out before they can be edited?” temporarily and check if you can edit the excel file.

    2. Clear office upload center cache. Go to Start->Search-> type “Office Upload Center”->settings->delete cached files.

    More reference:

    Delete your Office Document Cache.

    https://support.office.com/en-gb/article/delete-your-office-document-cache-b1d3765e-d71b-4bb8-99ca-acd22c42995d

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Thursday, August 22, 2019 7:29 AM
    Moderator
  • Hi Sara,

    As per your first point, when I click on No, then checked out option alert not showing while editing the excel from Open with Explorer, edit the file, checked in and finished without any issue but we want the check out option enable (Yes) which gives checked out warning and after clicking on checked out shows file is locked for editing.

    your second option I tried Go to Start->Search-> type “Office Upload Center”->settings->delete cached files. but still checked out option not allowing to edit the excel after creating in open with explorer. Please advice. 

    Thursday, August 22, 2019 8:06 AM
  • Hi SP2013Devp,

    After you select “No” for “Require documents to be checked out before they can be edited?”, then you could select “Yes” for “Require documents to be checked out before they can be edited?” and edit the excel document to check if the same issue will occur.

    And if the issue only occurs in one excel document, then you could create a new excel document and move the content from the problematical excel document to the new excel document.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Thursday, August 22, 2019 9:10 AM
    Moderator
  • Hi Sara,

    I tried the first option, Selected "NO" for "Require documents to be checked out before they can be edited?" and I'm not getting the check out option and able to edit the excel document, check in and close it. But again if I change from "NO" to "YES" “Require documents to be checked out before they can be edited?”, then same issue getting to "Check Out" the document and after clicking on "Check Out", "Document is locked for editing".

    User always create new excel document in Open with Explorer so moving content from another excel will not solve the issue. Please advice. 

    Thursday, August 22, 2019 12:26 PM
  • Hi SP2013Devp,

    For the issue, you should check who is editing the document firstly.

    If there is no body editing the document, then you could delete the document and re-upload the document to check if the same issue will occur.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, August 23, 2019 8:32 AM
    Moderator
  • Hi Sara,

    I'm creating the document with my id, as per my first post once I create the new Excel Document in Document Library --> Open with Explorer, I'm getting check out option and once I click for check out its giving error message  "locked for editing with button Notify / Cancel." as per above post screen shot. This issue I'm getting only first time when I create new Excel Document in Document Library --> Open with Explorer. Old document which is already created in Document Library I can able to edit. Here the customer using document library he can able to create, edit the document but when he create the document from Open with Explorer he's facing this issue. Please advice. Thanks

    Sunday, August 25, 2019 6:50 AM
  • Hi SP2013Devp,

    To troubleshoot the issue, you could edit the registry.

    Go to HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\WebClient\Parameters

    Find SupportLocking(if no, please add), set its value to 0.

    And you also could use office 2013 to check if the same issue will occur.

    More reference:

    The file Document.docx is locked for shared use by user in SharePoint.

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, August 26, 2019 9:29 AM
    Moderator
  • Hi Sara, 

    For Development url on my local machine I'm not facing issue but on the same machine production site is giving this issue, so I don't think so changes in HKEY is required. Also, to do this I need approvals, Please advice.

    We all are using by default Office 2016, so we cant ask user to go back for office 2013 and for office 2016 development url is working fine but production is giving the issue. Please advice.

    Thanks.

    Wednesday, August 28, 2019 7:55 AM
  • Hi SP2013Devp,

    You could compare the configuration between the production environment and development environment.

    And in the production environment, you could clear configuration cache.

    And then run a SharePoint 2013 products configuration wizard.

    More reference:

    Clearing the SharePoint Configuration Cache.

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, August 28, 2019 8:16 AM
    Moderator
  • Hi SP2013Devp,

    I've checked the scenario and yes it occurs for the first time I've tried to edit the excel. When I tried next time it worked. 

    Initially Excel was opened with http url: http://testsite.contoso.com/sites/Shared%20Documents/test.xlsx and was showing locked for editing.

    Next time when I've opened the same excel it was opened with network path: \\testsite.contoso.com\DavWWWRoot\sites\Shared%20Documents\test.xlsx no error, in checked-out mode.

    I think it's a bug in SharePoint. Below link might explain the behavior:

    https://social.technet.microsoft.com/Forums/sharepoint/en-US/7966c35d-b815-4951-8374-d64840ccf16c/documents-becoming-quotlocked-for-editingquot-by-self-when-no-other-edits-are-happening?forum=sharepointadminlegacy


    Best Regards,
    Brij K
    http://bloggerbrij.blogspot.co.uk/

    Thursday, August 29, 2019 11:57 AM

  • Hi SP2013Devp,

    How is everything going?

    Is there anything update about this issue?

    If the reply is helpful to you, you could mark the reply as answer. Thanks for your understanding.

    Best regards,

    Sara Fan

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, September 3, 2019 1:30 AM
    Moderator