none
RDP Problems and Random Restarts RRS feed

  • Question

  • Hello,

    I have a virtual machine (created yesterday), after my 30 trials expired. After setting the inbound port for RDP (like the docs https://docs.microsoft.com/en-us/azure/virtual-machines/troubleshooting/troubleshoot-rdp-nsg-problem) but still can't connect. But if I change to allow all ports it works.

    Another problem is that the VM is restarting (6 times only tdy), 7 times yesterday. What can be causing such problem? In resource Health logs this is the message:

    A reboot was triggered from inside the virtual machine. This could be due to a virtual machine operating system failure or as requested by an authorized user or process. The virtual machine will be back online after the reboot completes.

    The only thing running there is a dicord bot (this bot is running for more than a year now, so it can't be a problem with it (and in the 30 days of the first month) everything worked great.

    Best regards,
    Unloaded

    Friday, July 19, 2019 7:39 PM

All replies

  • Hi,

    If you open 3389 to all and you can RDP but without that you cant then it is a problem with the external IP you add for the rule to limit it to you.  Can you check your IP on http://icanhazip.com and ensure it matches?  

    For the reboots, you need to check the event logs.  If there is a page file configured on C:\ then you should also get a memory dump if one is created?

    Thanks,

    Matt

    Saturday, July 20, 2019 8:15 PM
  • Hi,

    Can you try to disable the bot temporarily for 24 hours? Just to confirm that the bot is not the problem. 

    You can also try to deallocate the VM from the Portal and start it again, with that way your VM will start to a new cluster.

    As for the RDP port, you can check if works well via the Azure Portal, 


    Please, If you think your question has been answered click "Mark as Answer" if just helped click "Vote as helpful". This can be beneficial to other community members reading this forum thread.


    Sunday, July 21, 2019 2:12 PM
  • Is there any update on this issue? Did any of the replies above help?
    Thursday, July 25, 2019 3:32 PM
    Moderator