none
SP says the User Profile Synronization service isn't running when it is RRS feed

  • Question

  • I just created a new SP server and farm.  It was all loaded from scratch then I imported the content database from our old server.  The new server has been working great for a week now but today I had a user tell me they were having issues opening Excel files with OOS.  The reason I loaded the new server was because I couldn't get the user profile synchronization service to work on the original server.  As a result the user gets "The wordbook cannot be opened" when opening an excel file.  It had alot of issues so I thought it best to start from scratch.

    Its been working great but today the same user got the same error.  I went and looked at the User Profile Synchronization service and it showed it was running when going to "manage services on the server".  When I go to manage service applications then click on the User profile service application link it says "User profile Sync is not currently provisioned" and when I try to configure a connection it says i can't because the service isn't running.  It clearly is running according to manage services on the server.  Am I missing something?

    Second thing is what does this do and why would it stop office online files from opening all of the sudden out of the blue?

    Thursday, January 9, 2020 9:24 PM

Answers

  • I think i got it figured out.  I stopped the user profile sync service and when I restarted it it prompted me for account information and what not.  From there I was able to provision it no problem.  I don't understand why its been working for the past few weeks though.  
    Friday, January 10, 2020 1:41 PM

All replies

  • Hi,trevoryour_cp,

    Please have a try with the following fix, run the powershell cmdlet

    $serviceInstance. = Get-SPServiceInstance | Where { $_.TypeName -like "User Profile Synchronization Service "}

    $serviceInstance.Unprovision()

    Then manually start User Profile Synchronization Service from CA> application Mangement> Manage services on server. Make sure the service is running as the farm account with enough permission. 

    Make sure your user profile service had farm account as administrator for that CA> Application management> Manage service application.

    After that do an IISreset and see if the issue remains.

    Reference: https://www.c-sharpcorner.com/forums/user-profile-sync-is-not-currently-provisioned

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best Regards

    Jerry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, January 10, 2020 3:00 AM
  • I think i got it figured out.  I stopped the user profile sync service and when I restarted it it prompted me for account information and what not.  From there I was able to provision it no problem.  I don't understand why its been working for the past few weeks though.  
    Friday, January 10, 2020 1:41 PM
  • Hi,trevoryour_cp,

    Glad to here you figured it out. Please mark the reply as answer. It will help other community members with similar issue to find the solution easily.

    Best Regards

    Jerry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, January 13, 2020 1:08 AM