none
Restore Problem "Restore-SPSite : The extension Microsoft.Office.Project.Server.Database.Extension.ProjectDatabaseExtension is of version 16.1.273.0, and the backup was on version 16.1.290.0. These versions are incompatible." RRS feed

  • Question

  • Hello, 

    We have our backup file (from another server) and when we run the restore command in Sharepoint Shell, the following message is shown:

    " <g class="gr_ gr_34 gr-alert gr_gramm gr_inline_cards gr_run_anim Style multiReplace" data-gr-id="34" id="34">Restore-SPSite :</g> The extension Microsoft.Office.Project.Server.Database.Extension.ProjectDatabaseExtension is of version 16.1.273.0, and the backup was on version 16.1.290.0. These versions are incompatible. "

    --> We have SQL 2014 and Sharepoint 2016 installed on the 2 servers. 

    We run the following command -trying to solve the error: 

    "<g class="gr_ gr_68 gr-alert gr_gramm gr_inline_cards gr_run_anim Style multiReplace" data-gr-id="68" id="68">Restore-SPSite :</g> The extension Microsoft.Office.Project.Server.Database.Extension.ProjectDatabaseExtension is of
    version 16.1.273.0, and the backup was on version 16.1.290.0. These versions are incompatible.

    "

    The update has run successfully and without warning or errors But that did not solve my problem. 

    Please, help. 


    • Edited by Majod Thursday, February 8, 2018 10:01 AM
    Thursday, February 8, 2018 9:59 AM

Answers

  • Hi Majod,

    According to your description, you're restoring a backup made with an newer build into a farm running a older build.

    The possibility is that you did install the correct CUs but didn't run PSConfig to update the database schemas.  Try to run PSConfig or the configuration wizard in your SharePoint 2016 farm.

    You can refer to below article for more information:

    https://social.technet.microsoft.com/Forums/windows/en-US/40ba57dc-2ae8-4d03-ac0d-a2bab3e54498/correct-build-version-and-restore-issue-in-sharepoint-2016-rtm-enterprise-version?forum=SP2016

    Usually we can either update our environment (and you should consider this option as basic) to solve this issue or go by non-standard way. This article provide the non-standard way which may be helpful to you:

    http://sadomovalex.blogspot.sg/2013/11/how-to-restore-site-collection-from.html

    Best regards, 

    Allen Bai


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by Majod Sunday, February 11, 2018 6:39 AM
    Friday, February 9, 2018 6:40 AM

All replies

  • Hi Majod,

    According to your description, you're restoring a backup made with an newer build into a farm running a older build.

    The possibility is that you did install the correct CUs but didn't run PSConfig to update the database schemas.  Try to run PSConfig or the configuration wizard in your SharePoint 2016 farm.

    You can refer to below article for more information:

    https://social.technet.microsoft.com/Forums/windows/en-US/40ba57dc-2ae8-4d03-ac0d-a2bab3e54498/correct-build-version-and-restore-issue-in-sharepoint-2016-rtm-enterprise-version?forum=SP2016

    Usually we can either update our environment (and you should consider this option as basic) to solve this issue or go by non-standard way. This article provide the non-standard way which may be helpful to you:

    http://sadomovalex.blogspot.sg/2013/11/how-to-restore-site-collection-from.html

    Best regards, 

    Allen Bai


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by Majod Sunday, February 11, 2018 6:39 AM
    Friday, February 9, 2018 6:40 AM
  • Many Thanks <g class="gr_ gr_39 gr-alert gr_gramm gr_inline_cards gr_run_anim Punctuation multiReplace" data-gr-id="39" id="39">..</g> 

    I tried updating the environment but that did not solve my problem. 

    The non-standard way worked. 

    ^_^

    Sunday, February 11, 2018 6:42 AM
  • I finally was able to get this to work by edit/change the minor version IN the backup file (using a Hex editor)

    In my case having the following error:
    restore-spsite : The extension Microsoft.Office.Project.Server.Database.Extension.ProjectDatabaseExtension is of version 16.1.309.0, and the backup was on version 16.1.303.0. These versions are incompatible.

    I only changed 303 (source farm version) in 309 (target farm version)
    (The version data is on the begin of the backup file)

    ps: None of the farms I work with uses Project Server and all SharePoint Server versions are x.0.x.x and not x.1.x.x


    Wednesday, August 21, 2019 9:47 AM