none
Unable to Edit Page - Access Denied RRS feed

  • Question

  • Hi there,

    I have a HNSC Web Application with a number of site collections sitting underneath.  Something has changed, and I'm not sure what, but now when I try to edit a page, I get an "Access Denied" error.  I am a Site Collection Administrator of all the sites and have in the past been able to edit pages fine.

    I have assigned the [portalsuperuseraccount] and [portalsuperreaderaccount] the correct permissions.  I cannot see any pages that are checked out - I cannot edit any page but I can browse the pages with no problems.

    I have recently set up a daily backup using task scheduler and saw a post suggesting the DB could be locked but I cannot see any sign of it being locked in either SQL or in CA.

    I have another Web Application also and have no problems editing the pages in the site collections attached to it.

    Any help would be most appreciated.

    Monday, March 10, 2014 5:57 AM

All replies

  • hi Kelsnz ,

    Please check whether the site collection is in readonly mode or not

    Get-SPSite -Identity <URL> -lockstate
    



    Regards, Pradeep

    Monday, March 10, 2014 8:38 AM
  • I'm not sure why - but that didn't seem to work for me.  I had to use:-

    stsadm -o getsitelock -url <Site-collection-url>

    The result was "None".  I also checked in CA and my sites are not locked

    Monday, March 10, 2014 10:34 PM
  • Just to add to this also - I have three site collections under this web application - the issue is affecting all of these site collections.

    Also, I am able to edit pages using SharePoint Designer - just not in the browser....that is where I get the Access Denied

    • Edited by kelsnz Tuesday, March 11, 2014 12:14 AM More Detail
    Monday, March 10, 2014 11:38 PM
  • *BUMP*  Anybody?

    I have run psconfig.exe and that was successful.  Each site collection in this web app has its own content database.  I have checked the permissions in IIS for the WSS folder all appears okay.

    I'm pretty sure it has something to do with IIS?

    Tuesday, March 11, 2014 11:00 PM
  • Try to create another site collection admin user. Use another AD account for this.

    I experienced similar problem. When I was look to user info table in SQL database, I have seen that there are deleted user record and new user record.

    Thursday, March 13, 2014 8:17 AM
  • I added another Site Collection Admin that was a new account created in AD.  I even removed the currently Site Collection Admins.

    Still the same result...

    Thursday, March 13, 2014 10:25 PM
  • Just add further, I created a new site collection in this web application and having the Access Denied problems on this also.

    Is there something in the Web Application or IIS site that could be causing this?

    Friday, March 14, 2014 1:08 AM