Error while processing request RRS feed

  • Question

  • Hi,

    I followed the how-to guide from quickstarts to create an Android app. 

    But when I run the app in Android Studio I get following error in my mobile app: "Error while processing request". Has anybody implemented this quickstart guide and got the same error in the mobile android app

    Which logs should I post so that you can analyze best?

    Thanks so far

    Monday, April 13, 2020 2:52 PM

All replies

  •  The error was due to an Azure App Service HTTP2 connection issue. It has nothing to do with the app code. For anyone facing the same problem, here is the solution.

    1. Go to https://resources.azure.com/
    2. Make sure you are in Read/Write mode by clicking in the option to the left of your name.
    3. From the left column, browse to: https://resources.azure.com/subscriptions/yourSubscriptionId/resourceGroups/yourWebAppResourceGroup/providers/Microsoft.Web/sites/yourWebAppName/config/web
    4. Find and Change the property: "http20Enabled": from true to false by clicking EDIT, Update value to “false” and then clicking in Save or PATCH.
    • Proposed as answer by Akshay M Monday, April 13, 2020 3:14 PM
    Monday, April 13, 2020 3:14 PM
  • Hi Akshay,

    I checked, but "http20Enabled" was already set to false

    Monday, April 13, 2020 3:49 PM
  • Can you be more specific with the browsing? Should I navigate to that URL you provided? which parts exactly are placeholders?
    • Edited by max2020max Tuesday, April 21, 2020 11:19 PM
    Tuesday, April 21, 2020 10:26 PM
  • We completely understand this issue could be frustrating, apologies for any inconvenience with this and delayed response.

    @Bertl and @max2020max, I believe you’re referring to the steps outlined in this document ‘Create an Android app’ / if it’s any other Azure doc please let us know?

    I have reached out to the product engineering (and content team) and relayed the feedback. We wish to engage with you offline for a closer look and provide a specialized assistance, please send an email with subject line “Attn:Ajay” to AzCommunity[at]Microsoft[dot]com referencing this thread and the Azure subscription ID, I will follow-up with you.

    Just to highlight, you could always leverage App Service diagnostics to fetch more details on the issue.  To access App Service diagnostics, navigate to your App Service app in the Azure portal.
    In the left navigation, click on Diagnose and solve problems
    - From there, run the “Availability & Performance” & “Diagnostic Tools” for investigation.
    Also, you may checkout the documentation Enable diagnostics logging for web apps in Azure App Service for enabling the logs and gain deeper insight into the error.

    As I understand from Akshay’s response above, users with a similar issue had rectified the issue by setting the ‘"http20Enabled" property to false, just sharing the older discussion thread, MSDN thread and blog for clarity and visibility.

    Thanks for your patience and co-operation. We look forward to your reply.

    Saturday, April 25, 2020 8:37 PM