Cannot delete a table in Access 2010


  • I have a number of older MBD databases that I am now using Access 2010 to maintain and I have discovered that I cannot delete tables from the UI in these databases. I tried converting a couple to ACCDB files but it didn't help. I can create tables, open them, modify them and so on, but cannot delete them, the option is grayed out on the ribbon and the delete key has no effect.

    If I make a new DB from scratch, I can delete tables okay, but in any of the existing databases it doesn't work. (I can delete tables from code, but not the UI)

    Any help appreciated.

    mercredi 13 octobre 2010 01:03

Toutes les réponses

  • Maybe there is some User Level Security (ULS) implemented.

    I would take the easy route, and "delete" the tables by copying everything else to a new database.

    -Tom. Microsoft Access MVP
    mercredi 13 octobre 2010 04:32
  • All the older MDB files were set up with User Level Security on them and I can open them in Access 2003 and delete away to my heart's content, so that may be influencing my ability to delete tables in them. Interesting then (assuming that this is the culprit) that the conversion process to ACCDB does not necessarily remove all the influence of the previously established security.

    I suspect I will wind up doing as you have suggested, I have already done this with one DB successfully.

    Thanks for your time.


    mercredi 13 octobre 2010 05:05
  • I have the same problem.  Also, the Paste and Cut options are dimmed.  My O/S is Win 7.  The accdb file has full permission access for all users.  It's not a O/S security feature.  Tom's reply seems too be incorrect.  Is this a bug?  I need the Copy - Paste (Structure) and Delete keys, so I can make a duplicate table with the same structure, then delete the original data-filled table, then rename the newly created table.  It's a much faster way to delete existing records from a large table than selecting and deleting them all within the table.  Any patches?  Fixes?  Workarounds?


    jeudi 14 octobre 2010 20:13
  • I know this is several months old.  I had the same problem and have come across a solution that worked for me.

    Open the database with your username and password (assuming you have administrator security).


    Go to User and Group Accounts and click the Clear Password button for the Admin user.  Exit the database.


    Click the shortcut to log into the database again.  It will not ask for a password.  Go to User and Group Accounts and click Change Password.  Since you are logged on as Admin, you will be changing the Admin password.  Enter the password you want assigned to Admin in the New section and then Verify it.  Exit the database.


    Click the shortcut to log into the database and use your username and password.  The Delete option is available.

    mardi 28 juin 2011 15:52
  • Thank you Access Volunteer. THIS WORKED!!!
    mercredi 20 juillet 2011 14:37
  • See this article for more reference:

    Set or change Access 2003 user-level security in Access 2010


    Hope this helps,

    Daniel van den Berg | Washington, USA | "Anticipate the difficult by managing the easy"
    mercredi 20 juillet 2011 17:58
  • If you start Access using the /wrkgrp parameter which points to a workgroup file that had the been used in the prior version you will be asked to log in as per the old days and then you should be able to delete tables.I haven't tried experimenting with setting permissions to "everyone" in the old database before converting but that might work too.

    dimanche 25 août 2013 20:39
  • I'm also using an old .mdb file with .mdw as a User Level Security (USL) impletementation.

    I have no problem in access 2007, 2010 until I recently using a MS Access 2013 to open it,

    cause I have to re-develop my solution, I found out the cut, paste, delete is dimmed and

    cannot be used anymore. The remove Admin user password work out for me. I emptied

    the Admin password and logon again, all functions came back. thanks

    mardi 27 août 2013 09:55
  • Thank you Access Volunteer! You saved me!
    vendredi 6 septembre 2013 19:43