Imagelist control produces "Class not registered" error RRS feed

  • Question

  • I am updating some old Word templates that have a treeview and imagelist control on a user form that act as a menu to a suite of over 300 templates.

    I need to update the node images which are stored on the imagelist.

    The templates were originally created for Word 7 then updated for Office 2000.  I have managed to resolve most issues in moving them to Windows 10 Microsoft 365 environment.

    This is stumping me.  When I select the imagelist control and view its properties, the about property tells me its "Image List ActiveX control - Version 6.0 (SP6)"

    When I click the Custom property I get error "Class not registered. Looking for object with CLSID:{7EBDAAE1-8120-11CF-899F-00AA00688B10}".  This CLSID does not exist in the registry.

    I have tried re-registering mscomctl.ocx. Have tried this alternately in system32 or SysWOW64.

    Interestingly regardless of what I do the control seems to reference "C:\WINDOWS\system32\MSCOMCTL.OCX". I see this if I look at the IDE toolbox "Additional Controls" list.

    As it is the form still works but with the old images for the treeview nodes.

    I have also tried to eliminate all references in the registry to "C:\WINDOWS\system32\MSCOMCTL.OCX" and then re-register with MSCOMCTL.OCX in SysWOW64 but then the template generates errors on loading and won't run the form at all.

    I have a good understanding of systems having worked in IT for over 20 years with over 10 in template development.  This template drives a menu system of over 300 templates.  I have been out of this field for about 15 years hence why these templates have not been updated for the various versions of Windows and Office since.

    My question is basically how can I access and edit these controls in my current environment.



    Saturday, November 28, 2020 9:21 AM