Remote blob storage for sharepoint 2010


  • Hi everybody

    I am trying to configure the rbs for sharepoint 2010  without success.

    I followed some step to step  instructions  as  per this links

    In the final steps, I run the rbs installer

    msiexec /qn /lvx* rbs_install_log.txt /i RBS_X64.msi 
    WSS_Content" DBINSTANCE="DBInstanceName

    on the WF server  but  the log  reports  a 2711  error  saying that  FilestreamServer  feature is not found.

    Previously I ran the same installer  on  the  db  server  and  all mssqlrbs  tables  were successfully created.

    If I ran the powershell  command

    $cdb = Get-SPContentDatabase -WebApplication <http://SiteName>

    $rbss = $cdb.RemoteBlobStorageSettings






    I see that the active provider name is empty.

    I saw this post

    but it's not clear if this matter  was  resolved  or not


    Thanks for helping



    Wednesday, June 08, 2011 7:27 PM


  • Hi paolo_tn,


    Thanks for your post.

    According the error message” on the WF server  but  the log  reports  a 2711  error  saying that  FilestreamServer  feature is not found.”, please make sure the FILESTREAM is enabled for the SQL Server at first.


    Also, if you have installed RBS on the first Web Server, you should run the command below:

    msiexec /qn /lvx* rbs_install_log.txt /i RBS-x64.msi TRUSTSERVERCERTIFICATE=true FILEGROUP=PRIMARY DBNAME="WSS_Content" DBINSTANCE="DBInstanceName" FILESTREAMFILEGROUP=RBSFilestreamProvider FILESTREAMSTORENAME=FilestreamProvider_1

    instead of

    msiexec /qn /lvx* rbs_install_log.txt /i RBS_X64.msi

     WSS_Content" DBINSTANCE="DBInstanceName



    More information:

    • Marked as answer by paolo_tn Friday, June 10, 2011 1:56 PM
    Friday, June 10, 2011 3:45 AM

All replies