none
Incomplete calculation. Recalculate before save? Help

    Question

  • I am using Excel 2013 and get mentioned problem every time when I save my document

    The document was previously saved under Excel 2010, now it comes up with this message every time I want to save and answering with yes does only cause this same message to come up again and again. So I can only save without recalculate.

    Is there any one who can help?

    Edwin

    Wednesday, December 12, 2012 10:53 AM

Answers

  • I have checked an it is using automatic calculation mode

    Just found the solution.

    I was talking about an xlsm file with a macro attached.

    When I signed the file it never came up with the message again. When I removed the signature, the message returned again.

    So it had to do with security.

    Thanks for the reply

    • Edited by EdwinKuster Wednesday, December 12, 2012 1:34 PM Found solution
    • Marked as answer by EdwinKuster Wednesday, December 12, 2012 1:35 PM
    Wednesday, December 12, 2012 1:23 PM

All replies

  • Check that Excel is using Automatic Calculation mode.

    Charles Excel MVP The Excel Calculation Site http://www.decisionmodels.com/

    Wednesday, December 12, 2012 12:38 PM
  • I have checked an it is using automatic calculation mode

    Just found the solution.

    I was talking about an xlsm file with a macro attached.

    When I signed the file it never came up with the message again. When I removed the signature, the message returned again.

    So it had to do with security.

    Thanks for the reply

    • Edited by EdwinKuster Wednesday, December 12, 2012 1:34 PM Found solution
    • Marked as answer by EdwinKuster Wednesday, December 12, 2012 1:35 PM
    Wednesday, December 12, 2012 1:23 PM
  • I am having the same issue - an .xlsm (macro) excel sheet is now giving me this error. It might be due to switching to Excel 2013. It is already using the auto calculation mode.

    Can you better describe your solution that had to do with security?

    Thursday, January 22, 2015 3:31 PM
  • It has been a while, and the solution was to go to vba window and sign de macro.

    At out company we usually sign all macro's we use under office documents.

    Hope this helps.

    Thursday, January 22, 2015 4:02 PM
  • I too have been having the same problem, since I started using Excel 2013, with an xlsm file which had been modified by an outside consultant to include conditional formatting and macros. All has been OK from Excel 2003 through to 2010. It only seems to affect 2013.

    Other sites seem to suggest the problem is with conditional formatting. However, whilst I have the file open, I have just created a very simple new file with no special formatting, macros, etc and when I went to save it I got the same message come up.

    The document is not signed and we do not have a facility for signing.

    I have Enable All Macros ticked and Trust access to the VBA project ticked.

    Other solutions rely on turning Automatic Recalc off which, quite frankly is not really practical.

    I’ve also noticed that when I have this errant file open other simple files (no formatting, no macros, no anything special) suffer from the same problem.

    If anyone could come up with a solution, I would be grateful. Although I guess the problem is a fundamental issue with Excel which needs to be fixed by MS.

    Wednesday, April 08, 2015 7:55 AM