PIA 2003 Error after installing Office 2013


  • I've created a program that uses the excel office 2003 interop (version 11). And it worked fine... untill i installed Office 2013 on my development computer, after this i made a few changes (just some try catch) but the references have changed. I believe it is because of the GAC. But now when i run it - it reports an error only on the deployment pc that the library in which the PIA is dos not exist. It is trying to reach version 15 even though i set it to 11. 

    I installed 2013 preview because i had to develop an add-in for 2010 and did not have that. Btw the deployment pc runs Windows Xp in citrix environment and i have no chance of installing the office 2013 PIA.

    is there anyone that knows how to fix this issue? I tried to copy the assembly local and it didn't help

    sincerely Theis

    Wednesday, December 12, 2012 10:27 AM


  • Hi theian,

    Thanks for posting in the MSDN Forum.

    It's based on my experience that the keys, values in registry has been changed via Office 2013, so your 2003's application will not work. You can reinstall PIA 2003 to fix it. Let's try it.

    Have a good day,


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, December 13, 2012 5:14 AM