none
Error on mso.dll when closing the Excel 2010 RRS feed

  • Question

  • I install a 64-bit add-in for Excel 2010 64 bit. The excel opens well and the add-in seems working.

    But when I close the Excel, it always give me this error:

    Problem signature:

    Problem Event Name: APPCRASH

    Application Name: EXCEL.EXE

    Application Version: 14.0.4756.1000

    Application Timestamp: 4b9c0870

    Fault Module Name: mso.dll

    Fault Module Version: 14.0.4760.1000

    Fault Module Timestamp: 4ba906d8

    Exception Code: c0000005

    Exception Offset: 0000000000466c52

    OS Version: 6.0.6002.2.2.0.272.7

    Locale ID: 2057

    Additional Information 1: 3684

    Additional Information 2: 3a670aff899249dc0ba11b879d874bf3

    Additional Information 3: 99c6

    Additional Information 4: 060fae9c97c6607aff0caa1fc286517c

     

    Does anyone know what the problem is?

    Thanks

    Tuesday, May 24, 2011 1:06 PM

Answers

  • Hi Bruce,

    The issue has disappeared after I rebuild the application and reboot after installing the add-in. I am not sure what did the trick exactly but it's working now.

    Thanks 

    • Proposed as answer by Bruce Song Monday, May 30, 2011 8:29 AM
    • Marked as answer by Bruce Song Tuesday, May 31, 2011 9:34 AM
    Friday, May 27, 2011 9:23 AM

All replies

  • I found if I open the excel and wait for a while, then the Excel can close properly. If close Excel immediately after opening it, the Excel will crash.

    It seems the Excel takes a long time to load the Add-in.  Does the Excel loads the add-ins before the main window opens? If I see the Excel main window opens, does it finish loading all add-ins or it is still loading something?

    Thanks for any help/suggestion.  I do not know how to get more details about this issue.

    Wednesday, May 25, 2011 2:05 PM
  • Hi Chasxu,

    As far as I know, Excel loads Add-Ins before the main window opens.

    If you close the window immediately, it probably cause the problem, but I haven't encountered such problem before. Why do you want to close it immediately. You may need to wait for it to load completely.

    Hope this can give you the hint and I will do further research about your problem.

    Best Regards,


    Bruce Song [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, May 26, 2011 11:41 AM
  • Hi Bruce,

    The issue has disappeared after I rebuild the application and reboot after installing the add-in. I am not sure what did the trick exactly but it's working now.

    Thanks 

    • Proposed as answer by Bruce Song Monday, May 30, 2011 8:29 AM
    • Marked as answer by Bruce Song Tuesday, May 31, 2011 9:34 AM
    Friday, May 27, 2011 9:23 AM