none
react-calendar-feed is not working in IE.. RRS feed

  • Question

  • I am not able to run this react widget in workbench also..Its coming as blank. When I deployed that solution in my tenant there also i am getting following error.. Please help.

    **Something went wrong
    If the problem persists, contact the site administrator and give them the information in Technical Details.
    Technical Details

    [SPLoaderError.loadComponentError]:
    ***Failed to load component "acef6c3f-852a-42e3-8a4b-7ea191ae9687" (CalendarFeedSummaryWebPart). Original error: ***Failed to load URL 'https://publiccdn.sharepointonline.com/abc.sharepoint.com/sites/appcatalog/ClientSideAssets/25653136-fc83-4abe-b9d2-a4ac041959d5/calendar-feed-summary-web-part_a5b64268e503b3b539ba832ffc06d63c.js' for resource 'calendar-feed-summary-web-part' in component 'acef6c3f-852a-42e3-8a4b-7ea191ae9687' (CalendarFeedSummaryWebPart). There was a network problem. This may be a problem with a HTTPS certificate. Make sure you have the right certificate.

    ***INNERERROR:
    ***Failed to load URL 'https://publiccdn.sharepointonline.com/abc.sharepoint.com/sites/appcatalog/ClientSideAssets/25653136-fc83-4abe-b9d2-a4ac041959d5/calendar-feed-summary-web-part_a5b64268e503b3b539ba832ffc06d63c.js' for resource 'calendar-feed-summary-web-part' in component 'acef6c3f-852a-42e3-8a4b-7ea191ae9687' (CalendarFeedSummaryWebPart). There was a network problem. This may be a problem with a HTTPS certificate. Make sure you have the right certificate.
    *CALLSTACK:
    Error
    at t._generateErrorStackForIE (https://spoprod-a.akamaihd.net/files/sp-client-prod_2019-08-16.010/sp-pages-assembly_en-us_89a71a07c8bdf9672544574aa95d0170.js:4:53720)
    at t (https://spoprod-a.akamaihd.net/files/sp-client-prod_2019-08-16.010/sp-pages-assembly_en-us_89a71a07c8bdf9672544574aa95d0170.js:4:53256)
    at t (https://spoprod-a.akamaihd.net/files/sp-client-prod_2019-08-16.010/sp-pages-assembly_en-us_89a71a07c8bdf9672544574aa95d0170.js:20:79630)
    at e.buildErrorWithVerboseLog (https://spoprod-a.akamaihd.net/files/sp-client-prod_2019-08-16.010/sp-pages-assembly_en-us_89a71a07c8bdf9672544574aa95d0170.js:20:118295)
    at e.buildLoadComponentError (https://spoprod-a.akamaihd.net/files/sp-client-prod_2019-08-16.010/sp-pages-assembly_en-us_89a71a07c8bdf9672544574aa95d0170.js:20:114320)
    at Anonymous function (https://spoprod-a.akamaihd.net/files/sp-client-prod_2019-08-16.010/sp-pages-assembly_en-us_89a71a07c8bdf9672544574aa95d0170.js:20:109769)
    at Anonymous function (https://publiccdn.sharepointonline.com/abc.sharepoint.com/sites/appcatalog/ClientSideAssets/890affef-33e0-4d72-bd72-36399e02143b/search-results-web-part_c3e174542874f8fbf02e0e130b9923fa.js:51:69494)
    at Anonymous function (https://publiccdn.sharepointonline.com/abc.sharepoint.com/sites/appcatalog/ClientSideAssets/890affef-33e0-4d72-bd72-36399e02143b/search-results-web-part_c3e174542874f8fbf02e0e130b9923fa.js:51:69364)
    at c (https://publiccdn.sharepointonline.com/abc.sharepoint.com/sites/appcatalog/ClientSideAssets/890affef-33e0-4d72-bd72-36399e02143b/search-results-web-part_c3e174542874f8fbf02e0e130b9923fa.js:51:88251)

    Monday, September 16, 2019 6:33 AM

All replies

  • Hi Rajrup,

    Please check the thread below.

    https://github.com/SharePoint/sp-dev-docs/issues/3871

    And try to deploy the solution follow the steps below.

    1. Run gulp clean
    2. Run gulp bundle --ship
    3. Run gulp package-solution --ship
    4. Upload .sppkg file from sharepoint\solution to your tenant App Catalog
    E.g.: https://<tenant>.sharepoint.com/sites/AppCatalog/AppCatalog
    5. Add the web part to a site collection, and test it on a page

    As this issue more related the example SPFx from GitHub, you can also submit a issue from here to get more helps.

    https://github.com/SharePoint/sp-dev-fx-webparts/issues

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, September 17, 2019 8:08 AM
    Moderator
  • Hi Denis, thanks for your reply. I have done the steps you mentioned but no luck. I have raised the issue in GitHub also I didn't get any response till date.

    Tuesday, September 17, 2019 2:44 PM
  • Hi Rajrup,

    Did you deploy the SPFx solution to CDN?

    Please try to deploy it to SharePoint Library to check if it works.

    https://www.c-sharpcorner.com/article/sharepoint-framework-deploy-spfx-webparts-to-sharepoint-library/

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, September 18, 2019 9:20 AM
    Moderator