none
A problem occurred while accessing the Office Document Cache. RRS feed

  • Question

  • Hi All,

     

    I have a windows service to auto refresher Excel (I have to do that), the application will auto lunch Excel and refresh it. But recently after running more than 1 day, all the Excel processes will hang then no Excel can be refreshed, then I have to reboot the Production Server.

     

    I found the error for each Excel process, the event time exactly match the Process start time. I have disabled the alert in service (ExcelObj.DisplayAlerts = false) but the alert in Event Viewer indeed.

    Microsoft Excel

    A problem occurred while accessing the Office Document Cache.

     

    Do you want to repair this problem?

    P1: 701941

    P2: 14.0.6029.1000

    P3: e8d8

    P4:  

     

    And since this is windows service, no user will response to this albert so I saw lots of hanging processes.

     

    The questions is: Why our Excel need to access to Office Document Cache? And how can resolve this issue so I don’t need to manually reboot the server everyday…

    Saturday, December 3, 2011 5:41 PM

Answers

All replies

  • I think the error is refering to the history log of recent files opened from office.  The recent files are in the registry so when you open a new file you can see the list.  There is an option in workbooks.open() method called AddToMru to disable the update of recent files.  The default is False.  Are yo setting it True?  See following webpage

    http://msdn.microsoft.com/en-us/library/microsoft.office.interop.excel.workbooks.open(v=office.14).aspx

    I think you are running Office 2010 SP1 June 2008. 
    14.0.6029.1000 is the version of the following file :
    Sharepointdesigner2010sp1-kb2460057-x86-fullfile-en-us.exe

    I would download the latest updates to the sharepoint if you haven't already.


    See websites below. 

    http://social.technet.microsoft.com/Forums/en-US/projectprofessional2010general/thread/c6ff85fe-1126-4955-a549-28b187d08eb9/

    http://support.microsoft.com/kb/2532118

     

    You mave want to check the Event Logs on the SharePoint to get additional information on your problem.


    jdweng
    Saturday, December 3, 2011 9:59 PM
  • Hi Joel,

    Thanks for your help! Following is the open method I'm using:

     eBook = Workbookstemp.Open(
                                uri, /*File location*/
                                2, /* */
                                false, /* Do not open in read only mode */
                                Type.Missing, /* Format omitted */
                                Type.Missing, /* Password omitted */
                                Type.Missing, /* Write protection password omitted */
                                true, /* Ignore read only recommended */
                                XlPlatform.xlWindows, /* Originated operating system */
                                Type.Missing, /* Delimiter omitted */
                                false, /* Omitted */
                                false, /* Do not add to notification list */
                                0, /* Default file converter for unrecognized file*/
                                false, /* Do not add to recent list */
                                true, /* Save in local language */
                                XlCorruptLoad.xlNormalLoad /* Action when file corrupted */
                                );
    


     My Excel version number is: 14.0.6112.5000

    And Yes, I have installed SharePoint in my production server, after that the issue came out. Why SharePoint related to this issue? Because I have disabled all the SharePoint services and IIS application pool, but the issue is still there. Are you saying the Office Document Cache was installed by SharePoint? If this is the issue I would uninstall SharePoint because I have to ensure my Windows Service running well.  BTW, can I disable Office Document Cache?

    BTW, I have disabled SharePoint so I cannot find a way to check the version number of SharePoint...



    • Edited by SSAS_user Sunday, December 4, 2011 3:25 AM
    Sunday, December 4, 2011 3:08 AM
  • Your error message that you posted is refering to a SharePoint Release number and not the Excel Version.

    Do you want to repair this problem?

    P1: 701941

    P2: 14.0.6029.1000

    P3: e8d8

    P4:  

     

    I suspect the problem is with running a script that opens and closes a large number of workbooks.  I think everytime a workbook is opened the filename is going into a cache and eventually the cache fills up.  My one question is "Does the error messages start at the same time the script starts or does the error messages start later"?


    jdweng
    Sunday, December 4, 2011 10:17 AM
  •  My one question is "Does the error messages start at the same time the script starts or does the error messages start later"?

    Yes, exactly the same time. I have checked those hanging Excel processes, the start time match the alert time in Event view. And the number of alerts also matched the Excel Processes which means all the Excel was trying to access to the cache... Besides that, the Memory of those Processes are amost same: 14 M. If I open the Excel application with nothing the memory is 14 M as well. So I guess my windows service can only create Excel object but cannot open the excel due to alert throwing out, but no user response to this alert of cause...

    If the alert came out from SharePoint why the title is Microsoft Excel? And you are right, my service opens and closes a large number of workbooks...

    How can I disable cache? So my service can back to before keep running stable.  Thank you Joel!

    BTW, after disable SharePoint service the issue still exists ... I guess I haven't disalbe all the things SharePoint related. Or you can let me konw uninstall which program can fix this issue

     





    • Edited by SSAS_user Sunday, December 4, 2011 2:52 PM
    Sunday, December 4, 2011 2:41 PM
  • I guess you are right, my SharePoint version should be 14.0.6029.1000, I will check with my colleague later.
    Sunday, December 4, 2011 3:00 PM
  • I would think your sharepoint should be newer since 14.0.6029.1000 since this file is June 2008, but not sure.  Also check on the sharepoint if there any errors in the Event logs.
    jdweng
    Sunday, December 4, 2011 9:51 PM
  • Hi Joel,

    I have checked with my colleague, the version number is 14.0.4762.1000.

    For the error message, every five Minutes there would be an error:

    "Event 5586 (SharePoint Foundation) of severity 'Error' occurred 10 more time(s) and was suppressed in the event log"

    Since I disabled the SharePoint releated service then this error show up. If I cannot find how to disable the cache then I would try to uninstall SharePoint but I'm not sure if I can uninstall SharePoint clearly... The worst situation is the issue still exists after uninstall.

    Thank you Joel!

    Monday, December 5, 2011 2:14 AM
  • Monday, December 5, 2011 2:52 AM
  • Thanks for the links.

    I konw the reason of this error, because I disabled the SharePoint services so it should return this error. But I don't think this error related to my issue.

    And I think there is no issue of my SharePoint site although I have disabled it. The Office Document Cache is just a function/feature. I want to konw 1) is this 'Office Document Cache' installed by SharePoint? 2) How can I disable the 'Office Document Cache'?  

    Monday, December 5, 2011 7:47 AM
  • You said the following:

    "Event 5586 (SharePoint Foundation) of severity 'Error' occurred 10 more time(s) and was suppressed in the event log"

    If the sharepoint was really disables how come you are getting this error? I still think there is a link or an SQL that exist referencing the SharePoint.  You ned to check your Defined Names and check if there is any externalk links like queries that exist beteen the client and server.  I think the only way of verifying for sure is to check the SharePoint Log files to see if any messages occured at the same time you ran you program.  From the websites, it seems there is an incompatibility between the sharepoint and the PC is version installed and/or the number of parameters don't match.

     

    I don't know if it is easy but maybe copy an existing excel workbook to a new workbook by copying each worksheet one at a time and using Pastespecial (values, then formats).  This will remove any hidden queries and links that may exist in the workbook.  Then try your program again to see if you get the same error message.

    Error messages:
    ==============
    Log Name:      Application
    Source:        Microsoft-SharePoint Products-SharePoint Foundation
    Event ID:      5586
    Task Category: Database
    Level:         Error
    Description:
    Unknown SQL Exception 8144 occurred. Additional error information from SQL Server is included below.
    Procedure or function proc_GetDatabaseInformation has too many arguments specified.


    jdweng
    Monday, December 5, 2011 1:38 PM
  • The alert message logged into Event view at 11/26/2011 1:06:30 PM:A problem occurred while accessing the Office Document Cache.

    I checked the SharePoint log and find:

    11/26/2011 13:06:29.16  OWSTIMER.EXE (0x1DA4)                    0x28F4 SharePoint Foundation          Monitoring                     b4ly Medium   Leaving Monitored Scope (Timer Job SchedulingUnpublish). Execution Time=1.5728 ddba86fc-e103-44e4-9a00-3c80f48c2d5f
    11/26/2011 13:06:30.40  w3wp.exe (0x14AC)                        0x0BA4 Excel Services Application     Excel Calculation Services     8jg2 Medium   ResourceManager.PerformCleanup: Memory Manager: CurrentSize=404471808. 53fed7f1-3175-516a-0000-000050f7b00c
    11/26/2011 13:06:32.19  OWSTIMER.EXE (0x1DA4)                    0x31EC SharePoint Foundation          Monitoring                     nasq Medium   Entering monitored scope (Timer Job job-application-server-admin-service) 2bb6001e-97b0-40a8-86f4-0de5e9072d91

    For the version number P2: 14.0.6029.1000, I'm not sure the meaning of this number, but I test the Excel, all the alerts related to this number. For example, create a new Excel, input something and then close the Excel without saving, then the alert logged into event view:

    Microsoft Excel

    Do you want to save the changes you made to 'Book1'?

    P1: 100216

    P2: 14.0.6029.1000

    P3:

    P4:

    The issue happend 4 times in total. And to reproduce this issue,  I need to keep the server running over 2 days... but I reboot server every day from last time issue occured. So the last time the issue happened is 11/29.

    Thank you Joel!

    Monday, December 5, 2011 3:17 PM
  • From this KB: http://support.microsoft.com/kb/2295835

    Documents are cached for offline access in the Office Document Cache in the following scenarios:

    • Documents are opened in Edit mode and are not opened anonymously. 

    It seems the Excel may access to the Office Document Cache indeed. I have only one excel need to upload to another SharePoint site, but I have 170+ Excel need to running every day. I cannot explain why this issue happend to all the Excel.

    Monday, December 5, 2011 3:25 PM
  • I just found an insteresting thing, every time the alert was generated, an event will log into SharePoint log at the same time:

    11/26/2011 13:45:31.11  w3wp.exe (0x14AC)                        0x0BA4 Excel Services Application     Excel Calculation Services     8jg2 Medium   ResourceManager.PerformCleanup: Memory Manager: CurrentSize=405057536. 53fed7f1-3175-516a-0000-000050f7b00c

    Monday, December 5, 2011 3:48 PM
  • Monday, December 5, 2011 7:12 PM
  • Thank you!

    I started SharePoint and then disable all the features/functions related to Excel, after that disable SharePoint again. Now there is no error from SharePoint... and I will let my colleague to add another funtion to my windows service, it will kill the process msosync.exe when it come out (I just cannot find a way to disable this process, I tried hard but I don't want to modify regedit). I will not reboot the server so let's see if this issue happend again in this week. Hope this works!

     

     

    Tuesday, December 6, 2011 1:56 PM