none
Page Layout and Text Layout Buttons Disabled on Ribbon

    Question

  • I am trying to create a publish site in Sharepoint 2010, and I am using the Ribbon control.  Currently, I am having trouble adding and changing content on my site, due to both the Page Layout and Text Layout buttons being disabled.  I have been trying to figure out what security or feature needs to be active to get these enabled again.  Any help would be appreciated.
    Thursday, January 07, 2010 4:30 PM

Answers

  • Brendon,

    Many thanks for you solution; this did not quite work for my own circumstance; but it worked as a basis for a my own steps which are not too dissimilar to yours: -

    1. Edit Page - Can follow your steps or just "Edit"
    2. Click Save & Close drop down and select "Save and Keep Editing"
    3. Page Layouts is now available

    Will look forward to reading your blog post if you can come up with a reason why the ribbon is behaving this way. 

    Wednesday, July 21, 2010 7:28 AM
  • I skimmed throught these responses so I appologize if someone already said this. But to clear up an confusion:

    In SharePoint 2010 you either have Text Layouts or Page Layouts, you typically wouldn't have both buttons available (note they are also on different tabs in the ribbon). When you activate the publishing features or if you started with one of the publishing site templates,  you will have the page layout button available and the text layout button will be grayed out. Alternatively if you aren't editing a publishing page, you are most likely editing a wiki page and have the text layout button available to you.

    The final alternative would be if you manually create a web part page, this has neither option (you pick a "layout" when its being created).


    Randy Drisgill - MVP SharePoint Server
    SharePoint911 Branding and Design Services
    My Blog: http://blog.drisgill.com
    Wrox: Professional SharePoint 2010 Branding and UI Design
    Thursday, October 14, 2010 6:43 PM
  • For those of you who have lost many hours searching through the web for the simple answer to the simple question of "I don't see a Page Layouts and Site Templates link under Look and Feel" and could not find it, here is the solution: The Page Layouts and Site Templates is a sub-feature of SharePoint Server Publishing, when you enable it, the darn button appears. And I don't understand why nobody can tell us this, and why this is not documented properly. My guess is, people usually enable each and every one of the feature set and never even experience this issue. Anyway, the SharePoint Server Publishing feature is a Site Collection feature, so you need to:

    Site Settings / Site Collection Administration / go to top level site settings

    Site Settings / Site Collection Administration / Site collection features / SharePoint Server Publishing Infrastructure -> Enable

    Now, you need to enable the same feature on your sub site. Go to your site:

    Site Settings / Site Actions / Manage Site Features / SharePoint Server Publishing -> Enable

    And finally, you will be able to see "Page Layouts and Site Templates" under Look and Feel.

    If you cannot, drop me an email and I will try to walk you through: ihsancem [obvious sign] gmail.com

    One simple thing, nobody helps, nobody explains, nobody documents, hours spent! I hate these inter-twined entangled feature sets. But I do love SharePoint none-the-less

    Cheerios


    the art of peace begins with you
    Friday, February 25, 2011 4:27 PM
  • FYI, as a workaround, I simply added the site actions menu twice to my page, but in the one before the ribbon, I wrapped it in a hidden div. All you need is the "Create Page" action in the first site actions menu. The key to remember is that you need give your second (visible) site actions menu a different ID than your first (hidden) control.

    <div style="display:none;">
    					<SharePoint:SiteActions runat="server" accesskey="<%$Resources:wss,tb_SiteActions_AK%>" id="SiteActionsMenuMain"
    						PrefixHtml=""
    						SuffixHtml=""
    						MenuNotVisibleHtml="&amp;nbsp;">
    						<CustomTemplate>
    						<SharePoint:FeatureMenuTemplate runat="server"
    							FeatureScope="Site"
    							Location="Microsoft.SharePoint.StandardMenu"
    							GroupId="SiteActions"
    							UseShortId="true"
    							>
    							<SharePoint:MenuItemTemplate runat="server" id="MenuItem_EditPage"
    								Text="<%$Resources:wss,siteactions_editpage%>"
    								Description="<%$Resources:wss,siteactions_editpagedescriptionv4%>"
    								ImageUrl="/_layouts/images/ActionsEditPage.png"
    								MenuGroupId="100"
    								Sequence="110"
    								ClientOnClickNavigateUrl="javascript:ChangeLayoutMode(false);"
    								/>
    						</SharePoint:FeatureMenuTemplate>
    						</CustomTemplate>
    					  </SharePoint:SiteActions>
    					 </div>


    Blog: blog.beckybertram.com | RSS | @beckybertram | SharePoint 2010: Six-in-One

    Thursday, March 08, 2012 6:23 PM

All replies

  • Never mind on the page layout button, I figured out why that wasn't working.  Now to get the Text Layout enabled.
    Thursday, January 07, 2010 4:47 PM
  • Hello Richard,

    could you please tell me your solution for the page layout button problem.

    Thanks.
    Dave
    Thursday, March 04, 2010 2:19 PM
  • hi, can you share why the Page Layout button is disabled? thanks!
    Friday, March 12, 2010 2:41 AM
  • I get the Layout Button problem all the time. It must be a bug. I usually refresh the page click edit page again and it will be enabled. Also make sure in the Site Settings  under "Look and Feel" -- >"Page Layouts and site Templates" page that you have page layouts available for use on the current web.

    David Opdendries
    ----------------------
    Blog
    Friday, March 12, 2010 11:01 AM
  • I got to your blog because I have the problem that I don't see the Page Layout button too.  But what is more I don't have the "Page Layouts and site Templates: menu under the "Look and Feel" that you mention above.

    Does anyone know whether there is a Microfoft document that outlines what features and buttons are enabled or disabled at a particular point?

    Thursday, May 27, 2010 9:01 PM
  • I'm also having the same problem, page layout is disabled in the ribbon.  I checked under "Page Layouts and Site Templates" and I have "Pages in this site can use any layout" enabled.  I tried enabling "Pages in this site can only use the following layouts" and adding a couple to it to no avail. 

    Any other ideas?

    OK, so if I add a new page, I can change the page layout.  After the first time I save and close the page, I can no longer change the page layout if I edit the page?  Am I just doing something wrong here?

    Friday, May 28, 2010 3:54 PM
  • same problem here, page layout button is disabled. usually works with refresh, but not always. Someone has a solution?

     

    grtz

     

     

    Tuesday, June 29, 2010 7:01 AM
  • What page type are you creating? Is it a Publishing Page? If so when do you see the Page Layout button being disabled?
    Regards,
    Chakkaradeep || SharePoint Solutions Specialist - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Tuesday, June 29, 2010 8:12 AM
  • We have noticed that as soon as you save, check-in or publish a page the page layout is disabled when you next go to edit the page to change the layout. If however you create the page and change the layout it works fine; however as soon as you then save etc... you are in the same scenario. This happens no matter which publishing pages we use, OOTB or custom; not too sure whether it is a 'feature'.

    --- Update --- Have noticed on a page which inherits it's master directly from v4 master this is not a problem; as our master page uses this directly as a base, I can not see what is the difference.

    --- Update --- We are not too sure whether this is related, but as we have split out our Site Actions from our Ribbon for our  design, this might be causing the problem; if the Site Actions is moved back into the Ribbon Control (TabRowLeft) then the problem seems to go away.... Surely these components are not mutually exclusive.

    Monday, July 19, 2010 12:35 PM
  • Verify that you have performed the following steps to get the Page Layout button to show up and assuming you have it enabled in the site settings and you have the right permissions, follow these steps on a page to get it to show up.

    1. Click the Check-out button on the Page tab
    2. Next on the Edit tab click the Edit button on the Page tab
    3. Now in Edit mode, click the Page tab once again
    4. The Page Layout tab is now ready to use!

    Hope that helps and will put full post with pictures up.

    Not sure on the question about having the site actions and ribbon together.

    http://blogs.sharepointguys.com/brendon

    Tuesday, July 20, 2010 2:55 PM
  • Brendon,

    Many thanks for you solution; this did not quite work for my own circumstance; but it worked as a basis for a my own steps which are not too dissimilar to yours: -

    1. Edit Page - Can follow your steps or just "Edit"
    2. Click Save & Close drop down and select "Save and Keep Editing"
    3. Page Layouts is now available

    Will look forward to reading your blog post if you can come up with a reason why the ribbon is behaving this way. 

    Wednesday, July 21, 2010 7:28 AM
  • Brendon - I have the exact same issue... could it be that you have a custom master page, and furthermore could it be that you're fixing the ribbon container in a div at the top of the page?.. at any rate, if you found the cause let me know please! it's a bit puzzling..
    Alex Talarico
    Wednesday, September 22, 2010 11:33 PM
  • Page Layout button disabled when using custom master page

    The same problem was happening to me when I was creating my own master page. Setting the new master page as the default master master page, then creating a new page layout, setting the new page layout as the default layout, and then creating a new page seemed to help.

    1. Set master page as default (Site Actions > Site Settings > (Look and Feel) Master Page > under "Site Master Page" section, select the new master page
    2. Create a new page layout (Site Actions > Site Settings > (Galleries) Master Pages and Page Layouts > (Documents ribbon) New Document > Page Layout > Defaults were ok
    3. Set the new layout as the default layout (Site Actions > Site Settings > (Look and Feel) Page Layouts and Site... > (New Page Default Settings) select the newly created page layout
    4. Create a new page (Site Actions > New Page)
    After this the newly created page has the page layouts enabled
    Monday, September 27, 2010 5:21 PM
  • putting the page in Edit mode enabled the Page Layout button and allowed me to change the underlying page layout.

    Thanks, Brendon!

    Thursday, October 14, 2010 4:14 PM
  • I skimmed throught these responses so I appologize if someone already said this. But to clear up an confusion:

    In SharePoint 2010 you either have Text Layouts or Page Layouts, you typically wouldn't have both buttons available (note they are also on different tabs in the ribbon). When you activate the publishing features or if you started with one of the publishing site templates,  you will have the page layout button available and the text layout button will be grayed out. Alternatively if you aren't editing a publishing page, you are most likely editing a wiki page and have the text layout button available to you.

    The final alternative would be if you manually create a web part page, this has neither option (you pick a "layout" when its being created).


    Randy Drisgill - MVP SharePoint Server
    SharePoint911 Branding and Design Services
    My Blog: http://blog.drisgill.com
    Wrox: Professional SharePoint 2010 Branding and UI Design
    Thursday, October 14, 2010 6:43 PM
  • I think Jules was on the right path here when you mentioned the site actions being outside of the ribbon, but that isn't the whole story. I've been playing around with a new master page and hit the same issue. After further investigation I found that the SiteActions doesn't need to be inside of the SPRibbon, but rather it needs to be BEFORE it on the master page. I have tried this every which way I can think of but for whatever reason the "Page Layout" control becomes disabled as soon as I move the SiteActions after the SPRibbon.

    I hope this helps.


    Chris Arella - Sr. Solutions Architect
    SharePoint User Experience, Branding and Design
    http://www.chrisarella.com
    Friday, December 24, 2010 3:52 AM
  • I was having this same problem, and also had a few other buttons not working.  After researching a few I realized after adding: 

     

    <asp:ContentPlaceHolder ID="SPNavigation" runat="server">
                       <SharePoint:DelegateControl runat="server" ControlId="PublishingConsole">
                       </SharePoint:DelegateControl>
    </asp:ContentPlaceHolder>

     

    Inside my ribbon at the very top fixed everything, Page layout worked fine, edit button worked fine etc.


    Matt
    Monday, January 03, 2011 3:01 PM
  • For those of you who have lost many hours searching through the web for the simple answer to the simple question of "I don't see a Page Layouts and Site Templates link under Look and Feel" and could not find it, here is the solution: The Page Layouts and Site Templates is a sub-feature of SharePoint Server Publishing, when you enable it, the darn button appears. And I don't understand why nobody can tell us this, and why this is not documented properly. My guess is, people usually enable each and every one of the feature set and never even experience this issue. Anyway, the SharePoint Server Publishing feature is a Site Collection feature, so you need to:

    Site Settings / Site Collection Administration / go to top level site settings

    Site Settings / Site Collection Administration / Site collection features / SharePoint Server Publishing Infrastructure -> Enable

    Now, you need to enable the same feature on your sub site. Go to your site:

    Site Settings / Site Actions / Manage Site Features / SharePoint Server Publishing -> Enable

    And finally, you will be able to see "Page Layouts and Site Templates" under Look and Feel.

    If you cannot, drop me an email and I will try to walk you through: ihsancem [obvious sign] gmail.com

    One simple thing, nobody helps, nobody explains, nobody documents, hours spent! I hate these inter-twined entangled feature sets. But I do love SharePoint none-the-less

    Cheerios


    the art of peace begins with you
    Friday, February 25, 2011 4:27 PM
  • I think for most of the people here this wasn't the same issue. Some people had problems with configurations, other had issues around customizations they made to master pages. There is no simple answer. If you didnlt customize anything (like the master page) and everything is OOB then check your configurations (feastures, permissions, etc.), or follow the recomended steps for editing pages mentioned a few times above. But if you are working with a custom master page then see my earlier post, or Matt Vore's above. Your problem could be related to repositioning content palceholders and controls incorectly.
    Chris Arella - Sr. Solutions Architect
    SharePoint User Experience, Branding and Design
    http://www.chrisarella.com
    Monday, February 28, 2011 1:31 PM
  • Hi Randy,

    I was actually working through chapter 5 in your book, Randys Waffles are swell by the way, I got to a part where I wanted to use Text Layout to change the layout to show two columns and a header when I noticed that the Text Layout button is not  on the ribbon at all. Not there. So, I went to another site in this site collection and, created a new page and BINGO the Text Layout button is there. My 'Randys Waffles' site was created using the Group Work Site Template, while the the other site was created using the Team Site template. Do the templates make a difference in this behavior?

    Thanks,

    davidh


    davidh
    Friday, April 01, 2011 5:46 PM
  • I was having the same problem, Chris Arella's post fixed the issue for me. 

    I had a custom MasterPage and based on the design I was given the Site Actions menu was moved outside of the ribbon area.  It worked fine until the ribbon was moved to the very top of the page above the Site Actions and then the Page Layouts item was disabled.

    So the fix for me was to make sure the Site Actions menu came before the rest of the ribbon controls.

    Monday, May 02, 2011 6:04 PM
  • Can you please tell how did you move the ribbon below site actions button. Because, When I did it, the position of the ribbon changed to bottom and there were few more alignment issues induced!
    Vijay
    Wednesday, June 01, 2011 8:15 AM
  • Can you please tell how did you move the ribbon below site actions button. Because, When I did it, the position of the ribbon changed to bottom and there were few more alignment issues induced!
    Vijay


    This is probably off topic, but...

     

    If you are editing a copy of v4.master, select the DIV with the ID "s4-ribbonrow" wrapping the entire ribbon, cut it, then place it where you want. In the code, the opening tag looks like this:

    <div id="s4-ribbonrow" class="s4-pr s4-ribbonrowhidetitle">

    Now I'm not sure what you are trying to do exactly regarding placement, but if you are trying to put it between the top nav and the content area you'd stick anywhere before the opening tags of the DIV with the ID "s4-mainarea." In the code, the opening tag looks like this:

    <div id="s4-mainarea" class="s4-pr s4-widecontentarea">

    You'd then pull out the entire SPAN (and it's contents) with the ID "siteactiontd" and place it anywhere above the DIV with the ID "s4-ribbonrow". In the code, the opening tag looks like this:

    <span class="ms-siteactionsmenu" id="siteactiontd">

    Again, I don't know where you're looking to relocate the Site Actions but just make sure it is before the SharePoint:SPRibbon. One thing you could do is place it within the #s4-topheader2 and left-float it to the right of the top navigation. If you do this I'd recomend you either change the SPAN tag to a DIV or place it in a new DIV so you have better control over it's position. Then apply CSS to float it. You'd want to do this because the navigation and search area both have floats on them and you'll need to compensate in your own CSS to position it correctly. Also, I'd probably recomend you move the search area somewhere like up into the title title row. Reason being, leaving the search area where it is cuts down on the usable space for your navigation. It is also better usability having it prominantly displayed in the traditional top-right part of your site banner.

    So now you are left with the question... what are you doing with the GlobalBreadCrumbNavPopout? You could move it with the site actions I guess, or keep it with the ribbon. If you decide to move it out of the ribbon you can delete the SPRibbonPeripheralContent wrapping them both since they are no longer needed.

    As you can see, there are a lot things to consider when you decide to move things around in SharePoint. Good luck.


    Chris Arella - Sr. Solutions Architect
    SharePoint User Experience, Branding and Design
    http://www.chrisarella.com

    Wednesday, June 01, 2011 1:09 PM
  • For those of you who have lost many hours searching through the web for the simple answer to the simple question of "I don't see a Page Layouts and Site Templates link under Look and Feel" and could not find it, here is the solution: The Page Layouts and Site Templates is a sub-feature of SharePoint Server Publishing, when you enable it, the darn button appears. And I don't understand why nobody can tell us this, and why this is not documented properly. My guess is, people usually enable each and every one of the feature set and never even experience this issue. Anyway, the SharePoint Server Publishing feature is a Site Collection feature, so you need to:

    Site Settings / Site Collection Administration / go to top level site settings

    Site Settings / Site Collection Administration / Site collection features / SharePoint Server Publishing Infrastructure -> Enable

    Now, you need to enable the same feature on your sub site. Go to your site:

    Site Settings / Site Actions / Manage Site Features / SharePoint Server Publishing -> Enable

    And finally, you will be able to see "Page Layouts and Site Templates" under Look and Feel.

    If you cannot, drop me an email and I will try to walk you through: ihsancem [obvious sign] gmail.com

    One simple thing, nobody helps, nobody explains, nobody documents, hours spent! I hate these inter-twined entangled feature sets. But I do love SharePoint none-the-less

    Cheerios


    the art of peace begins with you

    Thank You!!..It worked after activating the "Publishing" features on the site collection level as well as on the site level.
    • Edited by Mahendarb Thursday, December 22, 2011 11:04 PM
    Thursday, December 22, 2011 11:03 PM
  • FYI, as a workaround, I simply added the site actions menu twice to my page, but in the one before the ribbon, I wrapped it in a hidden div. All you need is the "Create Page" action in the first site actions menu. The key to remember is that you need give your second (visible) site actions menu a different ID than your first (hidden) control.

    <div style="display:none;">
    					<SharePoint:SiteActions runat="server" accesskey="<%$Resources:wss,tb_SiteActions_AK%>" id="SiteActionsMenuMain"
    						PrefixHtml=""
    						SuffixHtml=""
    						MenuNotVisibleHtml="&amp;nbsp;">
    						<CustomTemplate>
    						<SharePoint:FeatureMenuTemplate runat="server"
    							FeatureScope="Site"
    							Location="Microsoft.SharePoint.StandardMenu"
    							GroupId="SiteActions"
    							UseShortId="true"
    							>
    							<SharePoint:MenuItemTemplate runat="server" id="MenuItem_EditPage"
    								Text="<%$Resources:wss,siteactions_editpage%>"
    								Description="<%$Resources:wss,siteactions_editpagedescriptionv4%>"
    								ImageUrl="/_layouts/images/ActionsEditPage.png"
    								MenuGroupId="100"
    								Sequence="110"
    								ClientOnClickNavigateUrl="javascript:ChangeLayoutMode(false);"
    								/>
    						</SharePoint:FeatureMenuTemplate>
    						</CustomTemplate>
    					  </SharePoint:SiteActions>
    					 </div>


    Blog: blog.beckybertram.com | RSS | @beckybertram | SharePoint 2010: Six-in-One

    Thursday, March 08, 2012 6:23 PM