none
Search Results not displaying document Titles nor Name RRS feed

  • Question

  • We've come across an issue where SharePoint isn't displaying the document Title nor the Name in the search results for some word documents.  These documents appear to be mostly templated documents as they are primarily policies, project plans, meeting minutes and the like.  The search results for these documents actually display the first text in the document as the document title/name.  This seems to be only happening with Word documents as all other formats are working like expected. 
    Nick Hurst
    Tuesday, February 8, 2011 5:13 PM

Answers

  • Configuration for this feature is kept in Windows Registry of SharePoint server and can be turned off by performing the following simple steps.

    1. Open registry for editing by typing “regedit.exe” in Start > Run
    2. Navigate to the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\14.0\Search\Global\Gathering Manager]
    3. Change the hexadecimal value for EnableOptimisticTitleOverride to 0 (zero) on the right hand side.
    4. Restart SharePoint Search service by typing the following commands in command prompt.
      net stop osearch14
      net start osearch14
    5. Perform a full crawl

    I have't done any testing to see if the registry change has any potential consequences on any other SharePoint functionalities.

    • Proposed as answer by Steve.Curran Wednesday, March 30, 2011 8:18 PM
    • Marked as answer by Nick Hurst Wednesday, March 30, 2011 8:27 PM
    Wednesday, March 30, 2011 7:46 PM
  • You can file it as a bug with Microsoft Premier Support. It may be fixed in SP1.
    Blog | SharePoint Field Notes Dev Tool | ClassMaster
    • Marked as answer by Nick Hurst Monday, March 7, 2011 4:27 PM
    Wednesday, February 9, 2011 1:52 AM

All replies

  • This is a bug. When the word document is crawled and indexed, the indexer determines that the first text is more relevant than the actual Title property of the word document. Why I don't know, but it seems to only happen on Word 2007 files.
    Blog | SharePoint Field Notes Dev Tool | ClassMaster
    Tuesday, February 8, 2011 7:49 PM
  • Interesting, I had assumed that the Title just wasn't getting indexed.  But I tested it and your right, the Title is getting crawled.  Do you know of any solution to get the Title to display for these documents?  We have 1000's of documents that this is going to effect if we continue with our migration.  This essentially makes sharepoint search results unusable if you have templated documents because they appear to have the same document title since the introductory text on all these documents are the same. 

    Thanks in advance for any additional information!


    Nick Hurst
    Wednesday, February 9, 2011 12:19 AM
  • You can file it as a bug with Microsoft Premier Support. It may be fixed in SP1.
    Blog | SharePoint Field Notes Dev Tool | ClassMaster
    • Marked as answer by Nick Hurst Monday, March 7, 2011 4:27 PM
    Wednesday, February 9, 2011 1:52 AM
  • Yup...I agree with Steve regarding the "Title" field bug. But, we can modify the XSLT to display the "Name" field from the Document Libraries. We can find a crawled property "ows_linkfilename" and we can map that crawled property to our desired name and list it in the search core results "Fetched Properties". Modify the "Title" section in the xslt to display the value from this field. Thanks! 

    Monday, March 21, 2011 2:48 PM
  • True but that unfortunately would apply to all search results and not just 2007 documents.  The other problem is you would still have scoped searches going to the OSSSearchResults page which is not a webpart page. 

    At the end of the day I still want Title to be displayed regardless of the type of search result.  We have a support call scheduled and hopefully there is some sort of fix for this.  I'm very wary of trying to move to the 2010 platform for production considering the number of 2007 word documents our organization has.


    Nick Hurst
    Thursday, March 24, 2011 4:55 PM
  • Configuration for this feature is kept in Windows Registry of SharePoint server and can be turned off by performing the following simple steps.

    1. Open registry for editing by typing “regedit.exe” in Start > Run
    2. Navigate to the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\14.0\Search\Global\Gathering Manager]
    3. Change the hexadecimal value for EnableOptimisticTitleOverride to 0 (zero) on the right hand side.
    4. Restart SharePoint Search service by typing the following commands in command prompt.
      net stop osearch14
      net start osearch14
    5. Perform a full crawl

    I have't done any testing to see if the registry change has any potential consequences on any other SharePoint functionalities.

    • Proposed as answer by Steve.Curran Wednesday, March 30, 2011 8:18 PM
    • Marked as answer by Nick Hurst Wednesday, March 30, 2011 8:27 PM
    Wednesday, March 30, 2011 7:46 PM
  • The EnableLastModifiedOverride also works. The crawler also overrides this property as well. Nice find.


    Blog | SharePoint Field Notes Dev Tool | ClassMaster
    Wednesday, March 30, 2011 8:20 PM
  • Confirmed with a Senior Premier Field Engineer from Microsoft that the this is a valid fix and they are already working on a KB article describing this.
    Thursday, April 7, 2011 8:00 PM
  • Hi. Do you have the link for this KB??

    Thanks!

    Monday, August 13, 2012 10:21 AM
  • Saji,

    It will be great, If you can share the KB article for the same

    Thanks


    Manoj Mittal

    Friday, May 20, 2016 6:26 AM