locked
Issue with editing webpart in customized masterpage RRS feed

  • Question

  • Hi everyone,

    I'm creating a master page for a MOSS 2007 site, using Heather Solomon's minimal master page for a collaboration portal (which is what the site is also).

    I've done pretty well so far but am having some issues with the web part tool pane.  Namely, when I click on Edit Web Part, everything loads but the tool pane for the web part (and the rest of the page content for that matter) gets squished into a "box" that's less than 1" in height.

    I am not seeing in the CSS where I can modify this behavior.  I am using a modified core.css file (I copied the original and pointed my master page to it) plus a separate CSS file that I created.  And while I can find the ms-toolbar entries, I'm not seeing anything in there that I can tell to stop doing that. LOL

    Please note that I am most definately a newbie to designing for SharePoint so I'm probably just missing something, but I would really appreciate it if someone could point me in the right direction. :)

    I have screen shots of the behavior but didn't see a way to upload them and I can't upload to most photo websites due to the internet restrictions we have.

    I am testing this in IE 8 btw.  Chrome and Firefox don't work exactly like they should but they at least are editable.

    Thanks!
    Veronica Harris

    • Edited by Veronica Harris Wednesday, June 16, 2010 9:19 PM Added information
    Wednesday, June 16, 2010 9:06 PM

Answers

  • I figured it out on my own.  I added a height declaration to my div and it's now working perfectly.

    <div class="contentarea">

                .contentarea {

                float:right;

                width:850px;

                height:100%;

                margin:0px;

                padding:0px;

                }

    Sorry to have wasted your time. :)

    Veronica

    Monday, June 21, 2010 8:40 PM

All replies

  • Hi Veronica,

     

    It is hard to scope your issue without actually seeing your issue.

    I create a workspace for you, could you please upload some screen shots, the master page your customized and the customized CSS file to me?

    Workspace URL: (https://sftasia.one.microsoft.com/choosetransfer.aspx?key=5d9e1449-5dc1-49bc-9ef6-abfe15a2a314)

    Workspace Password: tNk%KJx_)S^

     

    Lambert Qin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Sincerely,
    Lambert Qin
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, June 17, 2010 1:48 AM
  • Hi Lambert,

    I get the following when trying to access the workspace URL

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
      <system.web>
        <customErrors mode="Off"/>
      </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
      <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
      </system.web>
    </configuration>

    Server Error in '/' Application.

    Runtime Error

     

    Thursday, June 17, 2010 1:23 PM
  • Hi Veronica,

     

    I am afraid for the inconvenience, but I can upload the file without any problem.

     

    As the workspace cannot be access in your side, I create another workspace for you.

    Workspace URL: (https://sftus.one.microsoft.com/ChooseTransfer.aspx?key=d95c8a2a-491b-4a7f-aa67-0d876f8140ce)

    Workspace Password: T5JSe]pGE0

     

    Could you please try to upload again?

     

    Lambert Qin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Sincerely,
    Lambert Qin
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, June 18, 2010 1:28 AM
  • Hi Lambert,

    The 2nd link worked so I have sent you 5 files (screenshots, the master page, and the modified CSS files).

    FWIW, maybe the reason the first link didn't work because it was sftasia and not sftus?

    Thanks!
    Veronica

    Friday, June 18, 2010 1:06 PM
  • Hi Veronica,

     

    Thanks for your cooperation.

     

    I could reproduce your problem, after troubleshooting some time by using Developer Tools with IE8. I found that the contentarea class in wdhstyle.css cause the problem.

    <div class="contentarea">

                .contentarea {

                float:right;

                width:850px;

                margin:0px;

                padding:0px;

                }

     

    If I changed the style to

                .contentarea {

                margin:0px;

                padding:0px;

                }

     

    The issue is no longer existed.

     

    Could you please verify it at your side?

     

    Lambert Qin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Sincerely,
    Lambert Qin
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, June 21, 2010 5:31 AM
  • Hi Lambert,

    Thanks for the reply!  I just rebuilt my machine late Friday, but as soon as I get SP Designer re-downloaded, I will test that and see if it works.  In your environment, when you changed that, did you still get your content area on the right side of the side-bar/quick-launch?

    Thanks!
    Veronica

    Monday, June 21, 2010 1:15 PM
  • Hi Lambert,

    You're right, taking those entries out does fix the issue with the web part editing.

    However, it also puts my entire content area below the quick-launch.  That won't really work, as I'm sure you can understand.

    Any other ideas on how to fix this?  I was really hoping for a more or less table-less design.  Is that impossible?

    Thanks!
    Veronica

    Monday, June 21, 2010 6:44 PM
  • I figured it out on my own.  I added a height declaration to my div and it's now working perfectly.

    <div class="contentarea">

                .contentarea {

                float:right;

                width:850px;

                height:100%;

                margin:0px;

                padding:0px;

                }

    Sorry to have wasted your time. :)

    Veronica

    Monday, June 21, 2010 8:40 PM