none
Search not working RRS feed

  • Question

  • Hi

    I have SharePoint 2016 farm with search configured and was working fine then it stopped working . 

    search is stopped working with the below exception

    There was an exception in the Database. Please retry your operation and if the problem presists, contact an administrator.

    Correlation ID: 3aed029f-865f-907f-74c2-a20a0fc146bb

    However after tried various methods, strange thing i have noticed that with default url http://<<Server name>> search is working fine and with AAM i.e. http://intranet... it's showing exception. Any idea ?

    Tuesday, September 10, 2019 7:29 PM

Answers

  • Hi Wail Ali,

    To troubleshoot the issue, you could replace the default URL with the http://intranet in the content source in search service application.

    There is a similar post:

    https://social.technet.microsoft.com/Forums/office/en-US/e12f28ad-b6b0-47d8-9a0d-fe2e0efd5913/search-is-not-working-in-sharepoint-2016-from-custom-list-box?forum=SP2016

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by Wail Ali Friday, October 4, 2019 3:49 PM
    Wednesday, September 11, 2019 8:09 AM
    Moderator
  • Hi Wail Ali,

    To configure server name mapping, you could go to search service application->crawling in the left navigation->server name mapping.

    You could add the default zone URL in the “Address in index:” and the URL you want to display in the search result into the “Address in search results: *”.

    After configuring server name mapping, you should run a full crawl.

    For more detailed information, refer to the article below.

    Server Name Mappings in SharePoint Search.

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by Wail Ali Friday, October 4, 2019 3:49 PM
    Thursday, September 12, 2019 1:42 AM
    Moderator
  • Hi Wail Ali,

    To troubleshoot the issue, you could remove the AAM settings and reset index in search service application.

    And then re-configure the AAM settings and run a full crawl.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by Wail Ali Friday, October 4, 2019 3:49 PM
    Monday, September 16, 2019 1:25 AM
    Moderator

All replies

  • Hi Wail Ali,

    To troubleshoot the issue, you could replace the default URL with the http://intranet in the content source in search service application.

    There is a similar post:

    https://social.technet.microsoft.com/Forums/office/en-US/e12f28ad-b6b0-47d8-9a0d-fe2e0efd5913/search-is-not-working-in-sharepoint-2016-from-custom-list-box?forum=SP2016

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by Wail Ali Friday, October 4, 2019 3:49 PM
    Wednesday, September 11, 2019 8:09 AM
    Moderator
  • Hi Wali Ali,

    Search generally uses the Default Zone (In your case, it's http://Servername/ ), I recommend to check the "Content Source" in Search Service Application to see if the "http://intranet/" URL has been set.

    If Yes, Have you tried / configured the Server Name Mapping?

    Best Regards,

    Karthick Rajan



    Wednesday, September 11, 2019 8:26 AM
  • Hi Sara My default URL is http:intranet .

    Wednesday, September 11, 2019 12:26 PM
  • Hi Karthick Rajan

    In the search service application the URL has been set .

    how do I configure server name mapping .

    Wednesday, September 11, 2019 12:29 PM
  • Hi Wail Ali,

    To configure server name mapping, you could go to search service application->crawling in the left navigation->server name mapping.

    You could add the default zone URL in the “Address in index:” and the URL you want to display in the search result into the “Address in search results: *”.

    After configuring server name mapping, you should run a full crawl.

    For more detailed information, refer to the article below.

    Server Name Mappings in SharePoint Search.

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by Wail Ali Friday, October 4, 2019 3:49 PM
    Thursday, September 12, 2019 1:42 AM
    Moderator
  • Hi Sara Fan

    I configured the name mapping , how do I run a full crawl .

    Thursday, September 12, 2019 11:59 AM
  • Hi Sara Fan

    I ran the full crawl and the search still not working , any idea .

     

    Thursday, September 12, 2019 12:03 PM
  • Hi Wail Ali,

    The AAM and server name mapping cannot be applied at the same time.

    Then you could select to use AAM or server name mapping.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, September 13, 2019 5:55 AM
    Moderator
  • Hi  Sara Fan Still the search not working , any ideas ?

    Friday, September 13, 2019 12:04 PM
  • Wail - can you be more specific?  Please provide detailed descriptions of what exactly you mean by "not working".  This helps us to more effectively troubleshoot the problem you are experiencing.
    Saturday, September 14, 2019 5:15 PM
  • Hi Wail Ali,

    This could be due to many reason - however you may check the below:

    1. In your content source try to give your AAM URL not server url.

    2. Then run the full crawl.

    If above does not work - verify the firewall for TCP port between APP and Front End server:

    For tcp port issue in SharePoint 2016 search you may refer the below URL:

    https://global-sharepoint.com/2018/11/18/how-to-fix-request-timed-out-error-in-sharepoint-2016-search/

    If nothing works - try to create one more test AAM URL and configure this in the content source, I believe this is the issue with AAM - I also had faced the similar issue long back however, using these back and forth trial troubleshooting it had got fixed. I remember it was the issue with AAM.



    Thanks&Regards,

    Habibur Rahaman

    MCSA,MCP,MCTS

    My Certificates

    Note: If you feel the proposed answer is helpful, please mark as so or if this answered your question,please mark as answer.


    • Edited by Habibur Rahaman Sunday, September 15, 2019 6:51 AM Added more info
    Sunday, September 15, 2019 6:50 AM
  • Hi Wail Ali,

    To troubleshoot the issue, you could remove the AAM settings and reset index in search service application.

    And then re-configure the AAM settings and run a full crawl.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by Wail Ali Friday, October 4, 2019 3:49 PM
    Monday, September 16, 2019 1:25 AM
    Moderator
  • Hi Stephen

    When I search and the URL is the server name , the search works fine but when I search and the URL is intranet the search is not working .I tried all the above with no result .

    Monday, September 16, 2019 11:51 AM
  • Hi Habibur Rahaman

    The SharePoint is internal to the firewall , it used to work fine and all of a sudden it stopped working .

    Monday, September 16, 2019 11:52 AM
  • Hi Wail Ali,

    To troubleshoot the issue, you could run PSConfig and perform an IISRESET.

    There is a similar post:

    https://community.spiceworks.com/topic/1995100-sharepoint-foundations-search-exception-in-the-database

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, September 17, 2019 7:51 AM
    Moderator
  • What do you see in the Event Viewer?


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 17, 2019 9:03 AM
  • Hi Wail Ali,

    How is everything going?

    Is there anything update about this issue?

    Best regards,

    Sara Fan

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, September 18, 2019 9:21 AM
    Moderator
  • Hi Sara Fan

    Still not working .

    I have a question for you under name mapping there is two options one is addressing the index and the other one is addressing search results , what do I need to put under each one .

    Thursday, September 19, 2019 12:33 PM
  • Hi Wail Ali,

    Address in index: you could type the URL of the web application which will be crawled.

    Address in search results: you could type the address that will be displayed in search results.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, September 20, 2019 8:21 AM
    Moderator
  • Have you checked the sharepoint logs? Search for the co-relation id inside logs. Error will be shown.

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 20, 2019 8:39 AM
  • Hi

    The event log is here

    alternate access mapping has not been configured users or services are accessing the site http:\\co-server75 with the URL http:\\intranet.my company.com.This may cause incorrect links to be stored or returned to users .if this is expected add the URL http:\\intranet.mycompany.com as an AAM response URL


    • Edited by Wail Ali Monday, September 23, 2019 10:38 PM
    Monday, September 23, 2019 10:33 PM
  • Hi Wail Ali,

    To troubleshoot the issue, you should check if you have configured Alternate Access Mapping for the current web application in central administration.

    If you have configured the Alternate Access Mapping, could you please share how you configured the Alternate Access Mapping?

    And you also should add the URL which is configured in Alternate Access Mapping in site binding in IIS.

    More reference:

    A guide to Alternate Access Mappings Basics in SharePoint 2013.

    There is a similar post:

    https://sharepoint.stackexchange.com/questions/70768/alternate-access-mappings-have-not-been-configured

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, September 24, 2019 7:18 AM
    Moderator
  • Hi Sarah

    The search is working now , thank you very much for your help .

    Friday, October 4, 2019 3:50 PM