none
Sharepoint 2013 - Empty project error

    Question

  • Hi to everybody,

    I am starting to develop some solution in sharepoint 2013 foundation in Visual Studio 2012 Ultimate version.

    I installed Microsoft Office Developer Tools for Visual Studio 2012 release in november but when I try to create a Sharepoint 2013 - Empty project the wizard ask me to specify a site to debug my solution, I insert my local site and I validate that with success.

    Unfortunately when I click on the finish button an error message box appears with the following message:

    "An error occured while trying to load some components. Please ensure that the following prerequisites components are installed:

    Microsoft web developer tools

    Microsoft Exchange web services."

    Someone can help me to fix that? This problems drive me crazy :-(!!!

    Many thanks in advance


    Jerry

    Thursday, November 29, 2012 9:59 AM

Answers

  • As crowleyj and Xiaoying have indicated, you most likely don't have the right prerequisites installed (if you aren't missing them altogether). This can happen if you install just the developer tools without the complete set of prerequisites. You could try fixing your setup by closing Visual Studio and then following steps:

    1. Go to Control Panel > Uninstall a program
    2. Select Microsoft Office Developer Tools for Visual Studio 2012 - Preview 2 - ENU
    3. Click on Change to uninstall it. The setup program should launch.
    4. Click on Uninstall to remove the Office Developer Tools.
    5. Download the Office Developer Tools using this Web Platform Installer link from the Get It Now section of the blog announcing the latest release of Office Developer Tools. This Web Platform Installer should install the Office Developer Tools and all the prerequisites (Exchange Web Services, LightSwitch HTML Client, etc).
    6. Try creating your SharePoint 2013 Empty Project again.

    Thanks,

    Saint.

    • Marked as answer by Jerry Lauber Friday, November 30, 2012 10:14 AM
    Friday, November 30, 2012 2:10 AM

All replies

  • Did you install by using the Web Platform Installer (WebPI)? Have you tried using the WebPI to reinstall the Preview-2 version of the tools?

    Thursday, November 29, 2012 10:53 PM
  • Hi Jerry,

    Could you please check the following things and let me know what you find?

    • Go to Visual Studio 2012 About dialog, is the Microsoft Web Developer Tools listed in the dialog?
    • Go to Control Panel --> Add/Remove Program dialog, what versions of Microsoft Exchange Web Services have you installed?

    Thanks,

    Xiaoying


    Xiaoying is a program manager in Microsoft Visual Studio SharePoint Developer Tools team | This post is provided "as-is"

    Thursday, November 29, 2012 10:56 PM
  • To be more accurate about the version of Microsoft Exchange Web Services, is it 32-bits version or 64-bits? The VS tools require 32-bits version of it.

    Thanks,

    Xiaoying


    Xiaoying is a program manager in Microsoft Visual Studio SharePoint Developer Tools team | This post is provided "as-is"

    Friday, November 30, 2012 1:12 AM
  • As crowleyj and Xiaoying have indicated, you most likely don't have the right prerequisites installed (if you aren't missing them altogether). This can happen if you install just the developer tools without the complete set of prerequisites. You could try fixing your setup by closing Visual Studio and then following steps:

    1. Go to Control Panel > Uninstall a program
    2. Select Microsoft Office Developer Tools for Visual Studio 2012 - Preview 2 - ENU
    3. Click on Change to uninstall it. The setup program should launch.
    4. Click on Uninstall to remove the Office Developer Tools.
    5. Download the Office Developer Tools using this Web Platform Installer link from the Get It Now section of the blog announcing the latest release of Office Developer Tools. This Web Platform Installer should install the Office Developer Tools and all the prerequisites (Exchange Web Services, LightSwitch HTML Client, etc).
    6. Try creating your SharePoint 2013 Empty Project again.

    Thanks,

    Saint.

    • Marked as answer by Jerry Lauber Friday, November 30, 2012 10:14 AM
    Friday, November 30, 2012 2:10 AM
  • Hello In my Case

    The solution was:
    Uninstall Web exchange service instances.
    Uninstall Microsoft Office Developer Tools.

    Now using "Webplatform Installer 4", install both and it will work this time. whit VS2012 close before.



    Monday, February 04, 2013 8:58 PM
  • I've got the same problem. Still didn't work for me :-( The Web Platform installer also doesn't list the Exchange Web Services install. I manually downloaded and reinstalled it. But I still get the same error message.

    • Edited by LZandman Wednesday, February 06, 2013 5:36 PM
    Wednesday, February 06, 2013 5:36 PM
  • I managed to fix it and wrote a blog about it:

    http://wp.me/p2woxr-4A

    Thursday, February 07, 2013 10:24 PM
  • WORKING SOLUTION:

    If you have already installed the Microsoft Exchange Web Services, uninstall it from Control Panel and then open up a command prompt. Navigate to the location of EwsManagedApi32.msi.

    In the command prompt, run EwsManagedApi32.msi addlocal="ExchangeWebServicesApi_Feature,ExchangeWebServicesApi_Gac"

    source: http://blogs.msdn.com/b/timquin/archive/2013/01/22/setting-up-visual-studio-2012-for-sharepoint-2013-development-offline.aspx

    Monday, March 18, 2013 8:16 PM
  • This worked well. Thank you very much...
    Wednesday, September 18, 2013 1:15 PM
  • Hi Jerry,
    refer this link, here This issue has been solved with clear description about it.


    Abu Shaeeb

    Friday, January 17, 2014 1:31 PM
  • if you try to create a project for any of these new fun items, you will get the following error:

    An error occurred whilst trying to load some required components, Please ensure the following prerequisite components are installed.

    Microsoft Web Developer Tools

    Microsoft Exchange Web Services"

    The problem is that the Microsoft Web Platform Installer adds parameters when installing the Microsoft Exchange Web Services that must be used in order to get around the error. If you have already installed the Microsoft Exchange Web Services, uninstall it from Control Panel and then open up a command prompt. Navigate to the location of EwsManagedApi32.msi. In the command prompt, run

    EwsManagedApi32.msi addlocal="ExchangeWebServicesApi_Feature,ExchangeWebServicesApi_Gac"

    Please ref the following link for details:  http://blogs.msdn.com/b/timquin/archive/2013/01/22/setting-up-visual-studio-2012-for-sharepoint-2013-development-offline.aspx 


    Frank@Hiweb 冯立超@瀚博资讯

    Sunday, February 09, 2014 3:38 AM