locked
Problem deploying a solution - Never changes from "Deploying" status.

    Question

  •  

    Hi!

     

    I have run into a weird problem. I have developed a feature that I've deployed without trouble on several servers, but this time it wont work! In Central Administration->Operations->Manage solutions the status never changes from "Deploying". Even a day later... The only clue I've got so far is from the log where it states:

     

    "Solution Deployment : Global solution prosjektromdeployment.wsp, deployed to 0 servers. Deployment config object is null"

     

    What is a deployment config object??

     

    The batch file used to deploy it is quite simple:

     

    stsadm -o addsolution -filename ProsjektromDeployment.wsp
    stsadm -o deploysolution -name ProsjektromDeployment.wsp -immediate -allowgacdeployment -allowCasPolicies
    stsadm -o execadmsvcjobs

     

    Am I missing something here?

    Friday, November 16, 2007 11:44 AM

Answers

  • Hm... I noticed there was another server in my farm that I never saw before and it was definitely not running smootly. The search and web-front-end service had failed. I tried stopping them, but now the status never changes from "Stopping". I noticed however that my solution now says "Globally deployed" in addition to the "Deploying" status. Still not available from Site Features, but I feel I got one step further. We will now try to remove this server from the farm, and see if that solves the problem. I will keep you posted!=)

     

     

     

    Edit:

    After removing the defective server from the farm, the solution deployed immediately=) Weeeee!

    Friday, December 14, 2007 10:20 AM

All replies

  • Hi,

     

    Has the solution already been deployed to the server that you are trying to deploy it to?  It seems for other people that have had this error, they are trying to redeploy a solution.

     

    If that is the case, you could try STSADM.Exe -o upgradesolution -f filename.wsp -name name.wsp -immediate - allowgacdeployment -allowcaspolicies

     

    Thanks

     

    Brett Lonsdale

    www.lightningtools.com

     

    Friday, November 16, 2007 1:02 PM
  • I have experienced this when working with two front-end server, in fact the issues was that one of my server was shut down that trouble the deployment.

    are you in the same situation with load balacing ?

    if it is the case you can stop the current deployment by trying this :
    stsadm -o enumdeployments that will give you the id of the job and make a
    stsadm -o canceldeployment -id <yourid>

    hope this help
    Friday, November 16, 2007 2:43 PM
  • Hm... There is only one server, and the solution has not been deployed to this server before, so I really can't figure out why this is happeningSad

     

    Monday, November 19, 2007 3:42 PM
  • Sorry to bump this, but after alot of testing and googling I am still no closer to figuring this out...

     

    In SharePoint Central Administration, under Timer Job Status it says:

    Windows SharePoint Services Solution Deployment for "kundesystemdokumenter.wsp"  avsp  Succeeded  100%  12/13/2007 3:36 PM 

     

    In Timer Job Definition ut says:

    Job title: Windows SharePoint Services Solution Deployment for "kundesystemdokumenter.wsp"

    Web application: N/A 
    Last run time: 12/13/2007 3:36:46 PM 

    But in Solution Management it says:

    Name                                       Status              Deployed To
    kundesystemdokumenter.wsp    Deploying          None

     

    And it never changes from Deploying to Deployed...

     

    I've tried deploying several different solutions that I have deployed without problems before, but now everything hangs... I've tried rebooting the server, canceling the deployment, deleting all deployed files and starting over again, and everything in between, but nothing works!Sad

     

    Is this anyway related to the daylight savings bug?

    Thursday, December 13, 2007 2:56 PM
  • I have the same on my testmachines if I forget to start the timer service. Is it startet on your server?

    René
    Thursday, December 13, 2007 2:58 PM
  • Do you mean the Windows SharePoint Services Timer that is listen under Administrative Tools -> Services? It appears to be running on my server, and is set to Automatic. Is there something I need to configure in Central Administration as well?

     

    Thursday, December 13, 2007 3:15 PM
  • I am having the exact same problem.  I have already deployed the solution though.  I retracked the solution at one point because it was having problems.  Now I am trying to deploy it again.  It hangs on "deploying" and never installs.  I have removed everything manually and then tryed deploying the solution again to no avail. 

     

    I was wondering if you guys had figured anything out.  Right now, I am banging my head against the wall.  I did not even create the solution which makes it that much worse.

     

    Thanks for any help you might give.

     

    Dave

    Friday, December 14, 2007 1:41 AM
  •  DrLeary wrote:
    Do you mean the Windows SharePoint Services Timer that is listen under Administrative Tools -> Services? It appears to be running on my server, and is set to Automatic.

    Exactly
     DrLeary wrote:
    Is there something I need to configure in Central Administration as well?

    I dont think so.

    But if it is not the timer service, I am out of ideas right now.

    Friday, December 14, 2007 7:28 AM
  • Hm... I noticed there was another server in my farm that I never saw before and it was definitely not running smootly. The search and web-front-end service had failed. I tried stopping them, but now the status never changes from "Stopping". I noticed however that my solution now says "Globally deployed" in addition to the "Deploying" status. Still not available from Site Features, but I feel I got one step further. We will now try to remove this server from the farm, and see if that solves the problem. I will keep you posted!=)

     

     

     

    Edit:

    After removing the defective server from the farm, the solution deployed immediately=) Weeeee!

    Friday, December 14, 2007 10:20 AM
  • whether the deployment of wsp u only tried through command prompt?if so once u try deployment through sharepoint central administration site manually....
    Saturday, December 15, 2007 10:07 AM
  • I tried both and different combinations, but none worked until I discovered that someone had added a server to the farm that was NOT supposed to be there and was NOT running smoothly at all. After removing this server, everything deployed as normal=)

     

    Thursday, January 03, 2008 12:31 PM
  • Hi,

    I have read through this post and have tried the solution mentioned. I have removed the server from the farm and the Deployed To field has changed to Deployed Globally but the Status is still Deploying.

    Am I missing something here........

    Thanks


    Update: The problem is resolved now. I deleted the timer job and that resolved the problem. I then run the deletesolution stsadm command to clear up the solution for a fresh deployment. But this is only after the removal of the not needed server from the farm.

    Thanks
    tatahere
    • Edited by tatahere Wednesday, July 23, 2008 4:15 PM Answer
    Wednesday, July 23, 2008 3:06 PM
  • I've seen this issue before, MS was involved in the solution which involved creating a new config database. Not that it's an ideal solution but might be worth considering if it's your only option.
    Wednesday, July 23, 2008 3:09 PM
  • Hi Daniel,
     I have the same problem, can u tell me send me the MS link about the involving solution plz.
    thank u

    RAfik - Developpeur Sharepoint
    Monday, August 25, 2008 1:53 PM
  • Anyone with a realistic solution? Is recreating the config DB the only way around? I'm not looking forward to this one....
    David Lozzi
    Delphi Technology Solutions
    Blog
    Tuesday, October 28, 2008 3:10 PM
  • I want to elaborate a little more on what my scenario is.

    I have three levels of SharePoint

    MOSS3 is development, in it's own farm. Windows 2003 Standard x86
    DEV1 is staging, in it's own farm. Windows 2003 Standard x64
    MOSS1 is production, in a farm. Windows 2008 Enterprise x64
    MOSS2 is production, same farm as MOSS1, same OS
    SQL1 is production, same farm as MOSS1.

    When I upload a brand new InfoPath form to MOSS3 and DEV1, they both sit on Installing in Manage Form Templates and in Solution Management they both say Deploying(schedule at ... ). Upload the same form to MOSS1 and it uploads, installs and works fine. My customer says that the form will end up loading on DEV1 after a solid day of waiting (he tried another form yesterday).... MOSS3 never gets installed.

    A month ago or so, we started with the content DB on MOSS3, then backed it up and restored it to DEV1, then backed it up from DEV1 and restored to MOSS1. Everything was working great, until Yesterday. Up until yesterday the last time we tried to update was about 10 days before that. Something changed between the last time it worked and now.

    I've checked for updates (via Add/Remove Programs) on both servers and didn't see anything installed in the last month...

    Thanks!

    David Lozzi
    Delphi Technology Solutions
    Blog
    Tuesday, October 28, 2008 3:39 PM
  • So, I'm working with Microsoft on this issue. The following command appears to force through the deployment and my forms work fine afterward. We're looking into WHY this is happening now. It appears the jobs are stuck in the timer...

    stsadm -o execadmsvcjobs

    Good luck!
    David Lozzi
    Delphi Technology Solutions
    Blog
    Tuesday, October 28, 2008 7:37 PM
  • I had exactly the same problem.

    Deployment Status:  Deploying.
    Deployed To:        None / Globally deployed.

    If you more than one front-end server; it is possible that there could be an issue with load balancing.

    First find the id of the deployment package that is pending deployment.
    stsadm -o enumdeployments

    Then cancel the deployment.
    stsadm -o canceldeployment -id <yourid>

    Now check the state of your deployment once more through the Central Administration>Solution Management:
    The deployment status may miraculously appear as "Deployed" now.

    But you still need to fix the issue with one of the servers.

    -Okan Safi
    Tuesday, January 20, 2009 10:34 AM
  •  Ours is fixed and now working. It appears we didnt have the latest SP on MOSS. MS said it is the new daylight savings time updates that was causing the issue. After applying the latest SP, it runs great!

    HTH
    David Lozzi
    Delphi Technology Solutions
    Blog
    Friday, March 20, 2009 4:02 PM
  • Do you know what hotfix you installed to fix this problem?

    I have this exact same problem and I have been trying to resolve it for a couple of days.

    I have MOSS and SP2.  There are only a couple of hotfixes that I don't have installed, but
    they have warnings not to install them unless they resolve the problem you are having.

    I have a webpart that I was able to deploy using the following:

    (doit.bat)
    echo on
    stsadm.exe -o addsolution -filename wpUser2.wsp
    stsadm.exe -o execadmsvcjobs
    pause
    remstsadm.exe -o deploysolution -name wpUser2.wsp -immediate -allowGacDeployment -allowCasPolicies -allContentUrls -force
    stsadm.exe -o deploysolution -name wpUser2.wsp -immediate -allowGacDeployment -allowCasPolicies -allContentUrls
    stsadm.exe -o execadmsvcjobs
    stsadm.exe -o execadmsvcjobs
    pause
    stsadm.exe -o installfeature -filename Wpuser2\feature.xml -force
    stsadm.exe -o activatefeature -filename "wpUser2\feature.xml" -url "http://kb1:2222/sites/UserSelfChange" -force
    stsadm.exe -o execadmsvcjobs

    All was fine. It was deployed and unabled.  I wanted to change some things in the webpart, but I am unable to get the new code
    to deploy into sharepoint.  I tried removing using the following:

    (undoit.bat)
    echo on
    rem @set PATH="c:\Program files\Common Files\Microsoft Shared\Web Server Extensions\12\bin";%path%
    stsadm.exe -o uninstallfeature -name wpuser2 -force
    stsadm.exe -o execadmsvcjobs
    pause
    stsadm.exe -o deactivatefeature -filename "wpuser2\feature.xml" -url "http://kb1:2222/sites/userselfchange" -force
    stsadm.exe -o execadmsvcjobs
    pause
    rem stsadm.exe -o retractsolution -name wpUser2.wsp -immediate -url "http://kb1:2222/sites/userselfchange"
    stsadm.exe -o retractsolution -name wpUser2.wsp -immediate -allContentUrls
    stsadm.exe -o execadmsvcjobs
    pause
    stsadm.exe -o deletesolution -name wpUser2.wsp -override
    stsadm.exe -o execadmsvcjobs
    pause
    rem stsadm.exe -o deletewppack -name wpuser2.wsp -url "http://kb1:2222/sites/userselfchange"
    rem stsadm.exe -o execadmsvcjobs

    When I look at the web part, the description still has the old-stale code.  (My change is to change the
    description on the web part, this makes it easy to see if the new code is in there yet).

    I have seen this information posted in a couple of places saying that fixes from Microsoft resolved this for folks.
    Do you know what fix, or hotfix or SP?  Do you maybe have the knowledge base number?

    Thanks in advance for any help you can provide. 
    Karen
    Monday, May 04, 2009 4:25 PM
  • Hi

    I have installed WSS SP2 and MOSS SP2 but the problem still persists.

    Can someone post the solution if you have already solved this?

    Thanks
    Carol
    Friday, January 08, 2010 10:07 PM
  • We have WFE/query role server and an app-server running central admin and the indexing role, deploying all WSPs from the app-server. When we got this problem on SP2, I checked that there was no hung jobs using stsadm -o enumdeployments and there was zero running deployments. As a last resort, I stopped the Windows SharePoint Services Web Application service on the WFE role (please read the note below), booted the server and then restarted the Windows SharePoint Services Web Application service on the WFE role. This will recreate all the SharePoint IIS sites, and this solved our "deploying" problem.

    Note: stopping the Windows SharePoint Services Web Application service will remove all SharePoint sites from IIS, and you will loose any config changes done to the IIS metabase such as SSL and host headers: http://mindsharpblogs.com/Daniel/archive/2007/01/12/1473.aspx 
    Saturday, January 09, 2010 7:02 PM
  • Hi KJellSJ

    Thanks for your reply.

    I was able to solve my issue by rebooting the server.

    It worked like magic.

    Thanks a lot

    Caro

    Monday, January 11, 2010 7:55 PM
  • I tried everything, none of them worked for me.

    Here is how I fixed.

    I deleted the OTSTimer.exe within the Task Manager under Processes tab at both the application server and the WFE. SharePoint re-started this process automatically. Then my solution deployment works just fine.

    Tuesday, March 16, 2010 5:41 PM