none
External Content Type does show up in External List >> External Content Type browser RRS feed

  • Question

  • Hello everyone,

    I started off with a BDC project in VS 2010. I added an entity, set up an ID and 2 methods: readlist and readitem (The finder and specific finder methods). Added a Linq to SQL Item to the project as well, dragged the table I wanted to test onto the O/R designer which has generated the Object for me.

    When I did the same with Sharepoint designer these 2 methods were sufficent to be created and deployed for the external type to show up in the External Content Type browser when creating a new External List.

    In this VS situation I get no errors or warning about the solution when deploying or building. Seems like it works ok, or should work ok. I as well implemented the readItem and readList methods/

    The qestion is:
    Even though it shows up in the Application Management >> Manage Service Applications >> Business Data Connectivity Service in Management Console, when I create a new External List, the external content type browser does not list it. Why could that be?

    To make sure I didn't screw something up, I have removed manually and readded the BDC and whatnot to the Farm. The project was created as a farm solution.
    Any tips what way to go from here to find why it doesn't show up in the External Content Type browser would be much appreciated.

    Regards


    Sunday, June 26, 2011 4:57 PM

Answers

    • Sometimes it can be because Visual Studio retracts the solution for you when you close down the browser window ( \ stops debugging). You can get round this by right-clicking on the project and choosing deploy. This won't attach the debugger but will mean it's not retracted after you close the browser
    • Are you able to use the ECT on a Business Data List Web Part?
    • Do you have permissions to use the ECT from Central Administration?
    • Try using http://bcstesterman.codeplex.com/ to see if you can call the methods successfully, it's an open source tool I wrote to help debug BCS Models

    Hopefully there are some pointers in there to help

    Regards

    Phill


    helpful? …please mark it so!

    Lightning Tools Check out our SharePoint Tools and Web Parts
    BCS Meta Man Automatic BCS Model Generation
    BCS Tester Man Open Source BCS test client
    Twitter LinkedIn

    • Proposed as answer by Shimin Huang Friday, July 1, 2011 7:27 AM
    • Marked as answer by Joe Flamming Monday, July 4, 2011 12:31 PM
    Monday, June 27, 2011 7:34 AM

All replies

    • Sometimes it can be because Visual Studio retracts the solution for you when you close down the browser window ( \ stops debugging). You can get round this by right-clicking on the project and choosing deploy. This won't attach the debugger but will mean it's not retracted after you close the browser
    • Are you able to use the ECT on a Business Data List Web Part?
    • Do you have permissions to use the ECT from Central Administration?
    • Try using http://bcstesterman.codeplex.com/ to see if you can call the methods successfully, it's an open source tool I wrote to help debug BCS Models

    Hopefully there are some pointers in there to help

    Regards

    Phill


    helpful? …please mark it so!

    Lightning Tools Check out our SharePoint Tools and Web Parts
    BCS Meta Man Automatic BCS Model Generation
    BCS Tester Man Open Source BCS test client
    Twitter LinkedIn

    • Proposed as answer by Shimin Huang Friday, July 1, 2011 7:27 AM
    • Marked as answer by Joe Flamming Monday, July 4, 2011 12:31 PM
    Monday, June 27, 2011 7:34 AM
  • Indeed, my solution was retracted and there were some deployment issues. Retracting the solution and deleting it then redeploy it helped me problem. Thanks...
    Monday, July 4, 2011 12:33 PM