Spell Check: "Arithmetic operation resulted in an overflow" error


  • Hello,

    I am having inconsistent results using the spell check feature when editing a custom list.  Sometimes, the spell check does not return any spelling errors when there are indeed spelling errors.  This inconsistent behavior can be seen by repeatedly spell checking the item (meaning I don't need to close it and re-open it to see the behavior).

    I found no errors in the SharePoint logs or IIS logs.  I ended up using Fiddler, and looked at what was happening when _vti_bin/SpellCheck.asmx was accessed.  I saw the following (in this example, I misspelled "being" as "bein"):

    When it correctly found the spelling error, the response was:

    <?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="" xmlns:xsi="" xmlns:xsd=""><soap:Body><SpellCheckResponse xmlns=""><SpellCheckResult><errorCode>Ok</errorCode><detectedLanguage>1033</detectedLanguage><spellingErrors><SpellingErrors><chunkIndex>4</chunkIndex><flaggedWords><FlaggedWord><word>bein</word><type>UnknownWord</type><offset>116</offset></FlaggedWord></flaggedWords></SpellingErrors></spellingErrors><spellingSuggestions><SpellingSuggestions><word>bein</word><sug /></SpellingSuggestions></spellingSuggestions></SpellCheckResult></SpellCheckResponse></soap:Body></soap:Envelope>

    When it did not find the spelling error (and displayed "No Spelling Errors found" to the user), I see the following:

    <?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="" xmlns:xsi="" xmlns:xsd=""><soap:Body><soap:Fault><faultcode>soap:Server</faultcode><faultstring>Server was unable to process request. ---&gt; Arithmetic operation resulted in an overflow.</faultstring><detail /></soap:Fault></soap:Body></soap:Envelope>

    Any idea what could be causing this?  

    Thursday, May 24, 2012 7:56 PM

All replies

  • Hi,

    Did this issue occur all the web application or only one web application?

    If the issue only happend in one web application, please try to check the application pool and application pool account for this web application.

    Xue-mei Chang

    TechNet Community Support

    Monday, May 28, 2012 6:26 AM
  • This only happens in one web application (and as mentioned, intermittently).  What should I check about the application pool account?  
    Tuesday, May 29, 2012 7:47 PM
  • Did you ever find a resolution to this issue?  We seem to be experiencing the same problem.

    Thanks - Jason.

    Monday, July 09, 2012 8:57 PM
  • I have not found a solution yet.
    Monday, July 16, 2012 4:31 PM

  • Couple of questions if you don't mind:

    Are you guys using FAST Search for SharePoint?  (We are; I am curious if you are as well)

    Have you tried using the webservice on another web application?  (Our works for the MySites web application)

    Have you seen anything in the ULS logs?  (See below for an Access Denied message in our ULS logs)

    ULS Log entry for one specific request:  (I've stripped out the first part of the entry which showed date & time, etc.

    Entering monitored scope (Request (POST:    
    Name=Request (POST:    663292a9-02b8-4787-b82f-49fba8a2e11c
    Medium      Site=/    663292a9-02b8-4787-b82f-49fba8a2e11c
    Access denied.    663292a9-02b8-4787-b82f-49fba8a2e11c
    Leaving Monitored Scope (Request (POST: Execution Time=20.7344788234259    663292a9-02b8-4787-b82f-49fba8a2e11c

    Monday, July 16, 2012 7:45 PM
  • Hi Chuck, Do you have any resolution or fix on this? I am currently experiencing this and unable to solve this. The error seem to be very intermittent and not going off. Please share here if you have any fix for this. Thank you.
    Wednesday, March 26, 2014 1:17 AM
  • Not sure if this will help you, but it may help others who come across this thread in the future.

    The problem that we were seeing was not intermittent (happened on every request for Spell Check) and only happened for one web application.  As it turns out, SharePoint 2010 SP1 installation fixed it for us.


    Thursday, May 01, 2014 7:58 PM