locked
VSeWSS 1.3 Deploy fails with "Faulted state" RRS feed

  • Question

  • I've created a generic "Hello World" webpart and are trying to deploy it to http://localhost

    The deployment fails with:


    System.ServiceModel.CommunicationObjectFaultedException  
    Server Error: The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it is in the Faulted state. 



    Regards
    - M
    • Edited by M. Heath Wednesday, January 14, 2009 12:26 PM
    Wednesday, January 14, 2009 11:58 AM

Answers

  • Hi

    I had the same problem - checked the IIS logs and saw 405 errors. Seems the .svc file type wasn't set up properly in IIS7.

    I re-registered WCF:
    %Windir%\Microsoft.Net\Framework\v3.0\Windows Communication Foundation\ServiceModelReg.exe -r

    and this appears to have fixed the problem - hope this helps

    Regards
    Phil

    • Marked as answer by M. Heath Wednesday, January 14, 2009 2:10 PM
    Wednesday, January 14, 2009 1:56 PM

All replies

  • Yeah, same thing here on an out-of-the-box new site definition.
    Wednesday, January 14, 2009 12:12 PM
  • Is the VSEWSS web service app pool account in the administrators group?
    Also, can you double check that you can browse to http://localhost and a WSS app comes up?

    Posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, January 14, 2009 1:18 PM
  • Hi

    I had the same problem - checked the IIS logs and saw 405 errors. Seems the .svc file type wasn't set up properly in IIS7.

    I re-registered WCF:
    %Windir%\Microsoft.Net\Framework\v3.0\Windows Communication Foundation\ServiceModelReg.exe -r

    and this appears to have fixed the problem - hope this helps

    Regards
    Phil

    • Marked as answer by M. Heath Wednesday, January 14, 2009 2:10 PM
    Wednesday, January 14, 2009 1:56 PM
  • Worked like a charm!

    On my 64 bit 2008 the path to ServiceModelReg is
    C:\Windows\Microsoft.NET\Framework64\v3.0\Windows Communication Foundation

    Thanks a lot!
    -M
    Wednesday, January 14, 2009 2:13 PM
  • The application pool account is member of the administrators group. I made the account member because I explicitely had it set to a non-privileged account for security reasons.

    I got HTTP Error 401.2 - Unauthorized

    IIS had no authentication settings for the web service
    When I changed to Anonymous authentication I could access the VSEWSS service from IE, and the Visual Studio package worked.

    BUT NOW I HAVE A WEB SERVICE WITH ANONYMOUS ACCESS THAT RUNS IN AN ADMINISTRATORS ACOOUNT !!!
    Wednesday, January 14, 2009 3:24 PM
  • Eric Vandekerckhove said:

    The application pool account is member of the administrators group. I made the account member because I explicitely had it set to a non-privileged account for security reasons.

    I got HTTP Error 401.2 - Unauthorized

    IIS had no authentication settings for the web service
    When I changed to Anonymous authentication I could access the VSEWSS service from IE, and the Visual Studio package worked.

    BUT NOW I HAVE A WEB SERVICE WITH ANONYMOUS ACCESS THAT RUNS IN AN ADMINISTRATORS ACOOUNT !!!

    Hi Eric,

    I can hear you now :-)

    The new web service requires local administrator access because of the permissions required for the SharePoint installation APIs. These have to be cross process calls because of the 32 bit Visual Studio to 64 bit SharePoint connection.

    We create the web service in the installer we also set it to local machine access only. You can't access it off host. Try it. We also don't add the permissions in the installer so that you can make the decision since you may have other concerns on your machine that we hadn't thought of. We're assuming here that the install is onto a developer workstation such that the developer is the only user of the machine and local administrator permissions would not be a concern within the machine.

    Please follow up if you have any other concerns or questions.

    Regards,
    Paul
    SharePoint Product Manager. Posting is provided "AS IS" with no warranties, and confers no rights
    Wednesday, January 14, 2009 4:32 PM
  • Hi Paul,

    This is not a concern for me, on my virtual machine that I fully control. But I'm also working at a customer site, a large bank, where even the development environments are strictly controlled by central IT, not by the developers. At this particular instance local administrator privileges woube completely out of the question since the SharePoint administration account works in a strictly controlled sandbox.

    Eric.
    p.s. sorry, i didn't mean to shout :-)
    Wednesday, January 14, 2009 6:47 PM
  • Eric Vandekerckhove said:

    Hi Paul,

    This is not a concern for me, on my virtual machine that I fully control. But I'm also working at a customer site, a large bank, where even the development environments are strictly controlled by central IT, not by the developers. At this particular instance local administrator privileges woube completely out of the question since the SharePoint administration account works in a strictly controlled sandbox.

    Eric.
    p.s. sorry, i didn't mean to shout :-)

    Hi Eric,

    Your customer restriction of not allowing local administrator priviledges would also cause the previous tools VSeWSS 1.2 to fail since they require Visual Studio 2008 to be run with administrative permissions. The permission is required because of deploying and retracting solutions to and from SharePoint. So we can't avoid it. With that strict policy your customer would not be able to do SharePoint development.

    Regards,
    Paul
    SharePoint Product Manager. Posting is provided "AS IS" with no warranties, and confers no rights
    Wednesday, January 14, 2009 6:51 PM