none
Business Data Connectivty Metadata Store is currently unavailable RRS feed

  • Question

  • Hi,

    I get the following error when i want to open the "External Content Types" via SP-Designer:

    All BCS-services are running and i can open the list with the central-admin-page.

    If want to create a new "External Content Type" following message appears:

    But i think the used account to connect to the SharePoint has all the needed permissions.


    Monday, July 27, 2015 10:27 AM

Answers

  • The Problem was:

    SharePoint-Designer was running under an account, which was on a different domain (old domain).

    Solution: Start SP-Designer under correct account (new domain) -> "Run as different user"

    • Marked as answer by Thomas Stessl Tuesday, August 4, 2015 9:44 AM
    Tuesday, August 4, 2015 9:44 AM

All replies

  • Hi Thomas,

    Firstly, please make sure that the Business Data Connectivity Service is associated with the web application where your site opened in SharePoint Designer exists.

    Please go to Central Administration > Application Management > Manage web applications > highlight the corresponding web application and then click Service Connections in the ribbon > make sure that Business Data Connectivity Service is selected.

    Secondly, please re-check if the user has permission to use the Business Data Connectivity Service.

    Go to Central Administration > Application Management > Manage service applications > highlight the Business Data Connectivity Service and then click Permissions on the ribbon.

    Thirdly, please check which authentication method is used for the web application.

    Best regards,

    Victoria


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, July 28, 2015 8:28 AM
    Moderator
  • The Problem was:

    SharePoint-Designer was running under an account, which was on a different domain (old domain).

    Solution: Start SP-Designer under correct account (new domain) -> "Run as different user"

    • Marked as answer by Thomas Stessl Tuesday, August 4, 2015 9:44 AM
    Tuesday, August 4, 2015 9:44 AM