none
Migrating Site - Pages Moved but Content Missing

    Question

  • Hello MSDN,

    Introduction: I'm not the admin, but I work closely with the employee our company has designated as such.  The company is has not yet come up with funding for a dedicated SharePoint administrator so we are just making due and learning as we go.    

    The Problem: The company needed us to migrate the site from being a sub-site of a parent site to its own site.  We have started to copy each department's site to the new site, but noticed that while the site pages are being copied over none of the app/webparts are migrating along with the pages.  Similarly, lists are migrating but all of the views and other customizations are no longer present.  Can anyone point us in the right direction for a resource so we can do this properly?

    Saturday, May 18, 2019 8:09 PM

All replies

  • Hi Grasor,

    How did you migrate the site?

    In SharePoint 2013, when migrating by OOB method, the customization in the site will not be migrated by default.

    After migrating, you could add the customization in the pages and lists manually.

    Or you could consider using other methods to migrate the customization from one site to another site.

    More reference:

    How to move sites in SharePoint.

    https://sharepointmaven.com/how-to-move-sites-in-sharepoint/

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, May 20, 2019 6:36 AM
    Moderator
  • Tuesday, May 21, 2019 3:14 PM
  • Hi Grasor,

    How is everything going?

    Is there anything update about this issue?

    If the reply is helpful to you, you could mark the helpful reply as answer. Thanks for your understanding.

    Best regards,

    Sara Fan

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Thursday, May 23, 2019 2:06 AM
    Moderator
  • Sara,

    Thanks for the follow up.  The "admin" used the template method to transfer the pages, but no luck.  The content is still missing.  We are not sure why.

    Thursday, May 23, 2019 5:31 PM
  • Hi Grasor,

    To troubleshoot the issue, you could save the site as template again and select “Include Content”.

    Then create the site based on the new site template to check if the same issue will occur.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, May 24, 2019 9:31 AM
    Moderator
  • Hi Grasor,

    How is everything going?

    Is there anything update about this issue?

    If the reply is helpful to you, you could mark the helpful reply as answer. Thanks for your understanding.

    Best regards,

    Sara Fan

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, May 27, 2019 2:09 AM
    Moderator