Error occurred in deployment step 'Retract Solution': Attempted to perform an unauthorized operation.


  • Hi,

    Is there any reason why I got the error above in my dev machine? It works perfectly fine if I login using the service account. So permission do I need for a regular account?

    Thanks in advance.

    Friday, August 27, 2010 7:55 PM

All replies

  • Hi,

    What kind of Service Account are you using, and what is the difference between your account and the service account? Most likely your account isn't a Administrator on your farm, which does not have permissions to retract solutions.


    Friday, August 27, 2010 9:59 PM
  • Hi wkpli,


    Thanks for your post.

    Here is some information about “Retract Solution” in MSDN:

    Retracting a solution is the process of removing assemblies, files, resources, safe control entries, and other solution components from computers to which they have been deployed. In cases where a solution is completely retracted, the features contained within a solution are uninstalled from the server farm. Just as solutions can be deployed either to the local server or the entire server farm, they can be retracted in the same way—at the local server or server farm level.


    So I think it’s problem about “User Account Control”.

    More information about it:


    Now, if you don’t login using service account, I suggest you use “Run as Administrator” when you open IE and open the SharePoint site.


    Share your result.

    Monday, August 30, 2010 3:52 AM
  • I have already added my regular account to the Farm Administration group and when I run the solution in VS 2010, I run as Adminstration too. When I tried to deploy some of the project in the solutions, they work, but some don't.

    Here is one of the errors that I got for deploying one solution, so I use my regular account to go to http://spsite_layouts/ManageFeatures.aspx and this account has no access to this page

    Error occurred in deployment step 'Activate Features': Attempted to perform an unauthorized operation.

    So, it is definitely permission issue, what am I missing if I am already the farm admin and local admin of the server.


    Monday, August 30, 2010 2:12 PM
  • Hi,


    Is it possible to specifiy which post on the site gave you the answer to the problem?

    The site itself is kinda general...



    Programming code is like magic, just use the right code (magic words) to make happen what you want..
    Wednesday, January 26, 2011 10:19 AM
  • I was able to fix it by setting the access policy for the current user deploying the SharePoint Solution.

    In SharePoint 2010 go to Central Administration - Manage web applications (under Application Management).

    There you select the SharePoint application and press "User Policy" in the ribbon. Over there you add your user you want  deploy with and give him full control.


    Programming code is like magic, just use the right code (magic words) to make happen what you want..
    • Proposed as answer by EagleWizard Wednesday, January 26, 2011 12:50 PM
    Wednesday, January 26, 2011 12:50 PM