Script execution gets blocked in remote application when accessed from a Word process RRS feed

  • Question

  • I've developed a document generator as a VSTO-based AddIn for Word that reads its data from a system engineering tool (i.e. PTC Integrity Modeler). Some of the model properites in the engineering tool are derived at runtime via VB scripts (tool internal). Since Office version 1806, remote script execution gets blocked when the Word process tries to read model data via the COM interface of system engineering tool.

    Is it possible to allow this remote script execution for a specific process or component? I also tried to exclude the COM interface from ASR rules via corresponding GPO, but had no success so far...

    I can provide a simple test component to reproduce this behavior (without the need to install the system engineering tool): a DLL that evaluates a formula via a VB script; when it's called from another VB-Script it runs correctly, whereas when it's called from a Word VBA environment it doesn't....

    Thursday, July 2, 2020 10:07 AM


  • Finally, the following blog entry solved this problem:
    • Marked as answer by KnowBody-RG Monday, July 13, 2020 10:38 AM
    Monday, July 13, 2020 10:35 AM