Visio 2010 unused stencils/shapes


  • I have gone through with so many artiles suggesting to use "Reduce File size" feature to remove those unused stencils/shapes, but even after clicking on this feature, those unused shapes/stencils are not moving at all. If I open only one visio .VSD file, and click on the visio icon on the taskbar, it shows all shapes/stencils making it difficult to open the original VSD file. Please advise me how to delete these shapes permanently to make it easier to work on Visio 2010.

    Monday, January 02, 2012 1:32 PM

All replies

  • Where are you seeing these extra shape or stencils? Which stencils are open? What type of Visio document? Why is it difficult to open the VSD file?


    -- Paul Herber, Sandrila Ltd. Engineering and software shapes for Visio.
    Wednesday, January 04, 2012 12:57 AM
  • These are the default visio shapes like Servers, Networks and even my own custom stencils. When i click on the Visio logo (V) in the Taskbar, it shows all those shapes/stencils which makes it difficult to find the original VSD file out of so many opened shapes/stencils in the taskbar. Is it the default Visio 2010 settings. Previously, i was using Visio 2007 but no such problem i ever encountered. I've attachecd the print screen of what I am currently seeing to   
    Thursday, January 05, 2012 5:08 AM
  • That's nothing to do with Visio, that's controlled by your desktop/task bar settings.


    -- Paul Herber, Sandrila Ltd. Engineering and software shapes for Visio.
    Friday, January 13, 2012 11:52 AM
  • Is there any way to close all unused shapes/stencils in the Visio? Problem is when we open any visio file, it opens a lot of shapes/stencils on the left-side and in the bottom as displayed below. One way is to close all of them before saving but it takes time to manually close them one by one. Isn;t there any default setting or one-way click to close them in one go. Thanks!!

    Tuesday, February 07, 2012 6:30 AM
  • you might check this out

    the second part of the puzzle is to first close the stencils you don't want and then

    File => info, select the properties button (the tiny dot next to the properties label which offers the advanced menu) and check the summary tab for the save workspace check mark



    If this answer solves your problem, please check Mark as Answered. If this answer helps, please click the Vote as Helpful button. Al Edlund Visio MVP

    Tuesday, February 07, 2012 1:39 PM
  • But that's not Visio showing the stencils opened within a document.

    Start Visio and create a blank document. Now go to windows explorer and find a stencil file, and double-click it, now do a few more. That's what the question is about.

    That's the Windows desktop showing the list of open documents (see my previous response).

    So, we've got to find out why all those stencils are being opened.

    -- Paul Herber, Sandrila Ltd. Engineering and software shapes for Visio.

    Wednesday, February 08, 2012 12:37 AM
  • I suffer the exact same problem as Sachin, but I usually have several Visios open and when I click on the Visio taskbar icon, there are literally hundreds of mini windows, one for each stencil. If I sit there for 20 mins and close them all except the documents I am working on, they all reappear again as soon as I reopen a document.

    It makes the taskbar icon unusable for switching to your Visio work

    Wednesday, April 25, 2012 1:36 AM