none
Unable to re-register Ms Word VSTO COM Add-in, when deployed through ClickOnce. RRS feed

  • Question

  • I develop office solutions, published via ClickOnce on a remote public web server. Whilst testing fully signed releases, I recurrently face this problem within Windows 10 machines: if the ClickOnce application is "installed" (meaning it appears in Settings/Apps & Features), but the COM Addin is not registered with Word, I am unable to re-register the Addin into Word.

    This scenario may occur at least for 2 flows: (1) the user closes Ms Word during launching, when it was the first time Word was executed since the ClickOnce installation was made - this maintains the ClickOnce installation but cancels the registration of the Addin; or (2) the user clicks the [remove] button in the "Manage COM Add-in" window of Ms Word - this unregisters the Addin.

    I have already tried the following:

    A. Uninstall/reinstall the ClickOnce setup via the Settings/Apps & Features panel

    B. Release an updated version of the Addin (incremented assembly and ClickOnce release version number): ClickOnce  successfully updates to the new version, but the Addin still is not registered into Word. I know this is the case because the Product Name property of my releases contains the release version number. The Product Name property being what is displayed as the name of the application in Settings/Apps & Features, I am sure the updates has been picked up if the name has changed.

    The only way I am able to re-register the Addin is by changing the Assembly Name of the VSTO project. Why is that? And why is this a problem I am able to reproduce only with Office 365 + Windows 10? I have a second testing machine using Office 365 + Win7 and I have no problems.




    • Edited by Ama_76 Monday, October 21, 2019 4:36 PM
    Monday, October 21, 2019 4:32 PM