none
SharePoint Designer 2010 errors out when trying to connect to SharePoint 2010

    Question

  • When trying to connect Designer 2010 to our SharePoint 2010 we have setup here, the web seems to open, but then it bombs out with an error "An error occurred while trying to fetch data from your SharePoint site. Unknown response from the server.". And we're stuck as of now. Noting this bombs out also from Designer 2010 on the server, as well as from my workstation, so it's some sort of service issue.

    We've done:
    1) Firewalls off, on both server and my desktop
    2) I've been made admin everywhere, including the farm admin. Doesn't just die on my user, but all users get same error.
    3) Clicking lots of checkboxes in hundreds of places :)

    Any thoughts as to why designer dies?

    Noting
    That when I Open Site in Designer 2010, and put the Url in the Site Name, the folder structure does show the folders of the site, so I can see images, _catalogs, SitePages, etc. It's just when trying to connect is when it doesn't work.
    Tuesday, November 03, 2009 10:34 PM

Answers

  • In my initial response, I had mentioned that I have experienced this issue before. It seems that you are experiencing the same thing that I saw: opening up an earlier SharePoint build with a later SharePoint Designer build does not work.. at least it did not for me and it seems you have seen the similar issue while trying to connect to SharePoint 4006.1010 build with SharePoint Designer build 4514.1007.
    Asif Rehmani, MVP. Host of http://www.sharepoint-videos.com (SharePoint and InfoPath Video Tutorials). Co-author of Book "Professional SharePoint Designer 2007"
    • Proposed as answer by ConstructiveTim Wednesday, November 18, 2009 9:16 PM
    • Marked as answer by Mike Walsh FIN Friday, November 20, 2009 7:19 AM
    Monday, November 09, 2009 4:32 AM

All replies

  • Hmm, that hasn't happened to me with SharePoint Designer 2010 64-bit Tech Preview and SP2010 Tech Beta.  I've been working with those two for a few months, so I agree that it's a service or system issue specific to your setup.

    Can you explain the last part?  How is it showing the entities on the left without connecting.  You said it shows those categories but only fails when trying to connect.  It can't show those without first connecting, so that was a little confusing.  Also, 2010 no longer shows folders like SPD 2007.  It shows Site Objects as you can see in Figure 3 of my blog post:

    Business Connectivity Services (BCS) – Creating an External Content Type (ECT) based on a SQL 2008 Table

    Images and _catalogs are not Site Objects.  Do you see a folder structure like it used to be in SPD 2007?
    SharePoint Architect || My Blog
    Tuesday, November 03, 2009 11:11 PM

  • Can you check the whether SharePoint Designer is enabled for the web application in Central Administration | General Application Settings | SharePoint Designer

    And also check the SharePoint Designer settings for the site under Site Settings | Site Collection Administration | SharePoint Designer Settings

    And finally, can you also check whether there are any errors logged into the Windows Event Log? The Windows Event Log is one such place along with the SharePoint logs where you can find more info about issues and problems.
    Regards,
    Chakkaradeep
    SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    • Edited by Mike Walsh FIN Wednesday, November 04, 2009 5:08 AM Sig far too long. Three lines is enough we don't need seven.
    Wednesday, November 04, 2009 12:08 AM
  • Further to what Chandran said, also when you are in the site (Browser UI), there is an option to open the site in SPD. Give that a go as well and see what happens.

    Since you are getting errors, it's best to check the Event Viewer logs as well.



    Alpesh Nakar Blog: http://alpesh.nakars.com/blog | Twitter: @alpesh SharePoint Resources: http://www.justsharepoint.com | Twitter @justsharepoint
    Wednesday, November 04, 2009 1:46 AM
  • Can you explain the last part?  

    I'll get my IT guy to pop in and give a more robust explanation of the errors and where we are.

    But no, I'm not seeing the entities without connecting, we're seeing the folders of the web in the Open Site interface. Simply Open Site in Designer, in the Url area type in http://servername, now without doing anything else here, still in that Open Site interface, the above area fills up with the folder structure of the site. In the Open Site interface is where we can see images, _catalog, etc. Then when clicking the Open button is when it tries to connect to the web, connecting, things spinning, then the error in a popup.
    • Edited by Mike Walsh FIN Friday, November 20, 2009 7:18 AM again don't use full quote. if you quote use only enough so we can identify the post you are commenting on
    Wednesday, November 04, 2009 3:00 PM
  • Oh, I see what you mean now - you're referring to the folder structure that you see in the popup window where you put in your URL - not actually in SPD at all.
    SharePoint Architect || My Blog
    Wednesday, November 04, 2009 3:26 PM
  • Yeah, this is in SharePoint Designer 2010. In File > Sites interface, clicking the big Open Site button. Put Url in there(not clicking any butons), you can see the folders in the Open Site interface itself. So Designer is connecting in one way or another to the web to get the folders of said web.
    Wednesday, November 04, 2009 4:53 PM
  • Yeah, that's strange, because it definitely has to connect to some degree to see the folder structure.  There may be an additional level of connectivity when clicking "Open."  Did you try "open site in designer" like Alpesh  mentioned?
    SharePoint Architect || My Blog
    Wednesday, November 04, 2009 6:44 PM
  • Thanks for the replies,

    I set up the site with Server 2008 SP2 and ran the basic Sharepoint 2010 installation.  This is just meant as a test environment for use with Sharepoint Designer.  The event log was showing an com error:
    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {  }

    The blog post by 

    http://geekswithblogs.net/mhamilton/archive/2006/12/19/101568.aspx.  Giving the local network service remote launch and activation resolved the issue and the com errors dissapeared.  The Sharepoint Designer connection issue continues. 

    Sharepoint designer is enabled in Central Admin and also on the top level site http://localhost/SitePages/Home.aspx .

    Same results when the sharepoint designer is opened from the site.  I did get this  The URL http://localhost/_vti_bin/_vti_aut/author.dll is not contained within a windows Sharepoint Services Site.

    In central admin there is a red x icon on both sharepoint designer and Reporting services.  Since the basic install was used, reporting services are not setup, so the red x icon for reporting services is expected.

    I did a fresh install of the entire box this morning, no change.  

    Thanks for the assistance!

    Wednesday, November 04, 2009 9:26 PM
  • Let's look at your setup incase we have missed something. You have Server 2008 SP2 and SQL Express (stand alone installation) with no DC?

    You did not have any issues setting up the SP Binaries and running the Config Wizard?

    Ok now did you run the Config Wizard in Central Admin?

    Hopefully not. :)

    Start with minimum service applications and see if you can connect to your site ( what site template have you used? )

    May be just start with simple team site template.




    Alpesh Nakar Blog: http://alpesh.nakars.com/blog | Twitter: @alpesh SharePoint Resources: http://www.justsharepoint.com | Twitter @justsharepoint
    Thursday, November 05, 2009 1:49 AM
  • I have experienced this issue before. It may or may not be the same situation as yours though... I received this error because I tried to open up a newer SharePoint 2010 build with an older build for SPD 2010. The build numbers have to be the same for SPD to open up SharePoint 2010 sites.
    Asif Rehmani, MVP. Host of http://www.sharepoint-videos.com (SharePoint and InfoPath Video Tutorials). Co-author of Book "Professional SharePoint Designer 2007"
    • Proposed as answer by Clayton Cobb Wednesday, November 18, 2009 4:51 PM
    • Unproposed as answer by Mike Walsh FIN Friday, November 20, 2009 7:18 AM
    Thursday, November 05, 2009 4:43 AM
  • We have the freshest install of SharePoint Designer 2010 from the //ProductWeb site. Looks like there's a date of December 2008 on the product page for this. Does this mean the ProductWeb doesn't have the newest of the newest build?

    Build I have is 14.0.4514.1007 (32-bit)
    • Edited by Harlequin Thursday, November 05, 2009 4:47 PM Typo - My 9 year old spells better than me...
    Thursday, November 05, 2009 4:26 PM
  • You do have a very 'fresh' build of the product. That's correct. This is not the problem for sure then. Not sure what exactly it could be. If I think of some other solution, I'll be sure to post it back here.
    Asif Rehmani, MVP. Host of http://www.sharepoint-videos.com (SharePoint and InfoPath Video Tutorials). Co-author of Book "Professional SharePoint Designer 2007"
    Thursday, November 05, 2009 5:08 PM
  • Hi Asif,

    Our version of Sharepoint is 14.0.4006.1010.  The install that we used was the basic install with service packs installed.  The SQL service used was the SQL express that is installed with the basic install 
    Thursday, November 05, 2009 5:14 PM
  • On the latest attempt, I did run the configuration wizard and timed out.  

    Friday, November 06, 2009 12:10 AM
  • Have you installed SQL  2008 SP1 and CU?

    Alpesh Nakar Blog: http://alpesh.nakars.com/blog | Twitter: @alpesh SharePoint Resources: http://www.justsharepoint.com | Twitter @justsharepoint
    Friday, November 06, 2009 12:51 AM
  • So, is this SharePoint running in a VM? If so how much RAM have you allocated to the VM?

    What method of installation did you choose? - Complete, Web Front End, Advanced??

    Can you create web apps/site collections without any problems?

    Can you also check whether can you browse to other sites using SPD2010?

    On the other hand, this can be totally be something related to the build 4514.1010. I would say 4514.1007 or 4514.1009 would be better builds.

    @ConstructiveTim - you said the SharePoint build is 4514.1010 but @Harlequin replied its 4514.1007 - Are you sure you arent connecting SPD 2010 build 4514.1010 to SharePoint site build 4514.1007 or vice versa?

    Did you check the SharePoint Designer settings?
    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Friday, November 06, 2009 1:14 AM
  • Oh and when you said timed out, something would have registered in the event  log as well. Can you check that as well :)



    Alpesh Nakar Blog: Alpesh Nakar's Blog | Twitter: Follow Alpesh on Twitter |SharePoint Resources: Just SharePoint Resource Center | Follow Just SharePoint updates on Twitter
    Friday, November 06, 2009 4:35 AM
  • Thanks for the comments. 

    This latest install was server 2008 R2 on hardware with 6 GBs.  I used the Advanced install using a local SQL 2008 SP1 install.  I ran the configuration wizard and it timed out with an error.  Event log is full of SQL Exception 547 errors.


    Event ID:      5586
    Task Category: Database
    Level:         Error
    Keywords:     
    User:          Domain\user
    Computer:      machine.domain
    Description:
    Unknown SQL Exception 547 occurred. Additional error information from SQL Server is included below.

    The DELETE statement conflicted with the REFERENCE constraint "FK_Dependencies1_Objects". The conflict occurred in database "SharePoint_Config", table "dbo.Dependencies", column 'ObjectId'.
    The statement has been terminated.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

    The GUID for this error is for Microsoft-Windows SharePoint-Windows SharePoint Services 4

    In the basic install I first used I had an ISS WAMREG error.  In Component services  I was able to fix the error by adding remote launch to the sercurity settings.  With this setup, I notice there ability to customize is not availabe.  The reference to the com fix post is in one of the posts above.

    I am thinking about doing a fresh install, wish I had done this on a hyper-V Virtual machine with snapshots :-(

    Friday, November 06, 2009 6:28 PM
  • The SharePoint Designer 2010 had that version number, 4514.1007. SharePoint is 4006.1010.

    And yes, we have connected to another site with our Designer, through the VPN to a Microsoft internal //SharePoint site actually. So we know the designer can connect okay.
    Friday, November 06, 2009 9:17 PM
  • In my initial response, I had mentioned that I have experienced this issue before. It seems that you are experiencing the same thing that I saw: opening up an earlier SharePoint build with a later SharePoint Designer build does not work.. at least it did not for me and it seems you have seen the similar issue while trying to connect to SharePoint 4006.1010 build with SharePoint Designer build 4514.1007.
    Asif Rehmani, MVP. Host of http://www.sharepoint-videos.com (SharePoint and InfoPath Video Tutorials). Co-author of Book "Professional SharePoint Designer 2007"
    • Proposed as answer by ConstructiveTim Wednesday, November 18, 2009 9:16 PM
    • Marked as answer by Mike Walsh FIN Friday, November 20, 2009 7:19 AM
    Monday, November 09, 2009 4:32 AM
  • So you think we need to find a Designer 2010 with the 4006.1010 build? I don't see how the SharePoint 2010 and the SharePoint Designer 2010 build numbers correspond to each other. One would think they have nothing to do with each other.
    Monday, November 09, 2009 9:52 PM
  • What's your site port?! is it 80?!
    SharePoint 2010 has a bug when you create a site on defaut 80 port  - SPD can't connect to you site in this case when you select Edit In SharePoint designer. The issue in WCF binding that it's already linked to localhost

    Try to create the site on other port, let's say 81 and test it again
    SharePoint Tips & Tricks Portal | Microsoft MVP | My Blog | My twitter
    Tuesday, November 10, 2009 5:18 AM
  • I made a new site in central admin and used the port that was generated.  Still had the same issue with Designer.  The interesting part was when I open IIS on the host machine and select the option to browse the site, it opens a "webpage cannot be found" and uses the url http://localhost:25986

    When I replace local host with machine name http://machinename:25986 the site opens as expected.  Could it be that designer starts communicating with the site and then the web service changes the url to localhost, killing the process?

    Tuesday, November 10, 2009 5:18 PM
  • Last response is interesting. What are your host file settings?
    DougTheCoder
    Tuesday, November 10, 2009 7:41 PM
  • That exactly what I meant. You need to create the custom host name and don't use default (80) port.
    Open the eventLog and you will see such errors

    ===================================
    WebHost failed to process a request.

    Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/14145203

    Exception: System.ServiceModel.ServiceActivationException: The service '/_vti_bin/client.svc' cannot be activated due to an exception during compilation. The exception message is: This collection already contains an address with scheme http. There can be at most one address per scheme in this collection.

    Parameter name: item. ---> System.ArgumentException: This collection already contains an address with scheme http. There can be at most one address per scheme in this collection.

    ====================================

    google to find detailed explanations. In two words, the localhost is already user in WCF binding by SharePoint and you need another name for your site or modify web.config

    I expect it will be fixed in Beta2
    SharePoint Tips & Tricks Portal | Microsoft MVP | My Blog | My twitter
    Tuesday, November 10, 2009 10:00 PM
  • My SPD/SP 2010 setup is working with no host header and port 80 on my web app.  http://<machinename>:80 (of course, no 80 required).  This is on Tech Preview with each product.
    SharePoint Architect || My Blog
    • Edited by Clayton Cobb Tuesday, November 10, 2009 10:39 PM
    Tuesday, November 10, 2009 10:28 PM
  • So, I created my web application/site collection at port 80: http://sample - I also added a host entry.

    a) I was able to open the site by just inputting http://sample in SharePoint Designer 2010
    b) I was able to edit the Home Page, add a web part and save the changes
    c) Was able to do the same from Site Actions | Edit in SharePoint Designer

    I am using build 4514.1007.

    I don't think this host header thing is a problem, unless it was a problem in previous builds.


    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Tuesday, November 10, 2009 10:37 PM
  • This has been resolved with the install of the recently released beta version.  We had been originally trying to connect a Beta Sharepoint Designer with a Technical preview site.  It is indeed a previous build issue, and finally the MSDN beta is available to test with so we can confirm!
    Our setup is:

    Server 2008 SP2 (chose not to use R2 as the patches are not currently available)
    Sharepoint 2010 Beta
    Jet Li's Walkthrough http://blogs.msdn.com/opal/archive/2009/11/16/installation-notice-for-sharepoint-2010-public-beta.aspx 

    Thanks to all the posts and guidance, much appreciated!
    • Proposed as answer by ConstructiveTim Wednesday, November 18, 2009 4:12 PM
    • Unproposed as answer by Mike Walsh FIN Friday, November 20, 2009 7:19 AM
    Wednesday, November 18, 2009 4:12 PM
  • Tim, I think it's more appropriate to mark Asif's response as the answer, because he gave you this information on November 5th.  I am not sure why it didn't register until now.  He said you have to have the same build numbers, and you somehow had SPD Beta already before it was released when SharePoint Server Beta had not been released for use with SPD Beta.
    SharePoint Architect || My Blog
    Wednesday, November 18, 2009 4:52 PM
  • Hi Clayton,

    That does make more sense.  Thanks Asif! 
    Wednesday, November 18, 2009 9:18 PM
  • Moderator Administration Comment only:

    It was a toss-up but as I'd already un-proposed the "propose as answer" on Asif's first post (because the thread went on and on after that so it didn't seem to be the answer) I "upped" Asif's second post which was proposed by ConstructiveTim. The effect is the same - the thread is marked as Answered and Asif gets the credit.

    Thanks to Clayton for his comment to ConstructiveTim and thanks for ConstructiveTim's proposal of Asif's second answer (which while the same as his first answer in essence also added version numbers so was marginally better than the first answer.).


    (Moderator)

    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Friday, November 20, 2009 7:24 AM
  • I am still having this problem, and I have confirmed that the SPD and SHPSVR versions are identical.
    Friday, September 10, 2010 7:48 PM
  • I have ran in to same problem below is the solution




    Microsoft SharePoint Designer

    An error occurred while trying to fetch data from your SharePoint site. Unexpected response from the server. The content type of the response is "". The status code is "OK".

    The solution is that there can only be 1 binding on a web application. If you have more than 1, it will no longer work and you get this error.
    What you need to do, is to extend your web application (central administration - application management - manage web applications)
    If you open the site of that extented web app, SPD will connect to that site.

    in my case i create another web app with single binding left teh current one as it was instead of all unassigned ip.


    Poorvesh
    • Proposed as answer by Poorvesh Wednesday, October 13, 2010 7:17 PM
    • Unproposed as answer by Clayton Cobb Tuesday, December 28, 2010 9:39 AM
    Wednesday, October 13, 2010 7:17 PM
  • I have ran in to same problem below is the solution




    Microsoft SharePoint Designer

    An error occurred while trying to fetch data from your SharePoint site. Unexpected response from the server. The content type of the response is "". The status code is "OK".

    The solution is that there can only be 1 binding on a web application. If you have more than 1, it will no longer work and you get this error.
    What you need to do, is to extend your web application (central administration - application management - manage web applications)
    If you open the site of that extented web app, SPD will connect to that site.

    in my case i create another web app with single binding left teh current one as it was instead of all unassigned ip.


    Poorvesh


    But this isnt really a solution for most shared environement. I think what you spotted is correct as i am getting the same issue with mutiple bindings on a single web application. How would you cater for DNS hosted site collection where there are many bindings possible on the same web app.

    so i have web application http://hosted.mycompany.com and many dns hosted site collection in that web application

    site collection - http://anothercompany.com in the web application http://hosted.mycompany.com/

    so the first one http://hosted.mycompany.com/_vti_bin/client.svc would work but http://anothercompany.com/_vti_bin/client.svc would not.

    Any help would be greatly appreciated.

    Wednesday, October 20, 2010 11:06 PM
  • Hi guys, I think this will help... I had this error also , and trying to add my IP on the alternate mapping, no way... I tried to erase the IIS default website too because my sharepoint website is on the same port number (80) , no way this error will disappear... Sometimes SharePoint Designer works, and some not ... I didn't find the solution to get an earlier verison of SharePoint designer a great one cause i had to erase all the MS Office too because of incompatibility issues... It was so weird till i found out that IIS didn't start properly when using IIsreset ( I was using it from the "Run" button ) but I never knew ... I tried he cmd command  and then "Run" and there was a service that didn't start "IIS Admin service or World Wide Web publishing service .. failed to start" ... I went to the Services and I found that IIS Admin Service wasn't working. I just started it and the error was gone.
    Static Void Brain !
    Monday, November 29, 2010 1:01 PM
  • I fixed the error doing the following:

    1. In IIS select Authentication.
    2. Select Windows Authentication.
    3. Click Advanced Settings.
    4. Set Extended Protection to Off.

    That's it.

    I can now open my site in SharePoint Designer 2010.
    By the way, I'm using Kerberos.


    egholm
    • Proposed as answer by bayley Thursday, February 24, 2011 8:54 PM
    Wednesday, December 08, 2010 1:47 PM
  • I'm experiencing this same error when trying to use SharePoint Designer 2010 (14.0.5128.5000) on a Windows 2008 R2 Standard virtual (different virtual from where SharePoint resides.)  The odd thing is, I can open the Central Administration site but not the site URL: http://EFACTS-APP-01/Courts/SC/ I get the error message: "The server could not complete your request.  For more specific information, click the Details button."  This error happens at the point SPD is communicating with the web service.  The Message Details is empty.  When I click OK.  I get the further error:  "An error occurred while trying to fetch data from your SharePoint site.  Unexpected response from the server.  The content type of the response is "".  The status code is "OK". "

    The odd thing is I do not get this error when I'm opening SPD 2010 on the Central Administration site.  I can edit that site.

    Thanks for any guidance you can provide.

    Tuesday, January 04, 2011 11:13 PM
  • I am also having the same issue, may be it is due to Kerberos

     

    WebHost failed to process a request.

    Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/42253292

    Exception: System.ServiceModel.ServiceActivationException: The service '/_vti_bin/client.svc' cannot be activated due to an exception during compilation. The exception message is: The authentication scheme 'Negotiate:Kerberos' is not supported.. ---> System.NotSupportedException: The authentication scheme 'Negotiate:Kerberos' is not supported.

    at System.ServiceModel.Activation.MetabaseSettingsIis.RemapAuthenticationSchemes(AuthFlags flags, String[] providers)

    at System.ServiceModel.Web.WebServiceHost.GetAuthenticationSchemes(Uri baseAddress)

    at System.ServiceModel.Web.WebServiceHost.AddAutomaticWebHttpBindingEndpoints(ServiceHost host, IDictionary`2 implementedContracts, String multipleContractsErrorMessage)

    at System.ServiceModel.Web.WebServiceHost.OnOpening()

    at Microsoft.SharePoint.Client.Services.MultipleBaseAddressWebServiceHost.OnOpening()

    at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)

    at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(String normalizedVirtualPath)

    at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)

    --- End of inner exception stack trace ---

    at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)

    at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)

    Process Name: w3wp

    Process ID: 10580

    Thursday, February 03, 2011 6:24 PM
  • I fixed the error doing the following:

    1. In IIS select Authentication.
    2. Select Windows Authentication.
    3. Click Advanced Settings.
    4. Set Extended Protection to Off.

    That's it.

    I can now open my site in SharePoint Designer 2010.
    By the way, I'm using Kerberos.


    egholm
    Just wanted to respond quickly.  Read through and tried all of this with no luck until I got to this post.  This fixed my issue, same one described in the original post.  Just another possible solution to thrown out there that worked for me.
    Thursday, February 24, 2011 8:55 PM
  • What bayley said.  This resolved my issue as well (though in my case, I had to enable "Windows Authentication" as it was disabled) with the added step of performing an "iisreset".
    Friday, April 01, 2011 8:24 PM
  • Hi,

    I am having the same problem That is being described in these posts - I've tried the IIS authentication fix described, but it does not seem to help.

     

    I'm getting the same Error Message as described by MMIDRESS.

     

    Any further intelligence out there on the issue?

    Friday, April 22, 2011 2:00 PM
  • I wanted to try out the SPD myself yesterday on my sharepoint site, and came across this same error.

    ( An error occurred while trying to fetch data from your SharePoint site. Unexpected response from the server. The content type of the response is "". The status code is "OK". )

    Thing is, I'm using a SBS2011 server, and I have not made any changes worth noting down here that can affect the function of sharepoint.

     

    I've tried most of the things I've seen posted here, such as try to connect to a site which has only one binding, this won't work for me either, and I'll still get the same error. I've tried it with a simple http://localhost:portnumber and with a specific host header, either one will still give me the error.

    I've tried to enable kerberos, and add the appropriate provider, enable/disable extended protection. I'm a bit at a loss here.

    The result is the same when trying to run SPD on the server that runs sharepoint itself, or when I run it from a client with Windows 7.

    The version number of sharepoint server and designer are both 14.0.4763.1000

     

    While I usually try to help people on these boards, I actually need some help myself this time.

     

    Kind regards,

    Stephan Schwarz.


    If you one of these posts answered your question or issue, please click on "Mark as answer". If a post contained helpfull information, please be so kind to click on the "Vote as helpful" button :)
    Saturday, April 23, 2011 1:01 AM
  • This solution worked for me :) thanks
    Wednesday, June 08, 2011 9:23 AM
  • I fixed the error doing the following:

    1. In IIS select Authentication.
    2. Select Windows Authentication.
    3. Click Advanced Settings.
    4. Set Extended Protection to Off.

    That's it.

    I can now open my site in SharePoint Designer 2010.
    By the way, I'm using Kerberos.


    egholm

    Thanks, I too had the same problem described by the original poster and this fixed it. Very nice !
    Sunday, August 14, 2011 2:16 AM
  • I have the SAME problem! You got the solution?
    Wednesday, January 04, 2012 1:37 PM
  • I had the same problem with SPD not opening up the my web application.

    In the Event viewer I had the same message MMIDRESS posted about the webhost  failed to process a request. 

    I reviewed this link http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/6720f9f6-fdbb-49ed-ad3f-86806a18663f and that led me to look at Sharepoint's alternate's access Mapping and IIS Bindings.

    In IIS I have 3 bindings to my website.

    http  *                                              80 *

    http computername.mydomain.com 80 *

    http internet-facing-FQDN                80 *

    I changed computername.mydomain.com to just computername and I was able to open up the website in SPD again.

    My alternate access in sharepoint looked like...

    http://computername                         default http://computername

    http://computername.mydomain.com intranet http://computername.mydomain.com

    http://internet-facing-FQDN                 extranet http://internet-facing-FQDN

    I hope this information can helps someone.


    • Edited by Ed Mendez Tuesday, September 25, 2012 6:04 PM typos
    Tuesday, September 25, 2012 6:03 PM